[SOLVED] AnyDVD (HD) 8.5.0.1 beta download link not working.

Discussion in 'AnyDVD HD (Blu-ray issues)' started by KBJ2007, Oct 28, 2020.

  1. KBJ2007

    KBJ2007 Well-Known Member

    See title.
     
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Works fine here

    Sent from my Pixel 3 XL using Tapatalk
     
  3. Matt West

    Matt West Member

    Not working here. Chrome gives an error stating that the EXE cannot be downloaded securely...
     
  4. KBJ2007

    KBJ2007 Well-Known Member

    Using Chrome here as well. Tried Firefox and it worked just fine so apparently, Chrome is blocking it for some reason.
     
  5. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Works in firefox. That said, did some testing. The problem lies with the SSL certificate. Chrome complains its not valid for the sandbox subdomain (hosting the actual file), it seems to load the certificate for the alpha subdomain. @James i tried changing the url you posted from http to https but that doesn't fix the problem. This likely needs manual intervention on the SSL certificate

    @KBJ2007 and @Matt West Please try another browser in the mean time. I can tell you from my end FireFox 82 works fine.
     
    KBJ2007 likes this.
  6. RedFox 1

    RedFox 1 Super Moderator

  7. lifegpc

    lifegpc Active Member

    Sometimes Chrome download exe competely but It don't display the save dialog. ( I don't know why, it occurs when I download AnyStream Beta.)
     
  8. whatever_gong82

    whatever_gong82 Well-Known Member

    I grabbed the file off of Opera, and it downloaded fine.

    Usually, I use either Chrome or Edge (a Chromium based browser), but I like to not stick to just one particular browser.

    I learned my lesson on that with Internet Explorer years ago.

    :)
     
  9. lifegpc

    lifegpc Active Member

    Now I use aria2c to download exe when use HTTP.
     
  10. Ivan

    Ivan Admin Staff Member

    sandbox.redfox.bz has no ssl cert (yet). So if you are trying https;// and force the web server to provide a ssl cert (which is not configured), the server provides the first cert he finds - even if it's the wrong one :)

    I'll set up SSL for sandbox later today...
     
  11. Ivan

    Ivan Admin Staff Member

    Fixed. Added SSL cert to sandbox.redfox.bz and redirect for port 80 > 443.
     
    whatever_gong82 and Aeneas72 like this.
  12. Ghildebr

    Ghildebr Well-Known Member

    you may need to go in to the sticky and change http to https
     
  13. Ivan

    Ivan Admin Staff Member

    URL in sticky should automatically redirect from http to https
     
  14. Ghildebr

    Ghildebr Well-Known Member

    It doesn't for me using Chrome. I can however right click on the link and select "Save link as" and that works.
     
  15. Ghildebr

    Ghildebr Well-Known Member

    Well it works in Edge. Maybe I need to clear my cache.
     
  16. lifegpc

    lifegpc Active Member

    The browser will automately driect to HTTPS because it will receive HTTP 301 Moved Permanently
     
  17. Ghildebr

    Ghildebr Well-Known Member

    Clearing cache did not fix it.
     
  18. Ivan

    Ivan Admin Staff Member

    Chrome behaves sometimes a little bitchy :)
    URL in sticky changed to https :banghead:
     
    whatever_gong82 likes this.
  19. Ghildebr

    Ghildebr Well-Known Member

    I agree about the "bitchy" part. Unfortunately it still doesnt work in Chrome. I do see that the link you see has been changed but look at this screen shot. I still see a http in the code.
     

    Attached Files:

  20. Ivan

    Ivan Admin Staff Member

    Even forum post can be bitchy. It showed URL as https, but "behind the scene" was still http :bowdown:

    Fixed. Finally.
     
    whatever_gong82, KBJ2007 and Aeneas72 like this.