[Solved]1.1.4.1 still stalling...

Discussion in 'AnyStream' started by Electron003, Jun 3, 2021.

  1. Electron003

    Electron003 Well-Known Member

    As the title thread states, 1.1.4.1 is still stalling for long periods of time. During this time task manager shows NO network activity. I did get ONE retry for fragment message in the log, but other than that, nothing from start to finish (that's the log you can see on screen).

    This title was using a vpn, (but others that have done the same thing haven't used one).

    This was a 1:58 min movie that took just under 3 hours to finally finish. While this one did finish, others have not, and I've had to abort.

    For me, this issue is becoming increasingly more frequent. I can watch the titles in a browser (Both with a vpn or not) - without freezing or buffering.

    One thing I have noticed, is that some titles are more prone to this happening than others - like the server node streaming it (probably not the correct term) is slower than some of the other nodes or something, Some titles just will NOT d/l and I've given up.

    AS just doesn't seem to realize that it's stalled. The 2nd title for today (currently in progress) has been sitting at 31% for almost 30 mins (no network activity via task manager). So I C&P'd the video link into a browser and it d/l'd without issue without making any changes to the current settings (even on a vpn). This seemed to stoke AS into action and it showed network activity again (probably a coincidence) for a minute or so (now 34%) and it has now been stalled again for the last 15 mins. The onscreen log shows nothing. Update: so after 25 mins @34% AS suddenly just started some network activity again. So far this title has taken 1 hour to get in 39% for a 1:45 hour title @ 2x speed.

    I sincerely hope this is an issue that can be resolved. One day to get one or two titles is not very user friendly.
     

    Attached Files:

  2. Prospere

    Prospere RedFox Development Team

    Thanks for the log!

    What I see is that there are queued fragment requests that are not being replied in time. For example, some of them were more than 3 minutes old. However, the fact that there was no timeout ever suggests the data being slowly dripped in.

    This does not mean the situation is OK, though. We're looking into it.
     
    StevenIvan and DeepSpace like this.
  3. Electron003

    Electron003 Well-Known Member

    That would be very good. Thank you.
     
  4. Electron003

    Electron003 Well-Known Member

    Here is another one. AS stalled at 76% for approx 37 mins until I aborted it. (no vpn). There was nothing in the oncreen log after the initial "Starting"

    Using 1.1.4.0 (1.1.4.1 failed to launch fully and I was getting a white screen within the AS browser -> so reverted.) I notice 1.1.4.2 is out, so I'll give that a go.
     

    Attached Files:

  5. Electron003

    Electron003 Well-Known Member

    Another one that took just shy of 3 hours to d/l (vpn ->yes). The title was only 101 mins long. Started the process at 2:06pm and finished at 17:00. Set at 2x speed.

    It dribbled slowly along on and off until 72%. It sat there for 30+ mins, then started again after a fragment retry kicked the system into action again. It ran perfectly until 86%, where it petered out, then dribbled along until 92% and sat there for about 40+ mins. The onscreen log showed nothing except for one retry for fragment. It finally completed.

    The really frustrating part here is that in this case, I was watching the same movie in a browser at the same time. It never froze, or buffered once during its run and completed just as one would expect -> all over the same single vpn stream. See log.
     

    Attached Files:

  6. Prospere

    Prospere RedFox Development Team

    Not quite sure VPN may be the problem here. I am working on this problem.
     
  7. Pete

    Pete Forum Admin Staff Member

    Can you please try 1.1.4.3?
     
  8. Electron003

    Electron003 Well-Known Member

    Been testing 1.1.4.3 all day.

    Now...I have changed region...so it's not the same as yesterday, but I can report it is working very well in the current region. Probably better than it has worked in a long time (for me at least). While it does slow down to small network figures (this seems normal though), it seems to be much more consistent overall, and perhaps even faster. Perceptions are difficult to map to reality at times ;)

    So...thanks for the effort. It is very much appreciated.