Several Games That Appear Not to Work

Discussion in 'GameJackal' started by ShadowDestroyer, Jun 13, 2007.

  1. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    13. Describe your problem, provide full error messages, and please state clearly what you were doing when you received those error messages.
    I have 3 games in which I cannot get to work. These games are: Diablo 2: Lord of Destruction, Starcraft: Brood War, and Age of Empires 3: The Warchiefs. According to the working thread however, Diablo 2: Lord of Destruction works fine. Perhaps the problem lies in that they are all expansions. When I set up Warcraft 3, they had me run it with the original disc, however the original disc does not normally start the program.

    Perhaps I am setting up the programs incorrectly. But I tried starting the game multiple times like the FAQ suggested, but I still am not able to start the games without a CD.

    If you could provide a solution to the issue, or perhaps an update, it would be greatly appreciated.

    1. What version of Game Jackal are you running?
    Main Version: 2.9.18.550
    Driver Version: 2.9.18.505

    2. What Operating system are you using? 64 bit? service pack?
    Windows Vista Ultimate 32-Bit

    5. What protection does your game use?
    Age of Empires 3 The Warchiefs: SmartE (I don't see a version)
    Starcraft Brood War: No Protection or Unknown (The game is almost 10 years old, so I suspect it has no protection)
    Diablo 2 Lord of Destruction: No Protection or Unknown (Also very old game)

    6. What is the name of the game you're trying to run?
    Age of Empires 3 Expansion: The Warchiefs
    Starcraft Expansion: Brood War
    Diablo 2 Expansion: Lord of Destuction

    7. What is the version of the game?

    AoE3x: 1.03
    SCx: 1.15
    D2x: 1.11b

    8. Is it cd or dvd version?

    All: CD

    9. What region or country is the original disc from?
    All: United States

    10. What cpu are you running?
    AMD Athlon 2600+

    11. What optical drives (dvd-rom,cd-rom, burners) are you using to create profiles with? What firmware version is installed on your reader?
    SAMSUNG CD-R/RW SW-252F ATA Device
    6.0.6000.16386

    12. What security software (firewall, antivirus) are you using? Please provide version numbers.
    Norton Internet Security 2007 (All updates as of June 13, 2007)
    Spy Sweeper 5.3.2
     
    Last edited: Jun 13, 2007
  2. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    Is everyone stumped, or is SlySoft investigating the issue?
     
  3. Loonie

    Loonie Well-Known Member

    I've had no problems at all with Diablo II or its expansion. I just built a completely standard profile, let it capture up to the menu screen, and that was all it needed. Sorry, not helpful I know.

    Starcraft is an odd one. I use a specific launcher program for it, and I have setup.exe (the 500 MB file from the CD) copied locally. I also have the registry path pointing at it. In fact, I have both the setup files copied from both the original SC CD and the Broodwar CD. I renamed them, and I have a batch file that renames the required EXE file to setup.exe depending which one I want to play. I can supply you more details on how to do this if you wish.

    As far as using GJ is concerned, yes it will work, but you will need to use the image mode when you create your profile. It will need to capture the whole CD, because regardless of the path in the registry, once SC detects the CD (or the profile), it is from that location it will try and read the resource file (setup.exe).

    Addiionally, if you wish to play the original SC, you will need to create a separate image profile for that CD.


    I'm afraid I cannot speak for AoE3 as I don't have it.
     
  4. Danger

    Danger Well-Known Member

    Question is do you have any other games running with GJ under Vista Ultimate?

    I ask this because I have only been able to get 1 game working with GJ & Vista Ultimate, Star Wars - Empire at War : Forces of corruption.

    However all games but one of mine so far, ParaWorld which is Tages protected, do work in XP. Among these are Age of Empires III (I don't have the expansion) & Starcraft - Broodwar.

    Out of 12 games on Vista only 1 works with GJ as opposed to XP where only 1 of the 12 don't work with GJ.

    Currently I have migrated 2 of my computers back to XP because they are mainly gaming computers which my stepsons play on alot, but am holding back on mine in hopes Slysoft can get this straighted out sometime soon and I take better care of the discs than they boys do:D
     
  5. Loonie

    Loonie Well-Known Member

    For some reason, I missed that "Vista" bit. So that's even less help. That's what you get for quickly scanning forums at work. I have no idea what to suggest about Vista.
     
  6. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    Heh, I guess I just need a vista update. BADLY! Good luck slysoft! :p
     
  7. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    The question is... WHY does vista cause problems? If they can figure that out, they have a massive number of bugs fixed... I hope they do fix it (well, I suppose they will have to, considering vista will become more popular than XP eventually), because it really hurts the useability of the program.

    I do want to say this... Warcraft 3 Frozen Throne does work, probably because it is a built in profile. Perhaps this means it is the portion that scans that doesn't work properly... Possibly to vista's new security stuff?

    Can I get a confirmination from a mod that SlySoft is aware of the issue?
     
    Last edited: Jun 16, 2007
  8. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    Ok, new issue... With the release of the new version, Age of Empires 3 - The Warcheifs on vista no longer complains for a CD. Instead, the game never starts.
     
  9. JeffChandler

    JeffChandler Member

    I have a suggestion for Diablo 2: LOD owners:
    Be sure to copy the missing .mpq files from the LOD disk to your diablo directory. Even on a full install, not all the files are copied over. ;)
     
  10. sickley

    sickley Active Member

    the problem with vista is that they "solved" the all the problems of all previous versions of windows. they created vista literally from the ground up, it has NO legacy coding in it, thus many programs that worked in xp will probably not work in vista, untill the program gets patched. so when slysoft updates the xp version of gj they have to do a lot more work still in order to get everything up and running with vista. my guess is they are still just a little behind, once they catch up there will be fewer problems :eek:
     
  11. sickley

    sickley Active Member

    i imagine this will be the same for all (previously) released games from blizzard. they all use basically the same style of .mpq files. so owners of diablo II, starcraft, and warcraft III need to make sure all your .mpq's and .dll's are in your folder.

    hope that solves the problem!! :agree:
     
  12. HunterB

    HunterB New Member

    Can you tell me exactly what settings you used to build the profile? Do you still have to keep the play disc inserted? I am unable to get the profile to work.

    Thanks,
    Hunter