Saawariya not playing

Discussion in 'AnyDVD HD (Blu-ray issues)' started by DMR, May 8, 2008.

  1. DMR

    DMR New Member

    I am unable to play Sony's new Blu-Ray release - Saawariya - which was released on May 6th.

    I used AnyDVD 6.4.2.0 and it's "Rip Video DVD to Hard Drive" function to make a backup onto my hard drive. I used ImgBurn to create an ISO. When I mount the ISO on a virtual drive and play with PowerDVD 8, it plays only upto the menu selection. Selecting Play from the Menu or going into chapters and choosing a chapter, both actions freeze up PowerDVD and I have to kill it.

    I also tried having AnyDVD in the background and using ImgBurn's function to create an ISO from Disc. Both ISO versions act the same - freezes up PowerDVD.

    I have other Blu-Ray DVD backups created both ways that work fine.

    Could you help please.

    Thanks.
     
  2. scribe5

    scribe5 Member


    I don't know if I have the answer, but I was able to copy that disk and play the image with no problems. Used latest beta of AnyDVDHD, and ImgBurn to create ISO. I mounted with Daemon Tools and Played with PowerDVD 8, with its latest patch. This under XP and 8600gt vid card, using 163.75 driver. I could play, pause, skip chapters and access menu with no issues.
     
  3. Adbear

    Adbear Well-Known Member

    Have you tried playing the original to see if that works?
     
  4. DMR

    DMR New Member

    Thank you for your feedback.

    The DVD plays on an external Blu-Ray player with no problem.

    When I insert the original disc in the PC's Blu-Ray Drive, PowerDVD 8 encounters the same issue and freezes in the menu when a selection is clicked. WinDVD 9 plays the movie without any problem.

    However, I have never been able to get WinDVD to play any of images mounted onto the virtual drive. I use Slysoft's Virtual Clone Drive to create the virtualization.

    I updated PowerDVD with the patch that is referenced in these forums, and I installed AnyDVD's latest beta release as well and recreated the ISO - but - no luck :-(

    At this point, it looks like it is a PowerDVD issue - doesn't it?