[S] Firmware 1.02 for LG BH16NS55

Discussion in 'CD/DVD/BD Drives' started by Grawp, Jun 21, 2018.

  1. SamuriHL

    SamuriHL Retired Moderator

    Yup, that looks correct. There's almost no risk of perma-bricking the drive because it's using the built in update process. Dosflash whacks the entire eeprom which is why it's considered dangerous. The patched windows flashers do not do that. To be clear, there's always a risk involved, but, it's no more risky than running an official update.
     
  2. MartyMcNuts

    MartyMcNuts Well-Known Member

    @SamuriHL seems to have gotten a little confused here. A BH16NS55 with 1.03 can be downgraded normally using the modifed ASUS flasher. Firmware 1.04 is the crappy one that has disabled DOSFLASH and the normal downgrade method. This can be currently be overcome by using the modified ASUS flasher to flash firmware ASUS 3.10 MK first, then you can downgrade to LG 1.02 or whatever other firmware you choose.
     
    whatever_gong82 and SamuriHL like this.
  3. SamuriHL

    SamuriHL Retired Moderator

    Ahhhhhhhhhhh damnit you're right. I forgot it was 1.04 not 1.03. Man there's too many drives and firmware out there! So yes, follow what Marty says!!!

    (P.S. I hope to hell we can get 1.04 to Mike at some point so the MK 3.10 step isn't necessary for that drive!)
     
  4. MartyMcNuts

    MartyMcNuts Well-Known Member

    Yep, Mike successfully obtained 1.04 from my drive yesterday. Now, we need to give him a few days to hopefully come up with something.
     
    whatever_gong82 and SamuriHL like this.
  5. SamuriHL

    SamuriHL Retired Moderator

    Perfect! That'll be good to have in the bag for future drive owners.
     
  6. MartyMcNuts

    MartyMcNuts Well-Known Member

    Yep, sure would. Hopefully he can also figure out how they disabled DOSFLASH.
     
    whatever_gong82 and SamuriHL like this.
  7. SamuriHL

    SamuriHL Retired Moderator

    That'd be nice. I'd like to have it re-enabled "just in case". Not that my new PC has IDE mode on the sata ports. SIGH.
     
  8. teckau

    teckau Member

    Hi guys,

    I am having trouble. I am connecting my BD drive via SATA to USB3 and attach it to my Win10 notebook. But the patched installer does not like the drive. Am I mistaken somewhere? BH14NS40_N1.00-A4_patched.exe is the patched installer, right? Anything I have to take into account that is missing right now?

    And again THX SO MUCH!
     
  9. SamuriHL

    SamuriHL Retired Moderator

    Goes back to what I said originally that *IF* your USB enclosure supports flashing.....not all of them do. When you say "does not like the drive" that's not super descriptive about what's happening when you try to flash.
     
  10. coopervid

    coopervid Well-Known Member

    It's more than 90% likely that your SATA ->USB chip set / firmware doesn't support flashing optical drives. Any chance to take it out and connect it to SATA directly?
    Sometimes you can also update the firmware of the SATA-> USB chip set but this is even more complicated.
     
  11. teckau

    teckau Member

    Sorry for not being descriptive. When I said "does not like" I mean that the tool does not recognise the drive even if Windows does. But that's what you've said, most likely my USB chipset is crappy.

    So I found myself an old DELL mini PC (160) that theoretically should help. SATA ports, BIOS has ATA option. Unfortunately the first SATA port is not usable (mounted in a way that you need a cable I don't have) and the second port can only hold a boot drive OR my BD drive.

    Any idea how I could build a USB pen drive or anything like that for booting that includes the tool? If I could boot the computer using something that is NOT a SATA HDD drive I could probably help myself out of this...
     
  12. SamuriHL

    SamuriHL Retired Moderator

    No no no no. None of that IDE crap. LOL That's not necessary nor is connecting it to the first SATA port. That's only for dosflash which we're not doing here. And yes, you can absolutely build a WinPE instance to do this flashing no problem.

    https://www.aomeitech.com/pe-builder.html

    Use that and you can throw the firmware flashing tool and the firmware on it and you should be good to go. No dosflash! :)
     
  13. teckau

    teckau Member

    Oups, right, the IDE part was only for the unwanted dosflash. It's already a little late for me. I've downloaded the PE builder and now I've to go to bed. Tomorrow in the morning I am going to try it out. That looks like a good chance...
     
  14. teckau

    teckau Member

    Ok, I could not sleep and went back to give it a try: It worked and I am VERY grateful that you guys were super helpful and patient with me!

    For those looking for an answer here's my story:

    Bought a LG BH16NS55 that came with 1.03 firmware. Had just a notebook. Bought a SATA/USB3 adapter, too. But no cigar updating the firmware through the USB connection. Got an old PC that had no usable second SATA (the one and only had to be used for the BluRay drive). Got myself a pen drive, downloaded the PE Builder exe, created a PE bootable usb drive and added the tool (patched flashing tool) and the necessary firmware files during the setup process so they were IN the Windows PE. Bootet the PE -> started the flashing tool -> update to MK firmware 1.03 -> no reboot -> directly downgraded to the DE image 1.02 and shutdown the PC.

    After that I connected the BluRay drive to my Windows 10 notebook where I got MakeMKV installed and it detected my drive (1.02!) and started ripping my disc w/o any problem. As I am not looking for PLAYING movies through that drive I am not testing this anytime soon. But for ripping it's perfect.

    One word on MacOS: Before connecting the drive to Windows 10 I tried it on my 2015 Retina Macbook. MakeMKV was somehow seeing the drive (worked sometimes and sometimes not) and I could NOT start the backup process. I got some "Error 'OS error - (ipc/send) invalid destination port' occurred while reading '/AACS/Unit_Key_RO.inf' at offset '0'" messages. If I can find that problem I will report.


    Again: Thank you guys soooo much! I appreciate your help! Best regards from Germany!
     
    whatever_gong82 and SamuriHL like this.
  15. SamuriHL

    SamuriHL Retired Moderator

    Glad you got it working!
     
    whatever_gong82 and RedFox 1 like this.
  16. Lazaros Velaetis

    Lazaros Velaetis Active Member

    Gday i just bought the LG bh16ns55 but it came with firmware version 1.04! dosflash says it unrecognized flash chip is there an update or is it already compatible or not??? haven't tried it yet was going to flash it first off the bat...
     
  17. MartyMcNuts

    MartyMcNuts Well-Known Member

    Please don't use dosflash. Grab the modified flasher and firmware from this thread.

    https://forum.redfox.bz/threads/new...h-using-official-modified-asus-flasher.76571/

    Grab the MK firmware pack from here. https://www.makemkv.com/forum/viewtopic.php?f=19&t=19113

    STEPS:

    1. Use the modified flasher to flash firmware ASUS BW16D1HT 3.10 MK
    2. Once the flash has completed, you can then flash whatever firmware you want to use.

    Easy Peasy!!

    Cheers!
     
    SamuriHL and whatever_gong82 like this.