Rip Blu-Ray with Panasonic SW-5582

Discussion in 'AnyDVD HD (Blu-ray issues)' started by Dopey, Apr 12, 2007.

  1. Dopey

    Dopey New Member

    I've searched and searched, but I couldn't find a clear answer as to rather or not AnyDVD HD supports this drive. I know this drive is region locked and there is no current way to circumvent that, but that is not an issue for me. My drive is locked to Region 1 (that's all it says in the device properties, not A just 1) and I'm only trying to rip US movies. I don't really have much of an interest in foreign films.

    I'm able to load my test movie, Stargate, and AnyDVD correctly sees the drive and movie (with the region stuff disabled for AnyDVD as it won't work on this drive). It says the drive is region locked to 1, as expected, and it detects the AACS encryption and says it removes it. All seems good until I actually try to rip it and it fails with the error message that says, the disc may be dirty... drive may be region locked...etc.

    I checked the filters and the only things filtercheck finds is for AnyDVD and CloneCD. No other filters were detected.

    Has anyone successfully used the Panasonic SW-5582 drive to rip Blu-Ray discs?

    I have to note one thing that may be causing the problem. I'm using a USB 2.0 external drive case. In theory this should work fine... in theory anyhow...
     
  2. roog

    roog Well-Known Member

    Read Slysoft guru James's comments about Panasonic (aka Matsushita) drives. You can do this by searching the AnyDVD HD thread for Matsushita and Panasonic.
     
  3. Peer

    Peer Redfox Development Team Staff Member

    The region-locking of that drive only refers to DVDs not BDs (that is also the reason why it says 1, not A).
    Drives cannot be locked to a BD region, only players. So this rules out the region coding as the source of the problem.

    Other question: have you ripped other discs than the one you mentioned? There are a few trouble-makers among latest BD discs, that actually have mastering errors - although I wouldn't conclude that your problem is one of those...
     
  4. Dopey

    Dopey New Member

    roog, I did search. As I said in my post I did find references to this drive being region locked, but I didn't find anything about it not being able to rip Blu-Ray discs. If you know of a post that I missed I'd greatly appreciate a link.

    peer,
    thank you much on that info on region locking. I guess I was completely confused... Anyhow, I guess that has nothing to do with the problem... but if it doesn't the why does AnyDVD mention it in the status?

    Come to think of it this clarification on the region coding reminded me of something else I noticed while trouble shooting. Windows Device Manager recognizes it as a DVD-RAM drive. I'm not sure if that's normal or not, but it does get the model number correct, so I found it hard to believe that it was abnormal. If it is abnormal then that would explain why AnyDVD mentions the DVD region lock in the status when a Blu-Ray disc is entered.

    I haven't tried any other discs, but Stargate is one I know has been ripped before and it's an old one. I can try to get some more Blue-Ray discs to test with, but it would be a few days...

    Here is the exact output of the status:
    Summary for drive J: (AnyDVD 6.1.3.3)
    MATSHITA BD-MLT SW-5582 BXC3 06/23/06XC3B
    Drive (Hardware) Region: 1

    Media is a Blu-Ray disc.
    Total size: 11667904 sectors (22788 MBytes)
    Video Blu-Ray label: 15027930_00000005_STARGATE
    Media is AACS protected!
    Removed AACS copy protection!
     
  5. Dopey

    Dopey New Member

    I just upgraded AnyDVD and tried another Blu-Ray disc (The Fantastic Four) and I had the same problem...
     
  6. rozas

    rozas Member

    I had no problem with this drive and 4 titles included dual layer like hellboy & C. royale (spanish marketdisks) just with the last one xmen3 I couldn't

    regards