"Rewinding" provokes a later playback freeze.

Discussion in 'AnyDVD HD (Blu-ray issues)' started by markfilipak, Sep 8, 2018.

  1. markfilipak

    markfilipak Well-Known Member

    AnyDVD HD v.8.2.7.0.
    BD player: PowerDVD-10.
    BD source: Commercial BD movie disc.
    OS: Win-7 SP3.

    Scenerio: At point 'x', I "rewind" a few seconds to replay some dialog. A few seconds later, playback once again reaches point 'x'. I continue playback. A minute or so later, playback freezes for a few seconds. I hear the BD drive seeking. When playback resumes, audio resumes but video remains frozen. A few seconds later, video resumes -- the audio & video are now both playing & are in sync.

    This only occurs when AnyDVD is ON (enabled). When AnyDVD is OFF, "rewinding" doesn't cause any freezes.

    I visualize an AnyDVD video buffer underflowing causing PowerDVD's buffer to underrun.

    Is there something I can do to "help" AnyDVD?

    I've got plenty of memory. The computer is a "retired" laptop that I've dedicated as an HDMI source to "feed" my home theater.

    Warm Regards,
    Mark.
     
  2. David_B

    David_B Well-Known Member

    Minor detail, but there's no such thing as Windows 7 Service Pack 3. ;)
     
  3. markfilipak

    markfilipak Well-Known Member

    Hmmm... Let's see. Maybe I'm running Win-XP SP3? No, it's Win-7 Home Premium with SP1. That computer is running my home theater, and I haven't used it as a general computer for some time. My bad. My point is that it doesn't have anything else to do, so I can devote a ton of memory to its processes. It's a Core i5 with 4 threads @ 2.4GHz & 6GB of RAM.

    So, tell me, David B, do you know of a fix for what I guess is a buffer problem?

    PS: I just checked it with Process Explorer. Running PowerDVD, the computer is using only 1.2GB of that 6GB of RAM. So it appears I could allocate some serious buffers if, A, I knew how to do that, and B, I could get AnyDVD to use them wisely.
     
  4. David_B

    David_B Well-Known Member

    I have no idea what is causing your problem, and my setup is not anything like yours, so unfortunately I really cannot try to reproduce the problem. (Running Windows 10 1803 with PowerDVD 18.)

    Have you tried using another player such as VLC or tried playing something in PowerDVD without AnyDVD running?
     
  5. markfilipak

    markfilipak Well-Known Member

     
  6. David_B

    David_B Well-Known Member

    Oops. My bad. Even so, have you tested with VLC?
     
  7. Bubbator

    Bubbator Well-Known Member

    Using win 10 and pdvd 17 I've always had the same issue--even when just pausing. When I use kodi for a problem disc I've never noticed the same behaviour. Of course I never tried exiting anydvd. So it may be pdvd to blame.
    B
     
  8. markfilipak

    markfilipak Well-Known Member

    Howdy, Bubbator. Try exiting AnyDVD (or simply un-enabling it in the task/notification area) and see whether the issue goes away. Kindly report back, would you?
     
  9. markfilipak

    markfilipak Well-Known Member

    VLC has too many bugs. I use it only to take BD screen shots.
     
    Last edited: Sep 9, 2018
  10. Bubbator

    Bubbator Well-Known Member

    Exiting anydvd produced a 1 or 2 second black out instead of the freeze in pdvd.
    B
     
  11. markfilipak

    markfilipak Well-Known Member

    Blackout? Wow. Can you compare it to the freeze? For example, my freezes sometimes last 10 or 15 seconds. The minimum I've experienced was about 5 seconds. A 1 or 2 second blackout would be an improvement for me.
     
  12. Bubbator

    Bubbator Well-Known Member

    Oh heavens! 5 seconds would be a Max. And it stutters more than freezes. The black out was with anydvd off.
    B
     
  13. testiles

    testiles Well-Known Member

    I've always found rewind and fast-forward in PDVD to be a little sketchy.

    Especially if you're reading directly from the disc.

    That's why I always use .iso's to play movies in PDVD.


    And even then, I usually click points on the "timeline" at the bottom of the PDVD screen to move around, even if just for a quick "rewind".

    It's much more responsive than the actual rewind function...

    But maybe in your case, you are using a remote instead of a mouse?


    T
     
    Bubbator likes this.