RESOLVED: Dolby Vision does not work with UHD discs

Discussion in 'CloneBD' started by coopervid, Mar 10, 2019.

  1. coopervid

    coopervid Well-Known Member

    UPDATE 02.04.2019: I received from Pete the version 1.2.4.7 and tested. Well, this resolved it partly. No more bleached out colors and the TV showed "HDR". Next I tried with the newest beta 1.2.4.8 and: Voila! TV shows now not only "HDR" but "Dolby Vision".
    Case closed. Thanks a bunch to everybody, especially Pete and the Elaboratebytes team :dance::thankyou::coolman:.

    First I had the thread for "2001". Picture extremely pale, DV doesn't get enabled on my LG UP 970.

    Now I have 2 other discs with the same symptoms. " Skyscraper" and "A star is born". I had never issues like that in the past. "The Meg" plays perfectly in DV and was compressed to 50 Gb disc using NVIDIA drivers from January, AnyDVD 8.3.3.0 and CBD 1.2.4.0.

    The new discs I tried with AnyDVD 8.3.4.0 and all versions of CBD from 1.2.4.0. to 1.2.4.6. No DV.

    So I decided for tests to roll the NVIDIA driver back to 384.76, CBD to 1.2.3.0 and AnyDVD to 8.3.3.0.
    No success. Same result. No DV. Therefore my conclusion is that nothing is broken with the newer programs or the NVIDIA driver in the meantime but something is different on these new discs concerning Dolby Vision itself.
    I know that it is asked for much but most likely you guys at Elaboratebytes should get an LG UP970 and one of the discs mentioned above to see the issue yourself - unless you have an idea what the nature of the issue could be.
    I can also provide CBD logs of my trials if you like. Just let me know which combination of the programs you would like to see.
     
    Last edited: Apr 2, 2019
  2. James

    James Redfox Development Team Staff Member

    Did anything else change? Firmware version of player, receiver, TV?
    Do the original discs play correctly?
     
  3. kufo

    kufo Well-Known Member

    Strange coopervid ... :confused: I was hoping that you would succeed with your experiments. It seems there but a problem of the player with newer films to give. Meg works, but the 2001 in 4K appeared about a month earlier (11/18).
    There is a software-based problem already obvious.
    The Sony 700 and the Panasonic 9004 play the copy with DV.
    Something seems to prevent DV detection on your copy. It is probably related to the graphics drivers, but probably has different effects than my problem.
    I'm happy with CBD since the update to 1.2.4.6.
    Now that the driver is recognized as the culprit, one should probably do research in this direction. On the other hand - An error with DV is perhaps not as clear to find, as my general playback error from the German forum.
    L. G.
    KUFO
     
  4. coopervid

    coopervid Well-Known Member

    @James ,

    there was no firmware update recently for any of my components.

    Yes, putting in the original discs I get right away the "Dolby vision" info in the top right corner with all of these discs. Nothing with the copies and colors are very light. If you like I can take some pictures and upload them.
    A star is born and 2001 are Warner Brothers movies. Skyscraper is Universal. The Meg (which works) is also Warner Brothers.
     
  5. coopervid

    coopervid Well-Known Member

    @James ,

    let's rule out any new firmware of the components. The logic is: The copy of "The Meg" still plays with DV.
     
  6. James

    James Redfox Development Team Staff Member

    Can your player stream over the network? What happens, if you play the largest m2ts from the CloneBD copy via a network share?
     
  7. coopervid

    coopervid Well-Known Member

    I never tried that. But I'm currently checking something different. I'll let you know then....

    I am also not sure if streaming the m2ts would help. As far as I know there are 2 video streams in parallel. The video per se and a second containing the DV information. So I would just stream the video but nothing would look at the DV data to adjust the picture accordingly. Why do you think that streaming the m2ts video will bring us forward with this issue?
     
  8. James

    James Redfox Development Team Staff Member

    You should at least see HDR-10 with correct colors. Maybe even DV (the second stream is inside the same file). It would rule out problems with the encode itself.
     
  9. coopervid

    coopervid Well-Known Member

    Be patient. I will try other things first. Even if streaming would work, it wouldn't help me with discs.
     
  10. coopervid

    coopervid Well-Known Member

    So...

    I'm not a believer- The Monkees. Pardon me to corrupt that Sixties song.

    I don't like your competitor very much and I feel really at home here since many years. But their program made a 50Gb copy of "A star is born" from a 8.3.3.0 AnyDVD ISO with DV working.

    Let me know which files to upload to compare. I think this also rules out any factors that could be related to my soft- or hardware. Like said- this disc was "A star is born". I will continue to check "2001" and "Skyscraper" but my guess is that both will work as well.
     
  11. coopervid

    coopervid Well-Known Member

    "Skyscraper" also works OK as a 50 Gb copy with Dolby Vision using your competitor's program.

    Let me know how I can be of any help fixing this.

    Tomorrow I will check "2001". All this testing needs a heck lot of time.

    Please note. I'm currently on NVIDIA 384.76 and CBD 1.2.3.0 and AnyDVD 8.3.3.0 from my trials. If you send me a beta and let me know the program versions to combine with I will for sure do the tests for you. I don't care if some coasters are the result. We need to made progress here.
     
  12. James

    James Redfox Development Team Staff Member

    You could try to play a CloneBD created m2ts file via network or USB stick.
     
  13. James

    James Redfox Development Team Staff Member

    Is your player able to read BD-RW discs? You could just create partial copies.
     
  14. coopervid

    coopervid Well-Known Member

    James,

    unfortunately I never bought BD-RE discs. But burning is limited to 2x speed anyway and therefore very slow. And I don't own a streaming box.

    The player and the AV receiver both don't accept video via USB. It seems my TV does. Will check later if it can play m2ts files, first from regular BD movies and if it works then from UHD movies. I'll let you know.
     
  15. coopervid

    coopervid Well-Known Member

    The videos from both programs play. TV shows "HDR" for both and they are identical regarding quality and color.

    Just to be more precise: The videos played are both after compression to fit on a 50Gb disc. So it seems CBD retains the HDR information as well in the m2ts file but if burned on a disc there is some glitch that makes the video pale using CBD.
     
    Last edited: Mar 11, 2019
  16. coopervid

    coopervid Well-Known Member

    @Reto , @Pete and @Fabian and @James

    I'm really disappointed to not get even an reaction to my tests that costed me a couple of coasters worth at least $40 starting with issues with the 2001 UHD. I offered my help to even create more coasters going forward. But you are just mum right now. If you are working on this - please let us know. If you need me to be a Alpha-tester for some experiments - let me know. But the worst is to just not even say: Hey, I acknowledge that there seems to be an issue and we are working on it.

    Another suggestion: Why don't you establish a circle of well known users with well known positive contributions as Alpha-testers before you publish the Betas?
     
    whatever_gong82 and kufo like this.
  17. kufo

    kufo Well-Known Member

    Good point
     
    Last edited: Mar 12, 2019
  18. Robert Ylvestedt

    Robert Ylvestedt New Member

    @coopervid you should really invest in some BD-RE DL discs.. Sure they are a bit expensive but they are essential for testing. Me.. I couldn't live without 'em. :)

    //LD
     
  19. Pete

    Pete Forum Admin Staff Member

    Absolutely - one already does the trick, at least for testing.
     
  20. Pete

    Pete Forum Admin Staff Member

    Sometimes, they guys just actually work (frantically!) on the software instead of loitering around in the forum. You can't expect them to answer daily - they are not support staff, they are the developers.
    Plus: yours is not the only topic.
    A bit more patience, please.
     
    whatever_gong82 and eviltester like this.