Replicas has multiple, multiple playlists

Discussion in 'AnyDVD HD (Blu-ray issues)' started by kzajac, Apr 16, 2019.

  1. kzajac

    kzajac Active Member

    Replicas has multiple (over 100?) playlists showing when opened in CloneBD
     

    Attached Files:

  2. coopervid

    coopervid Well-Known Member

  3. James

    James Redfox Development Team Staff Member

  4. coopervid

    coopervid Well-Known Member

    Oops,

    I didn't check the log but the subject didn't say anything if it's DVD or BD. Sorry!
     
  5. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    @Pete will need to fix the screenpass

    Sent from my Nexus 6P using Tapatalk
     
  6. Pete

    Pete Forum Admin Staff Member

    Now it should be fine, try again, please.
     
  7. testiles

    testiles Well-Known Member

    Pete,

    If I play my protected .iso of Replicas in PDVD it plays fine, no problem.

    However if I play it in JRiver, I get the Blue Screen of "You have a copy protected disc, yada, yada....".

    I take that to mean the AnyDVD fix for the title is not working for JRiver?


    Attached my log file...



    T
     

    Attached Files:

  8. Pete

    Pete Forum Admin Staff Member

    The AnyDVD fix corrects the logic in BD-J, so it should work 100%.
    I can't say anything more - I don't have that disc or ISO.
     
  9. SamuriHL

    SamuriHL Retired Moderator

    Does that mean it's potentially a bug in libbluray's bd-j implementation?

    Sent from my Pixel XL using Tapatalk
     
  10. gameowl

    gameowl Well-Known Member

    I made a backup up copy of Replica on 1080p bluray disc using AnyDVD HD and CloneBD. Just got done watching the movie. Played completely fine in my Sanyo player. AnyDVD HD selects before ripping in the status windows 375 for the good playlist and CloneBD in the software shows 375 for the main movie. Both are correct, 375 is the correct playlist.
     
  11. gameowl

    gameowl Well-Known Member

    I made a backup up copy of Replica on 1080p bluray disc using AnyDVD HD and CloneBD. Just got done watching the movie. Played completely fine in my Sanyo player. AnyDVD HD selects before ripping in the status windows 375 for the good playlist and CloneBD in the software shows 375 for the main movie. Both are correct, 375 is the correct playlist. This is for US North America movie
     
  12. testiles

    testiles Well-Known Member

    Hi gameowl.

    There's no doubt that, after Pete's fix, AnyDVD indicates the correct playlist for this movie.

    It's just not working when you play the movie with JRiver Media Center.


    T
     
  13. Lukas

    Lukas Well-Known Member

  14. Pete

    Pete Forum Admin Staff Member

    It turned out, that the cause is, indeed, a slight deviation from the BD-J specification in JRiver Media Center's implementation.
    A fix was added to the latest AnyDVD version to hide this deviation from the code on the disc.

    I am pretty certain, that roughly 40 to 60 different other Screen Pass titles are also affected, maybe even more.
     
    whatever_gong82 and SamuriHL like this.
  15. SamuriHL

    SamuriHL Retired Moderator

    Thanks for adding that. I wonder if it's a good idea to bring this to j river's attention and get their bd-j implementation fixed?

    Sent from my Pixel XL using Tapatalk
     
  16. James

    James Redfox Development Team Staff Member

    Certainly. AFAIK Pete has already done it.
     
    whatever_gong82 and SamuriHL like this.
  17. SamuriHL

    SamuriHL Retired Moderator

    Awesome!

    Sent from my Pixel XL using Tapatalk
     
  18. testiles

    testiles Well-Known Member

    Thanks Lukas.

    I think 8.3.5.1 included Pete's fixes but as of right now, still not quite working for me.

    Working with Pete to resolve the issues...


    Pete indicated to me he was contacting JRiver.

    From what I understand, the issue is really on their end and AnyDVD is trying to side-step it.

    Maybe they will fix their end and maybe they won't.

    TBD.



    T
     
    whatever_gong82 and SamuriHL like this.
  19. testiles

    testiles Well-Known Member

    So, nothing wrong with Pete's fix.

    Something wrong with my cranium (lol).

    I was rushing to test this and mistakenly used an unprotected .iso created from the previous release.

    Even AnyDVD's magic can't fix an .iso with protections already removed. That horse has left the barn!


    Once I mounted a protected .iso, so that the new fixes could be applied, I was able to play the movie farther than before without any ScreenPass issues.

    Haven't had time to watch the entire movie yet, but I think Pete's fix did the trick.


    Thanks so much @Pete!



    T
     
    whatever_gong82 and SamuriHL like this.
  20. Lukas

    Lukas Well-Known Member

    @testiles
    these are joyful messages i hear very happy
     
    whatever_gong82 and testiles like this.