Read error while reading ISO on disc

Discussion in 'AnyDVD HD (Blu-ray issues)' started by DarthRay, May 7, 2019.

  1. DarthRay

    DarthRay Member

    I have an ISO I ripped a while ago with 'keep protection' enabled. Yesterday I mounted it and re-ripped it in order to remove the protection. This particular ISO seems to always fail at 99% with read errors, even though I'm able to read the contents of the original ISO file just fine and the MD5 hash generated during the original ripping process still matches (i.e., the file was not modified since it was created).

    Why is AnyDVD reporting errors? Is the ISO corrupted somehow? How do I avoid this situation going forward?

    Thanks!
     
  2. mmdavis

    mmdavis Well-Known Member

    You really shouldn't rip a DVD to iso using AnyDVD, and the "Keep Protection enabled" is for Bluray, not DVD. An AnyDVD log would be needed to see if it is a defective disc or an AnyDVD problem.

    I am assuming this is a DVD since you posted in the DVD section and you didn't specify.
     
  3. DarthRay

    DarthRay Member

    My apologies, I don't know why I ended up posting this in the DVD forum. It was actually meant for the Blu-Ray one. Is there any way to move this thread there? Otherwise, I'll post again there. My apologies again.
     
  4. Ch3vr0n

    Ch3vr0n Translator NL

    No need, already moved both topics

    Verstuurd vanaf mijn Nexus 7 met Tapatalk
     
  5. James

    James Redfox Development Team Staff Member

    How did you mount the image?
     
  6. DarthRay

    DarthRay Member

    Thank you!
     
  7. DarthRay

    DarthRay Member

    Via PowerShell: Mount-DiskImage <path_to_iso>. I believe this uses OpenVirtualDisk and AttachVirtualDisk under the covers.
     
  8. James

    James Redfox Development Team Staff Member

    Well, use something that works. Like elby Virtual CloneDrive.
     
  9. DarthRay

    DarthRay Member

    Just tried Virtual CloneDrive. Got the same error at around the same place (99% complete). Don't remember if the message was the same but this one says "verify error sectors" instead of "read error sectors".
     
  10. James

    James Redfox Development Team Staff Member

    Ah, this isn't a read error. The Integrity check for correct decryption has failed. Retries didn't help, as the damage seems to have happened during the creation of the protected image. Or the protected image was damaged after the rip.
    Or it is a "glitch" which can be ignored... ? You can re-rip with the original disk to check.
     
  11. DarthRay

    DarthRay Member

    Unlikely that the image was damaged after the rip given that the hash captured at creation time by AnyDVD itself in the .md5 file still matches the content. That leaves us with a failure during the creation of the protected image. I'll re-rip and see what happens.

    Thanks for the help.