QuickSync disabled

Discussion in 'CloneBD' started by testiles, Oct 17, 2018.

  1. testiles

    testiles Well-Known Member

    Tonight, I was in the process of using CloneBD to "gently" compress a movie down from 27G to fit a 25G disc.

    Problem was, CloneBD would not engage hardware acceleration as it normally does and the estimated completion time was in the triple-digits.

    What's worse, a check of CloneBD settings showed the QuickSync h/w acceleration setting grayed out!


    As a gut reaction, I downconverted from release 1.2.3.0 to 1.2.2.0 but it didn't make any difference.

    I happened to notice though that there was one of those Win 10 automatic updates in the wee hours yesterday morning.

    By checking restore points, I found out the update installed Intel Graphics 24.20.100.6344.

    Envy 4K Restore to get back Hw Accel 2.JPG


    When I rolled that update back, Intel Graphics 22.20.16.4718 was restored and CloneBD allowed using QuickSync once again --


    Envy 4K After Restore to get back Hw Accel.JPG


    -- giving a 40 minute compression time (reading from disc).


    Unfortunately as someone else on the Forum said, with Windows 10 this is Microsoft's computer, not mine, so I can't hold off the update forever.

    So, wondering if CloneBD will be able to work with QuickSync with this new Intel Graphics release in the near future?


    (Haven't included a logfile because the new Graphics is no longer installed...)


    T
     
  2. tectpro

    tectpro Translator (ms_MY)

    Till there may be a fix.

    You can stop auto install with the
    Group Policy Editor

    Only for Windows 10 Education, Pro and Enterprise editions and security updates will still install automatically.
    1. Open the Run command (Win + R), in its type: gpedit.msc and press enter
    2. Navigate to: Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update
    3. Open this and change the Configure Automatic Updates setting to ‘2 – Notify for download and notify for install.’
    4. Open the Settings app (Win + I) and navigate to -> Update and Security -> Windows Updates. Click ‘Check for updates’ which applies the new configuration setting
    5. Restart
     
    whatever_gong82 likes this.
  3. Pete

    Pete Forum Admin Staff Member

    I don't know, which Intel GPU you have, so there may be differences, but I checked for the latest Intel Driver for HD 530 on the Intel page.
    There I got 25.20.100.6326 - and it works fine with CloneBD.
     
  4. testiles

    testiles Well-Known Member

    Thanks.

    I'll try this.



    The GPU is HD Graphics 630.

    I guess the inability to select "QuickSync" in Settings means CloneBD cannot use it on this GPU at the later version ???


    T
     
  5. Pete

    Pete Forum Admin Staff Member

    OK, now I checked another computer with HD 630 graphics:

    Windows update won't deliver anything more recent than Feb 2018 (version 23.20.16.4973).
    When I update directly from the Intel site, again, I get version 25.20.100.6326 - which is just a couple of days old, it doesn't get any newer than that.

    And again, it works just fine with CloneBD.

    So I have no idea what kind of driver that is, you have there and where you got it from, it definitely seems bad.
    Just go to Intel and download the latest, official driver and you should be good.
     
  6. testiles

    testiles Well-Known Member

    Yeah, it definitely came from Windows Update.

    Or maybe an HP update that was part of the Windows Update.

    As shown in the attachment above, when I checked the restore point taken before the Windows Update in the AM of the 16th, it reported that rolling back to that would remove the 24.20.100.6344 Graphic version and re-install the previous one. So that's what installed it.

    Thanks for confirming it's a bogus driver, not CloneBD....


    For now, I'm good because I'm back to what I had before.

    I guess if Windows tries to install it again, I will install the latest from the Intel website.

    But when I tried that in the past, my computer said the latest driver was incompatible.


    Ch3vron mentioned that often happens with OEM computers and I should do an install anyway. Been reluctant to force the issue but I may have to.


    Because I'm assuming if I have the latest and greatest version, 25.20.100.6326 for example, the Update will not try to install 24.20.100.6344 over that.


    T
     
    Last edited: Oct 17, 2018
  7. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    That's because HP modified the driver slightly to make the official installer THINK it's not compatible. Since the GPU is built into the CPU that's highly doubtful. They just want you to use "their" (less optimised) version instead. And we all know how slow those manufacturer updates can be.

    Read this on how to force a driver:

    Code:
    https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/
    So when you grab the driver, grab the ZIPPED download (not the download and update assistant) for the driver itself, and not the installable exe. You need the zip file from the below link

    Code:
    https://downloadcenter.intel.com/download/28240/Intel-Graphics-Driver-for-Windows-10?product=98909
    Left side of the page, bottom blue button
     
  8. testiles

    testiles Well-Known Member

    Thanks Ch3vron, I'll try this....


    T
     
  9. testiles

    testiles Well-Known Member

    Well, after a bit, Windows auto-installed the "bogus" Intel driver again with the same negative results in CloneBD (no h/w acceleration available).

    I thought I turned the Windows Update Service off but I see Windows will turn it back on using its new Medic Service.


    @tectpro I have Windows Home, so I don't believe the Policy Editor is available to me.


    @Ch3vr0n I read your instructions and links in #7 to "force" install the latest Intel driver and it seems straightforward enough. BUT I'm going to try one last thing before that...


    I went to the HP site and downloaded the latest Intel driver there.

    That took me from 22.20.16.4718 --> 24.20.100.6025.

    CloneBD likes this new driver. :=)


    There is still the possibility that Windows will try to install the problematic 24.20.100.6344 over that so I "hid" this update using a method I found here:


    https://support.microsoft.com/en-us...-window?utm_source=twitter?utm_source=twitter


    This is supposed to flag a problematic update so that Windows does not try to install it until you "un-hide" it.

    I hope it works.


    Just for grins, I also tried a trick I found online that may "incapacitate" Windows Update Medic Service to keep it from turning Update Services back on after I have disabled it.

    We'll see if it works --- but even if it does I don't intend to keep Windows Update disabled forever.


    So hopefully "hide" will do the trick.

    And if not I will force-install the latest Intel driver.

    I guess no worries about voiding the Desktop warranty doing that because it was up week before last :=).



    T
     
  10. SSoft88

    SSoft88 Active Member

    @testiles

    I normally don't wade into these things but I've done the stop-driver-update dance myself.

    Lots of conflicting and dated info available on the interwebs - MS keep moving the goalposts.

    Even if updated with the latest OEM driver, no guarantee that MS update won't roll over the top of it with their "latest" (older) version. This has happened to me.

    In my experience the common-wisdom group policy change - mentioned in a previous post - doesn't work, no matter what version of Win 10.

    The only way I've found to guarantee a device driver won't update accidentally or unawares is to block it via hardware ID.

    This is a basic description of method I've used successfully:
    ==============================
    First, collect the device IDs for hardware you don’t want Windows to "manage" for you.

    In Device Manager, go to Details tab for each respective device and select Hardware IDs from the drop-down menu under Properties.
    Copy / make note of the Hardware ID.

    Exclude these devices from Windows Update via Local Group Policy Editor (gpedit.msc)...

    Go to Computer Configuration > Administrative Templates > System > Device Installation > Device Installation Restrictions.

    Open "Prevent installation of devices that match any of these device IDs", enable the Setting, click the Show… button, then for each device, enter its Value.
    ==============================

    Disclaimer #1 - this will also block you from manually updating the driver at any point in the future, without first reversing the GP change.

    Disclaimer #2 - Since you're on Home version, all bets are off ;)

    This is the only method that worked for me, no matter what the "experts" have said elsewhere. Hope it works for you too.
     
  11. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    The gpedit method is both risky and unneeded. There's a better and safer method and that's to use the guide I previously linked to that lets you change from the OEM driver to the stock Intel driver by just manually updating the driver itself from the Intel driver zipfile.

    Verstuurd vanaf mijn Nexus 6P met Tapatalk
     
  12. testiles

    testiles Well-Known Member

    @SSoft88 thanks for your suggestion.

    I'll take note of it.


    Right now, things are still ok.

    Well, the trick I tried to get the Medic Service to stop turning back on Windows Update didn't work and Update is in full effect.

    But it looks like the "hide" I described is still holding.


    So, as of right now, I'm still at 24.20.100.6025.

    I prefer this driver because it's the latest HP-sanctioned one -- and ofc because it's not causing problems with CloneBD.


    If the "hide" fails at some future point, I'm going to download the latest Intel driver as per @Ch3vron's instructions.


    If I find Windows Update is even overriding that (which it shouldn't), I'll try Group Policy Editor.

    TBH, not my favorite solution if, as you say, it even prohibits manual driver updates (and has to be reversed and re-instated to manually update).

    But if it turns out to be my very last resort, I would try it.


    Thanks for the input, guys.



    T