• RedFox is offering a Cyber Week discount of 20% on all products (except upgrades/renewals), valid until December 3, 2023.
    If you are entertaining the thought of purchasing one of our products then now is the right time to act!

Resolved Provider Setup Failed with Disney Plus - Very Specific Case


New Member
Thread Starter
Nov 29, 2021
Before anyone jumps on me about using a VPN. I am NOT using a VPN. I can access Disney Plus perfectly from a web browser.

My case is very specific. I canceled my old Disney Plus account and started a new one. I was able to login into Disney Plus with Anystream just fine. Then using a web browser I changed some profiles around. Then the next time I opened Anystream I got the Provider Setup Failed message. I went back to the web browser and tried to return the profiles and names back to what they had been, but AS still fails. It appears that AS has saved some old login/profile info which is no longer valid. I tried deleting the Disney Plus tab in AS, closing AS, then starting AS and re-enabling Disney Plus, but that doesn't work.

Is there any way to delete the saved login info within AS so I can do the login process again from the start for AS?

Cant you just log out of the program in AnyStream? I hope you realize you need a no-advertisement subscription. Maybe we could help more if you posted a log file.
Can't log out because I can't reach the provider to begin with. See attached photo. Log file is attached. The logout and search fields you see i the screenshot are greyed out and don't respond to clicks, even once I bypass the "Provider setup failed" pop up box. If I can just get back to the point where it shows active login and logout fields, that would be a start. I can reach Disney Plus perfectly in two different web browsers and StreamFab. The problem is specific to AnyStream.


  • AnyStream_1.6.8.2.astlog
    16.1 KB · Views: 2
  • AS Disney Plus Provider Failed.jpg
    AS Disney Plus Provider Failed.jpg
    60.5 KB · Views: 7
Last edited:
Uninstall the program, and clear all your caches and cookies. Reboot , reinstall the program and see how that helps.
Thank you very much Cartman0208!! That is exactly the kind of information I was looking for! Unfortunately it came too late. I didn't want to risk losing all my settings (output templates, provider logins, etc) by doing a reinstall, so I used a somewhat recent disk image I had made and did a full restore on my system drive. Now it works fine! I am saving your information because it is likely to come in handy sometime later! Thanks again!
It seems that the issue with AnyStream is that it causes login/logout errors whenever the saved login information does not match the login from the current session. I experienced the same problem (albeit when using a VPN, but that's not the cause). With the suggestion from cartman0208 I managed to get it to work reliably anytime I switch to a different region.