Problems with Game Jackal under Windows Vista

Discussion in 'GameJackal' started by Targon, Jul 26, 2007.

  1. Targon

    Targon Well-Known Member

    I have just installed the latest version of Game Jackal on a Windows Vista Home Premium 32 bit, and have found that it just doesn't work. The same games work with Game Jackal on Windows XP, so it seems like it's a Vista issue. I am running as Administrator to help eliminate some of the issues as well, with no luck.

    In addition to this, my new system is a dual core Athlon 64 X2 5600+, so the dual-core could potentially be causing some additional issues.

    Here are the requested pieces of information about my setup:

    Please answer these questions when posting about issues:

    1. What version of Game Jackal are you running?
    2.9.18.565

    2. What Operating system are you using? 64 bit? service pack?
    Windows Vista Home Premium 32 bit with all updates installed prior to installing Game Jackal.

    3. If you have virtual drives, disable them while profiling and playing profiles.
    Nothing is installed that would provide a virtual drive.

    4. Remove packet writing software from your system (including Directcd, Incd, DragtoDisc, Drive Letter Access, CyberLink InstantBurn, etc.)
    Since this system came without any software for burning CDs/DVDs(besides the stuff included with Vista), there should be nothing causing a conflict with Game Jackal.

    5. What protection does your game use? Don't know? Find out before posting about issues (and include that information)! Use Protection ID. It's a free program. Use ProtectionID and scan your HD directory where the game is installed (right click the icon on your toolbar, and select "scan files/folders"). Or just scan the main program .exe(s) that you find in the game directory on your hard drive. Provide the protection name and the version number.

    I have tried several different games, mostly SafeDisc. Civilization 4: Beyond the Sword and Warlords, as well as others. Note that I have no problems under Windows XP.

    6. What is the name of the game you're trying to run?
    See my response to question 5.

    7. What is the version of the game?
    Latest versions of Warlords and BtS.

    8. Is it cd or dvd version?
    The expansions come on CD

    9. What region or country is the original disc from?
    Region 1(USA)

    10. What cpu are you running?
    Athlon 64 X2 5600+ running at the stock 2.81GHz/core

    11. What optical drives (dvd-rom,cd-rom, burners) are you using to create profiles with? What firmware version is installed on your reader?
    LiteOn DVDRW LH-20A1H

    12. What security software (firewall, antivirus) are you using? Please provide version numbers.
    Tested without any Antivirus software installed, again to verify that nothing was getting in the way. UAC is also off to test.

    13. Describe your problem, provide full error messages, and please state clearly what you were doing when you received those error messages.

    I create a profile using ultra scan as an option as well as normal, and the profile is created. Every time I try to launch the game through Game Jackal without the CD in the drive, I either get a message saying I need to insert the original CD, or the game locks up without launching, and Game Jackal is also frozen. At that point, nothing works until I reboot(requires a hard reboot via reset button). I have verified that I have Game Jackal set to single processor mode.

    At this point, I am forced to not use Game Jackal under Vista due to these problems. Any advice would be appreciated...
     
  2. Yard Waste

    Yard Waste Well-Known Member

  3. matthew

    matthew SlySoft Team Member

    Try turning UAC off. I know this is not a desirable option, however we have found many applications that this has issues with. Infact MS's own development environment (VS2007) works better when running in admin mode... so you can see how difficult it is for the rest of the development community if MS's own apps have trouble. :doh:

    In the meantime, we will continue to work towards better Vista support.
     
  4. Targon

    Targon Well-Known Member

    I am running as administrator, and UAC is off. Still no luck at this point, so I suspect that either the DVD-RW drive just isn't working well to create a profile, or something else about Vista is the problem. My next step is to turn off the firewall(the Windows Vista firewall), just in case for some really odd reason it is causing problems.
     
  5. Targon

    Targon Well-Known Member

    I just tested with both the Windows Firewall and Windows Defender turned off, and no luck. I am going to do another reboot with the Defender service set to disabled and see if that will help.
     
  6. Targon

    Targon Well-Known Member

    Still no luck, so I'll need to wait until the next version of GJ to be released that fixes Vista problems I suppose. Ah well, it could be worse...
     
  7. matthew

    matthew SlySoft Team Member

    What is the error that is coming up?
     
  8. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    Probably no error, just that the game still requires a cd.
     
  9. Targon

    Targon Well-Known Member

    The game claims that the CD isn't in the drive(so is asking for the correct CD). Note that the same games work with Game Jackal on a Windows XP machine, so unless there is a problem with the DVD-RW drive in this computer, it LOOKS like it's a Vista issue.

    This is a Vista Home Premium 32 bit system, so it's not a 64 bit problem. This won't help track down the problem, but Alcohol 120% works. I just hate wasting the hard drive space on a full CD or DVD image, which is why I prefer Game Jackal.
     
  10. Targon

    Targon Well-Known Member

    Ok, Game Jackal is working under Vista, but what I had to do to make it work is rather...unusual.

    I set up a virtual drive using Alcohol 120%, and suddenly Game Jackal works perfectly(no, I have no image mounted in Alcohol 120%). The only reason that I can think of for this behavior is the CD/DVD drive "locking" that Game Jackal tries to do, and for whatever reason, it works properly due to Alcohol 120%'s virtual drive, but doesn't work with the physical drive I have in the machine. I am going to check and make sure that the whole master/slave settings are set correctly on this machine, but if the virtual drive lets Game Jackal work, I'll accept it.

    Edit: I spoke too soon. I can get some things to work under Vista, Oblivion and Medieval 2: Total war. Civilization 4, Civ 4: Warlords, and Civ 4: Beyond the Sword so far are not working. It looks like it's just the difference in copy protections. Either that, or the profile modes not working since Medieval 2 and Oblivion are specifically listed, but the Civ titles do not. Again though, I have no problem with the Civ 4 titles under Windows XP so it is a Vista issue.
     
    Last edited: Aug 5, 2007
  11. matthew

    matthew SlySoft Team Member

  12. chrs2ca

    chrs2ca New Member

    Problem solved

    I was having the exact same issue with the same results for previous suggestions. The new beta seems to have fixed all issues between Game Jackal, the Civ series, and Vista
     
  13. chrs2ca

    chrs2ca New Member

    Problem back

    After running a few times, it asks for CD to be inserted again. Too bad CD is at home and I'm not :(
     
  14. Webslinger

    Webslinger Retired Moderator

    Ensure you lock the profile after creating a successful one.
     
  15. matthew

    matthew SlySoft Team Member

    Which game is it specifically?
     
  16. chrs2ca

    chrs2ca New Member

    Civilization IV Beyond The Sword. The profile will work 1 time only then it asks for CD. I tried this about a dozen times. same results each time: 1 time run then won't work. Locking the profile has no effect.
     
  17. Targon

    Targon Well-Known Member

    I am about to reboot and see if my Beyond the Sword profile continues to work. One problem I have run into with some games under XP was that a different CD/DVD in the drive would be detected, and since the copy protection would check the protection on the inserted CD/DVD, it would fail, even when Game Jackal was working fine.

    So, make sure you have no CD or DVD in your drive(s) and check if it works. I will be right back with my report.
     
  18. Targon

    Targon Well-Known Member

    I just rebooted, and have verified that Beyond the Sword works perfectly with the beta version. I will check Neverwinter Nights 2 and several other games when I get back from work.