Probleme mit Untertiteln

Discussion in 'AnyStream (de)' started by bambam, Mar 30, 2021.

  1. bambam

    bambam Well-Known Member

    Moin,

    mir ist gestern aufgefallen, dass ich bei heruntergeladenen Filmen beim Abspielen (über NAS, Oppo 203) keinen Untertitel anwählen kann obwohl ich ihn ursprünglich mit herunter geladen habe.

    Die meisten meiner Filme habe ich im MKV Format auf dem NAS liegen, welche ich mit MKV Toolnix erstellt habe.
    Unveränderte .mp4 Dateien lassen sich vom PC aus mit VLC abspielen, da ist der Untertitel vorhanden. Mein Oppo zeigt aber auch bei diesen unveränderten Dateien keinen Untertitel an. Sobald ich die Datei in MKV konvertiere, ist der Untertitel dann auch unter VLC verschwunden.
    Bei MKVs aus anderen Quellen (DVD/BR, Mediathekview) habe ich diese Problem nicht.
    Ich bin mir natürlich nicht sicher, ob das Problem mit einem möglichen Fehler von AnyStream zusammenhängt, oder ob der Fehler bei mir liegt.
    Und bevor jemand fragt, warum ich die Dateien in MKV konvertiere: Die heruntergeladenen Filme haben keine Kapitelmarken, die füge ich gerne nachträglich mit MKVToolnix ein, da mein Oppo sich oft nicht merkt, wo ich einen Film beim Anschauen unterbrochen hatte und Vor-/ Zurückspulen mit dem Oppo relativ langsam ist. Mit Kapitelmarken ist man da schneller. Falls jemand ein (freeware) Tool kennt, mit dem ich solche Kapitel auch einfach in .mp4 Dateien einfügen kann, dann "darf" er es mir gerne mitteilen.... :)

    LG
    bambam
     
  2. D300

    D300 Well-Known Member

    Kann man mit dem Ts-Muxer nicht auch Marken setzen !
     
  3. bambam

    bambam Well-Known Member

    vermutlich schon, habe ich noch nicht getestet.
    Kann ich ja mal versuchen....
     
  4. bambam

    bambam Well-Known Member

    so, ich habe etwas mit dem tsMuxer herumprobiert. Untertitel werden hier unterstützt und sind auch wählbar. Jedoch erkennt der tsMuxer nicht, wenn der Untertitel mehrere Zeilen hat und schreibt dann alles in eine Zeile. Die ist dann zu lang und passt nicht in den Bildschirm. Man kann natürlich manuell auch noch den Schriftgrad des Untertitels verkleinern, dann passt es wieder, sieht aber komisch aus. Meine Kapitel sollten sich mit dem Muxer auch erstellen lassen, es gibt unter dem Reiter BluRay die Option hierfür (z.B. alle 5 Minuten), es hat aber keinen für mich erkennbaren Effekt, was man da einstellt, Kapitel werden jedenfalls keine funktionierenden erzeugt. Die Ausgabe als BR ISO führt zu einer Datei, welche sich nicht mit dem VLC öffnen lässt.
    Die funktionierende m2ts kann ich aber dann noch mal durch den mkvtoolnix jagen, dann habe ich Kapitel und Untertitel (leider nur nicht im Original-Format).
    Ich hoffe es hat noch jemand eine Lösung (oder kann mir sagen, was ich falsch mache)?

    LG
     
  5. Darth Sidious

    Darth Sidious Well-Known Member

    Extrahiere deine Untertitel und passe sie mit "Subtitle Edit" (unter Werkzeuge/Lange Texte trennen) an, so das sie konform werden (siehe Bild 01).

    Das liegt daran, dass es kein BD/UHD konformes Material ist (siehe Bild 2). Hier kannst du nur mit MKVToolNix deine bearbeiteten Sub`s einfügen, sowie die gewünschten Kapitel erzeugen lassen und dir dann eine funktionierende MKV erstellen lassen.

    01.png 02.png
     
    Last edited: Mar 30, 2021
  6. bambam

    bambam Well-Known Member

    Danke für Deine Antwort.
    Das blöde ist, in der Ursprünglichen mp4 ist ja soweit alles gut (auf dem PC/VLC), nur funktionieren die Untertitel aus mir unerfindlichen Gründen nicht, wenn ich den Film auf meinem Oppo abspiele. Und wenn ich eben, wie gewohnt per MKVToolnix ne MKV draus mache, sind sie ganz weg. Aber eben nur wenn die Quelle AnyStream war, sonst klappt es wunderbar.
    Ich suche nun nach ner Lösung, die heruntergeladene MP4 umzuwandel, so dass ich am Ende die Untertitel noch habe (und auf dem Oppo abspielen kann) und zusätzlich z.B. alle 5 Minuten eine Kapitelmarke drin habe.
    Hierfür aber 3 Programme zu bemühen um erst den Untertitel zu extrahieren, dann wieder einzufügen, dann na m2ts draus zu machen und dann mit toolnix wieder ne MKV ist mir irgendwie auf Daue etwas zu aufwändig. Für einzelne Filme mag das gehen, die lade ich aber eher nicht mit Any, es geht mir eher um Serien, die ich nicht auf Scheibe habe. Da jetzt jede Folge so aufwändig zu bearbeiten ist mir, wie oben bereits gesagt, etwas zu aufwändig.

    LG
     
  7. Darth Sidious

    Darth Sidious Well-Known Member

    Na dann viel Glück mit der Suche, sowas ist mir nicht bekannt.
    Davon war auch keine Rede.
     
  8. bambam

    bambam Well-Known Member

    Dann habe ich was nicht verstanden, welches Vorgehen schlägst Du vor?
    1. Subtitle mit Subtitle Edit extrahieren
    2. mp4 in tsMuxer laden und Subtitle wieder einbinden? In welchem Format ausgeben?
    3 Dann alles in MKVToolnix um Kapitel einzufügen?

    Oder ganz anders??
    Bin hier eher der "learning by doing" bzw. "try and error" Typ, wäre aber für Tipps dankbar
     
  9. Darth Sidious

    Darth Sidious Well-Known Member

    1.Subtitel mit dem TsM extrahieren (Demux)
    2.Subtitel mit Subtitle Edit in konforme txt Datei umwandeln (Zeilenlänge anpassen)
    3.Mit MKVToolnix Sub`s einfügen, gewünschte Kapitel erzeugen und daraus eine MKV erstellen
     
    Last edited: Mar 30, 2021
  10. bambam

    bambam Well-Known Member

    So, ich habe jetzt mal Subtitle Edit installiert. Wenn ich versuche, die mp4 von Anystream zu öffnen, kommt diese Fehlermeldung:
    upload_2021-3-30_13-54-25.png

    Wenn ich die Datei mit dem tsMuxer in eine .ts Datei wandle, kann ich sie mit SubtitleEdit öffnen, bekomme aber die Meldung, es wäre keine Subtitle vorhanden (Wird aber in VLC angezeigt und richtig abgespielt).
    Wenn ich ne M2TS draus mache, kann ich den Subtitle bearbeiten.
    Bei Dateien aus anderen Quellen (z.B. DVD/BR) geladen, wist der Untertitel mit SubtitleEdit zu öffnen, er wird aber auch von MKVToolnix korrekt eingebunden. Beide Dateien lassen sich auch auf dem Oppo dann richtig abspielen. Deshalb vermute ich ja, dass unter AnyStream irgend etwas nicht richtig angelegt wird.

    Die M2TS kann ich nun (mit und ohne Bearbeitung mit SubtitleEdit) in MKVToolnix packen und Kapitel erstellen, das ganze läuft auch unter meinem Oppo dann korrekt.
     
  11. bambam

    bambam Well-Known Member

    Da bin ich schon zu doof für, kann die Funktion da nicht finden...
     
  12. Darth Sidious

    Darth Sidious Well-Known Member

    02.png
     
    bambam likes this.
  13. bambam

    bambam Well-Known Member

    Ok, Demux hatte ich noch nie angeklickt.

    @Darth Sidious: Du Hast recht, so funktioniert es, Danke hierfür erst einmal.

    Ich werde mir fürs Erste so behelfen.
    Dennoch wundert es mich, warum die MP4 auf dem Oppo keinen anwählbaren Untertitel zeigt, auch SubtitleEdit kann mit der MP4 (und auch der .TS aus dem tsM) nix anfangen. Die extrahierten Untertitel (oder auch die aus einer M2TS) werden sowohl vom SubtitleEdit, als auch vom MKVToolnix akzeptiert.
    Muss ich wohl erst einmal so hin nehmen.....


    LG
     
  14. Darth Sidious

    Darth Sidious Well-Known Member

    Das ist einfach zu begründen, denn die Firmware des Oppo ist nicht dafür entwickelt worden.
     
  15. bambam

    bambam Well-Known Member

    Kann schon sein, dass der Oppo generell keine Untertitel bei MP4 zeigt, habe gerade keine passende Datei zur Hand, um dies zu testen.
    Mich wundert aber, dass MKVToolnix den Untertitel eben auch nicht aus der MP4 von Any übernimmt (ebenso SubtitleEdit), bei anderen Quellen tut er dies doch auch. Untertitel in MKV unterstützt der Oppo ja einwandfrei.
    Fragen über Fragen.... :)

    Bin übrigens nun dabei, zumindest bei einigen ausgesuchten Serien, die Untertitel manuell einzubinden. Habe ja Zeit. Lockdown hat dann doch auch noch was Gutes (bitte nicht zu wörtlich nehmen, will hier keine Corona Grundsatzdebatte lostreten).
     
  16. Darth Sidious

    Darth Sidious Well-Known Member

    Oder du gehst einen anderen Weg, sieh mal in deine PM.
     
    bambam likes this.
  17. bambam

    bambam Well-Known Member

  18. D300

    D300 Well-Known Member

    So nen Film mal wo hochladen!?.., dann kann ich da auch mal Versuche damit machen.
     
  19. bambam

    bambam Well-Known Member

    Danke für Dein Angebot.
    Aber Ich tue mich etwas schwer damit, einen Film, der möglicherweise so etwas wie ein Wasserzeichen hat, irgendwo hoch zu laden.
    Nenn mich paranoid (oder zumindest sehr vorsichtig), aber selbst das Hochladen eines .astlog Datei bereitet mir durchaus Bauchschmerzen.


    Edit:
    Ich vermute aber, dass das geschilderte Problem keines ist, das spezifisch bei mir auftritt.
    Aufgefallen war mir das ganze bei der Serie "Das Damengambit", da hier relativ viel Text im Hintergrund in der Originalsprache gesprochen wird (z.B. russisch oder spanisch). Da hilft eben ein deutscher Untertitel.
    Wenn Du etwas herumprobieren möchtest, reicht es, glaube ich, wenn Du Dir z.B. da eine Folge von (Netflix) herunter lädst. Ich glaube nicht, dass die sich wesentlich von meiner Datei unterscheidet. Mich würde interessieren, was da mit den Untertiteln passiert, nachdem Du z.B. mit MKVToolnix ne MKV draus gemacht hast.

    LG
     
    Last edited: Mar 30, 2021
  20. DaveO88

    DaveO88 Moderator DE

    es ist doch einfach , demuxe wie schon erwähnt mit TSM die UT (SRT) und diese kannst Du einfach mit mit sup2sub Unbenannt.JPG Unbenannt1.jpg neue UT erstellen in dem Format was Du willst
     

    Attached Files: