Problem with Chernobyl UK Bluray, AnyDVD HD and Oppo 203 clone

Discussion in 'AnyDVD HD (Blu-ray issues)' started by Manni, Jan 10, 2020.

  1. Manni

    Manni Well-Known Member

    Weird issue with this title and AnyDVD HD:

    - If I rip it to BD folders with AnyDVD HD, I can play it fine on my HTPC over the network (with menus, I use jRiver), but my Oppo 203 clone can't play either disc (same BD folders rip, same network). I get a blank screen, and back to the player network playback menu. It happens for both discs.

    - If I rip the discs with DVDfab instead (usually not my first choice), both folder rips work fine for both the HTPC and the Oppo 203 clone.

    So clearly not a physical disc issue, or an Oppo issue. This is the only title that has this problem with the Oppo clone, usually any rip works both on the HTPC and the Oppo (all BD folders). I use anyDVD for 99% of my rips, and only use DVD Fab or MakeMKV when AnyDVD doesn't handle the title or has an isssue as this one (not often!).

    Obviously the problem is solved for me as I'll simply use the DVDFab rips, but please let me know if you need anything else to resolve this issue with AnyDVD HD so that other users don't experience the same problem.

    I might find other titles that have that problem as I start to use the Oppo 203 more, if that's the case I'll report back
  2. Pete

    Pete Forum Admin Staff Member

    Well, a log file is always a good start.
  3. Manni

    Manni Well-Known Member

    Sure, I just wanted to make sure first there was some interest to look into this :)

    Here you go, attached the log of disk 1

    Note that there shouldn't be anything wrong with it: the disk can be read and ripped fine by AnyDVD. The resulting rip is just not valid for the Oppo 203 clone (though it seems to work fine with software players).

    Attached Files:

  4. James

    James Redfox Development Team Staff Member

    Why don't you rip to .iso? I always rip to iso for playback with the fake Oppo.
  5. Manni

    Manni Well-Known Member

    Hi James,

    Simply because if you do this, you can only start playback manually, using the player interface. You can't start playback with remote IP control on any files (.ISO, .MKV, etc). You can only play folders (DVD, BD, UHD). You can try with the Oppo app, you'll see it doesn't support ANY file for playback, contrary to the player's interface, at least with SMB.

    The interface of the clone is not usable for my needs (I have a collection of more than 3000 discs ripped to three different NAS in dozens of different folders). I need categories etc to access my titles (and ideally something that looks better than the player's barebone text interface).

    I worked with Brian to get the Oppo 203 supported by Movies, and it works fantastically well: you choose the title in the MyMovies app on the iPad, and MyMovies starts playback on the Oppo clone. So much better than the player's clunky interface.

    The main two downsides: you need to have a PC or laptop that can be used as a bridge to control the Oppo (it doesn't have direct support like the Dune), and you have to rip to folders. So I converted my whole collection from mkv, 3dmkv and ISOs to folders (even for 3D titles, at the cost of twice the storage space!) because of this limitation of the clone with IP control. Most of my BDs and DVDs were already ripped to folders for various reasons, but all my UHD BD and 3D BD had to be converted.

    I really like the stability of the Oppo 203 vs the HTPC (especially for 3D now that nVidia has dropped the ball), and I'm planning to leave the HTPC behind as a primary player soon, so it's worth it to me.

    As I said initially, the problem is resolved for me with DVDFab. I only wanted to let you know, and help if you wanted to understand why the AnyDVD rip is less standard/rejected by the Oppo, as it might happen with other titles / for other users.

    It's absolutely fine if you think it's not worth investigating, I'm happy to re-rip with another tool any title that shows this behaviour with the Oppo. It's just that AnyDVD is my first-choice ripper, so I like it to be as good as it can be :)

    Keep up the good work !
    Last edited: Jan 10, 2020
  6. James

    James Redfox Development Team Staff Member

    Okay, let's rephrase this...
    If you create an iso with AnyDVD, does the Oppo clone play it? To rule out a bug in file creation.
    Or for the advanced fake Oppo user:
    Does it play the original disc with AnyDVD running through an SMB share? If not, change options in AnyDVD until it does and tell us all the details. No need to rip / re-rip at all.
    Thank you!
  7. Manni

    Manni Well-Known Member

    I looked at the settings (better late than never) and I realized that region code removal was inexplicably disabled (I usually have it on automatic). :oops:

    So I enabled RC removal, ripped to BD folder... and it worked fine, of course. :rolleyes:

    So there was nothing special about the DVDfab rip, it was just removing the region code... :D

    That also explains why the original bd folder rip was working on the HTPC, given that I use unlicensed software players.

    I don't know when the option was changed, or how, but I'm sure I'm going to have to re-rip quite a few bluray titles...

    Sorry for wasting your time, and thanks for your help in resolving the mystery. Next time, I'll start with checking the settings ;)
  8. James

    James Redfox Development Team Staff Member

    Glad to know.
    Hint: You don't need to rip for testing on the fake Oppo. Saves a lot of time. Try out the great subtitle options in AnyDVD, much better than Oppos! ;)
  9. Manni

    Manni Well-Known Member

    Thanks for the hint, but I didn't manage to get the Oppo to see the physical disc in the HTPC. I shared the disc in explorer, so it should be visible in the workgroup when I browse the HTPC from the Oppo, but when I try to connect it fails. If you have a link to an explanation, I'd love to see it, it would indeed be handy in some situations to be able to test settings without having to rip.
  10. James

    James Redfox Development Team Staff Member

    It sounds like SMB v1 is disabled on your Windows PC. Oppo networking is pathetic, it only supports SMB v1. Microsoft disables it in Windows 10 by default.
  11. Manni

    Manni Well-Known Member

    That was it! I enabled SMB 1.0 and my shared drive automagically appeared on the Oppo after reboot. I was able to test on the fly that the blank screen issue was indeed due to the the region code. Thanks a lot, works a treat :)
    Aeneas72 likes this.