PowerDVD11 Playback of Blu-Rays (BD-j) broken with AnyDVD 8.2.x.x

Discussion in 'AnyDVD HD (Blu-ray issues)' started by Kishiro, Feb 20, 2018.

  1. Kishiro

    Kishiro Member

    Playing BD-J Blu-Rays with PowerDVD 11 has stopped working after AnyDVD-HD v8.2.0.0 (or thereabout). It's still broken in th 8.2.2.2 Beta.

    Simple Blu-Rays (without bd-j) plays fine without issue. But whenever I try to play a disc which loads a java menu at startup, like a Criterion disc etc., PowerDVD shows a black screen and flashes it's 'prohibited' message which usually shows up when you try to do a user-prohibited operation (PUO).
    It's seemingly trying to play chapter 0, title 0 which runs 0 minutes... Checking the 'Remove user prohibited operations' setting in AnyDVD changes nothing. The problem seem to affect all java-discs i've tried. Including older discs that worked just fine with earlier versions of AnyDVD-HD.

    Any suggestions ?
     
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Yes, logfile of a problematic disc with an AnyDVD version that works and one that doesn't. No logfile, we can't help you.

    Sent from my Nexus 7 with Tapatalk
     
  3. Kishiro

    Kishiro Member

    Here's a log-file. This is the Criterion BD of 'The Breaking Point'. using AnyDVD-HD 8.2.2.2. (which causes playback problems). I'll try to find an older AnyDVD-HD version to install and come back with a log for the same disc when it worked. bbl.

    [Attachment removed]
     
    Last edited: Feb 21, 2018
  4. Kishiro

    Kishiro Member

    It might not be AnyDVD-HD after all... I've now tested 19 older versions, all the way back to v8.1.1.0 and all bd-j discs are still fubar.. Damn.. even really old ones. :/ I don't know why.. I'll run procmon and see if I can get some useful info or hint on what's happening. If anyone have experienced bd-j discs suddenly stopped working, please chime in.
     
  5. sondeterra

    sondeterra Well-Known Member

    Is your JRE up to date?
     
  6. Kishiro

    Kishiro Member

    I haven't found out what went wrong. But AnyDVD-HD was not the cause. My PowerDVD installation must have become corrupt at the same time I installed the AnyDVD-hd 8.2.0.0 release. Go figure... Anyhow I managed to get bd-j discs to work after removing, cleaning and re-installng PowerDVD. All is good. :-D