PowerDVD Ultra BD Playing Error

Discussion in 'High Definition Software' started by AndreSocha, Oct 20, 2007.

  1. AndreSocha

    AndreSocha Member

    I get the following error playing any DB movie via PowerDVD Ultra:
    "A critical component of the player requires periodic updates. New movies could fail to play if the critical component is not updated promptly. Would you like to update now?"
    I say yes and get the following confirmation:
    "Player application update. Update progress finished".
    When I press the play button, I get the same message again.
    I contacted PowerDVD, they sent me a new version PowerDVD Ultra (build:3319a) [Vista ready] that should fix it, they said.
    It didn't.
    However, I disabled accidentaly AnyDVD and the movie played until I got a message that my screen is not HDCP compliant. Which it isn't, that's why I use AnyDVD.
    I'm confused now, where the isue is. Is that PowerDVD, AnyDVD or both being incompatible?
    At the same time PowerDVD plays fine HD DVD movies with AnyDVD enabled. (On the same machine, different drives).
    Any ideas?
     
  2. Stormlord

    Stormlord Well-Known Member

    All I can say is you are not the only one. I reverted back to the older 3174a build, atleast that one plays most of my BD just fine (except for memoirs of a geisha)
     
  3. LINUS

    LINUS Beta Tester

    Funny thing is, if I deactivate AnyDVD, the message disappears and I can play BRs, but without sound! How strange is that ....

    The new PDVD version is just buggy, however, it kind of worries me that they seem to recognize AnyDVD, I hope I am wrong, but that is, what it looks like!


    Edit: well, it looks like (at least under XP, dont know about Vista) AnyDVDHD does not work with the newest version of PowerDVD (3319) any more. Very sad ....
    If you deactivate AnyDVDHD the meassage disappears....
     
    Last edited: Oct 21, 2007
  4. Adbear

    Adbear Well-Known Member

    Well I can't say whether it works if you're using a none HDCP compliant setup, but on Vista Business 32 bit I have the latest PowerDVD and AnydvdHD and they both work fine, allows me to rip older discs (ones without the new AACS) no problems, and it makes no difference whether I have Anydvd HD running or not Powerdvd plays everything I've tried on it (around 40 Blu-ray and 20 HD DVD from original discs)
     
  5. LINUS

    LINUS Beta Tester

    Don't know about Vista, I use XP, as I said.

    Adbear: Are you really using PowerDVD 3319? It's not a patch, it's a new full version only available directly from Cyberlink.

    In my case, the whole mess is only caused by Spiderman3/German version which does not work with older PDVD versions.
     
  6. Adbear

    Adbear Well-Known Member

    yes I have the full installer sent by Support at Cyberlink
     
  7. LINUS

    LINUS Beta Tester

    Okay, so maybe this is a XP only problem.

    I hope support can clear this up, the error under XP is definitely caused by the presence of AnyDVDHD.

    Without reclock and AnyDVDHD Spiderman3 works just fine with Ultra 3319a.

    BTW: Out of 'self devence' I ripped Spiderman3 (first time ever) which worked however I do not get the correct audio track (only the comment track) when I play back the stream file. So that was no solution either. Is there a tool by which I can select the correct audio track?
     
    Last edited: Oct 22, 2007
  8. woods

    woods Member

    Hello.
    I am troubled with this problem, too.:(
    An error comes out me when I put Ultra 3319a.
    However, I cannot regenerate Spider-Man unless I put Ultra 3319a.
    An error does not occur if I invalidate AnyDVD.
    I can regenerate Spider-Man.However, there is another problem.
    I cannot play it by a DVI dual link connection unless I use Anydvd.(1920X1080,72Hz)
    Because "HDCP" is a single link.
    On this account I cannot play it unless HDCP becomes invalid.
    This is a very important problem..:bowdown:
     
  9. Stormlord

    Stormlord Well-Known Member

    Woods,

    same problem here. I have a dual link screen too. Still have to check the full version of the 3319a link they sent me though. Will try tomorrow or so.
     
  10. Stormlord

    Stormlord Well-Known Member

    I can confirm powerdvd Ultra 3391a build (full installer) does NOT work either when AnyDVD HD is enabled. It will work with 3104a just fine.

    I tried a disc with no region protection (planet earth):

    Summary for drive F: (AnyDVD 6.1.8.4)
    PLEXTOR BD-RPX-B900A 1.01 12/07/06BLE8
    Drive (Hardware) Region: 1

    Media is a Blu-Ray disc.
    Total size: 12011456 sectors (23459 MBytes)
    Video Blu-Ray label: 35223635_E4001
    Media is AACS protected!
    Removed AACS copy protection!
    Blu-Ray disc is region free!

    - if I have anydvd HD enabled: pop up to fetch a "a critical component update" will appear in endless loop everytime I try to play a blu ray disc. It does not appear anything is effectively being downloaded. This is with older discs too.
    - the same disc will start to play, but after a few seconds it will post up the HDCP error of my resolution being too high (my screen is 2560x1600, so it needs dual link to be used at full resolution)
    - Meanwhile - HD DVD will play back just fine with AnyDVD HD enabled! (e.g Dune, Matrix,...)
    - If I rip the a blu ray movie to the HDD and play it from there, it will play fine too (but then, both HDCP and region code etc. will be gone)

    Basically, the problem occurs with any Blu Ray I tried in my posession.

    If I revert back to 3104a the discs play just fine...

    It seems 3391a has a problem with AnyDVD HD, when playing Blu Ray from the disc media. The problem does not occur with HD DVD and it does not occur when the movie is first ripped to HDD and played back from there on.
     
  11. AndreSocha

    AndreSocha Member

    This is waht I have found starting this thread. What I couldn't determine was whether the HDCP had any part in it. I couldn't really play a BD disk with AnyDVD disabled because I was getting the HDCP error. Nevertehless, before the error poped up, I could see the DB disk root menu for a second. Which made me think that 3319a is not compatible with AnyDVD. Since then, I got a hardware device that emulates HDCP and I can confirm it now. No BD disk I have will play with AnyDVD enabled with the version 3319 or 3319a. They will play fine with AnyDVD disabled.
    Not sure now who shoudl and will fix it, AnyDVD or PowerDVD?
    PowerDVD support became unresponsive after sending me 3319a.
     
  12. Adbear

    Adbear Well-Known Member

    Strange, I still don't have any problems whether I have AnydvdHD running or not my Blu-rays and HD DVD's still play fine in Powerdvd 3319a
     
  13. IAM4UK

    IAM4UK Member

    I have an HDPC-compliant monitor (Samsung HLN-617W DLP) and have purchased and tried four different HDCP-compliant graphics cards based on AMD 2400HD PRO and nvidia 8500GT. Yet Cyberlink Advisor always reports that my setup fails HDCP compliance. Can I get any information on the device you said might help such a situation?
     
  14. AndreSocha

    AndreSocha Member

    The device is Gameswitch PS3-S201 but AnyDVD works for me as well. Both allow me to play BD disks in 720p and 1080p on a 1080p monitor that without either one of them is flagged and HDCP incompatible stopping the playback.
     
  15. woods

    woods Member

    Hello Stormlord,
    It is a symptom completely the same as my thing.
    This is a very troublesome thing.:(
    I intended to use 3104a.
    However, "3104a" cannot play Spider-Man 3.
    I think that this is a problem of PowerDVDULtra.:mad:
    However, I want them to cope in AnyDVD HD.
    The reason is because it does not think that PowerDVDULtra revises this problem...:bowdown:
     
  16. RichB

    RichB Well-Known Member

    do you know what version is required to Play Spiderman 3 and Revenge of the Silver Surfer?

    - Rich
     
  17. sarah99

    sarah99 Well-Known Member

    I have no problem playing Spiderman 3 with PDVD 3104a (ripped to HD first)
     
  18. LINUS

    LINUS Beta Tester

    How do you get the correct sound? When I do this I end up with the comentary track only.

    Thanks.
     
  19. sarah99

    sarah99 Well-Known Member

    I didn't select anything, the correct audio played right off.
     
  20. Adbear

    Adbear Well-Known Member

    I assume you're playing the disc with menu structure and not just the m2ts file