POTC 1&2 won't play in Powerdvd

Discussion in 'AnyDVD HD (Blu-ray issues)' started by Stormlord, Aug 19, 2007.

  1. Stormlord

    Stormlord Well-Known Member

    I've been having this curious problem playing Pirates of the Carribean 1 & 2 using PowerDVD. I've been going over this with Cyberlink, but thusfar no solution :(

    Notice: I have no issues (other then known) playing back any other HD DVD or Blu Ray discs I have (including some other recent ones, like the ultimate Matrix collection on HD DVD ...). All of the discs I currently own are region 1 (A)

    My player is region 2 (B) (plextor), - I'm located in Europe. I'm using anyDVD HD to be able to play back on my two screens (one Dell3007 2560x1600 and an HD Ready (1080i) plasma on second output) and to remove the region protection.

    Both the POTC discs are indicated by AnyDVD 6.1.70 to have AACS protection but no region code. I tried automatical region selection and forcing region A, made no difference.

    My videocards are 2x8800GTX from EVGA.

    I tried any version of PowerDVD Ultra 7 from build 2911 to 3104R1, but I cannot play the main movie file (in the case of both films).

    When I insert the disc I get no menu and the screen remains black, it just seems to "hang" the player. The same happens if I rip the files to the harddisk. I can playback all the other movie files except for the 00001.m2ts main movie file, and I can also playback the extra's on the second disc incl. its menu.

    I CAN play back the main movie, but only I rip it to HDD and use TSREmux 0.0.18 to strip out the AVC video file and DD 5.1 track and use file playback in PowerDVD Ultra OR Media Player Classic (the latter only outputs the sound in a stereo downmix though).

    Now, that cannot be the general idea can it? To have to rip and demux a movie to be able to play it back? I'm not trying nor willing to copy the discs: I only want to be able to play the discs I purchased on my hardware! I have 2 legit originals of the discs and legit versions PowerDVD Ultra 7 and AnyDVD HD software.

    Any ideas? My guess there is something with the file structure that causes playback problems, or maybe some kind of protection using BD-J???
     
  2. Adbear

    Adbear Well-Known Member

    Have you tried just going down to 1 screen? And making sure the graphics card is on the latest drivers?
    I've not had any problems with Pirates 1 or 2 playing back from the original or from the Harddrive, but if you're doing it from the HD make sure you also copy over the Certificate folder as it needs it to play
     
  3. Stormlord

    Stormlord Well-Known Member

    The videocard has the latest drivers and one or 2 screens doesn't make a difference. Besides: all other blu ray or HD DVD play, and also all other additional tracks from the disc, just not the main movie file - unless I rip and remux it.
     
  4. James

    James Redfox Development Team Staff Member

    1.) Update to newest PowerDVD
    2.) make sure, DEP is disabled, otherwise JAVA titles don't play

    EDIT:
    3.) Avoid BD discs, buy HD DVD instead. :)
     
  5. James

    James Redfox Development Team Staff Member

    Disable DEP on your machine and reboot. This works. Really. Or update to latest PowerDVD, this should fix this, too.
     
  6. Rathbone80

    Rathbone80 Well-Known Member

    What is DEP and how can I disable it?
     
  7. stanko3

    stanko3 Member

    Hi,

    i had the same problem until i read this topic and disabled the DEP in my Win XP (only for the PowerDVD.exe)
    DEP = Data Execution Prevention

    To disable it:
    1. Click Start
    2. Select Control Panel
    3. Select System
    4. Click the Advanced tab
    5. In the Performance region select Settings
    6. Click the Data Execute tab in the dialog box that opens
    7. Select Turn on DEP for all programs and services except for those I select
    8. Click Add.
    9. The open dialog box will open. Browse and select your application (PowerDVD.exe)
    10. Click Open
    11. Click Apply
    12. Click Ok
    13. Reboot

    This worked for me. I hope also for you.
     
  8. Stormlord

    Stormlord Well-Known Member

    Thanks guys, I had DEP enabled for all apps. When I switched it to enabled only for critical windows apps and services the problem was solved... Looks like somebody is doing something illegal if that is the case ;)

    I'll communicate the solution back to PowerDVD, more work for them to debug - hehe...