Payments Failing (Visa thru my bank and Mastercard Prepaid Gift Card)

Discussion in 'Purchase and License Keys' started by MLRTYME, Nov 8, 2021.

  1. MLRTYME

    MLRTYME New Member

    Need some help here. I have tried both using the Visa card through my personal bank, as well as a purchased Mastercard Prepaid Gift card, and neither will process. I am attempting the purchase during the 20% off discount window and it expires in a few hours. I tried with my bank card on Friday (11/5) and got a returned email that the transaction was denied and that I needed to contact my bank. When I called them on Saturday (11/6), they stated they have no history of any charges attempting to be made with the merchant name listed in the email. Since I had just returned from a European business trip a month ago, I know the card can complete international transactions.

    So, to try again, today I purchased a prepaid Mastercard Gift Card and made sure to purchase more than the amount listed on the site, so I had a buffer for up to a 5% transaction fee. This was also denied with the same message that the bank refused the charge and I needed to contact my bank. I know I went to the appropriate site and 'registered' the prepaid card under my name/address prior to attempting the transaction.

    I'll be honest that I'm a bit frustrated at this point. First confirming with my bank that the information emailed to me was untrue (my bank did not receive any transaction request) then having the dedicated prepaid gift card that I purchased explicitly for this reason was also denied, despite that being the very method of payment suggested by one of the forum posts I had seen searched on this topic.

    Who can I speak to in order to help get this resolved, and guarantee I receive the 20% off discount? I do not deal in bitcoin, so that is not an option.

    I appreciate any help that can be provided. Thank you in advance.
     
  2. MLRTYME

    MLRTYME New Member

    Please disregard. I was able to utilize a family member's crypto-wallet and just pay them back with the Prepaid Gift Card. The crypto purchase was successful.

    Still, It is frustrating to see 2 different advertised payment types not work, specifically after clarification from my financial institution that no attempts to charge were ever made. I hope others in the same situation have more success than I had and that RedFox can review the process to help make it more successful for others in the future.

    Now, onto backing up all the movies I've purchased in the past few years!
     
    DeepSpace and whatever_gong82 like this.
  3. Ivan

    Ivan Admin Staff Member

    Thank you for fighting so hard to purchase from RedFox :bowdown:

    I checked your 3 purchase attempts, the one with Mastercard got denied with "3Dv2 error: Not authenticated/account not verified" and the 2 others Visa attempts got denied with "3DS timeout".

    Looks like redirecting you to your card issuing bank(s) for 3D Secure authorization got stuck somewhere in the middle of the road.

    Can you remember what happened with redirection after you hit the final "Purchase Now" button?

    Make sure, you back them up in the right way (DVD or Blu-ray?) and that you have enough space to back them up :coolman:
     
    DeepSpace and whatever_gong82 like this.
  4. 84Lion

    84Lion Active Member

    I tried to purchase an AS+ upgrade today. Tried our MasterCard (denied) then my wife sent them a text back and they said it was OK to charge. So I tried again, denied again. Then I tried a VISA card and that was denied. Do credit cards in US not work at all?
     
  5. whatever_gong82

    whatever_gong82 Well-Known Member

    Please contact Support or PM (Private Message) @Ivan so that you'll get the help that you need.

    :)
     
    BRCS likes this.
  6. Ivan

    Ivan Admin Staff Member

    Your first two transactions with Mastercard got denied with error "[CODE_83]". I have absolutely no idea what this error indicates.
    Third transaction with Visa got denied with "3Dv2 failed, status 'N': not authenticated/account not verified; transaction denied". Looks like this card is not enabled for "3D Secure v2" authorization.

    I'll do some further investigations and reply to the PM you sent me.
     
    DeepSpace and whatever_gong82 like this.
  7. 84Lion

    84Lion Active Member

    Ivan, per our conversation, many thanks for resolving the issue!

    For those "on the fence," let me say that the Plus upgrade to Anystream is more than "worth it." The queue/batch capabilities alone are fantastic and a great help when downloading TV series.
     
    DeepSpace and whatever_gong82 like this.
  8. Ivan

    Ivan Admin Staff Member

    Thank you for your nice feedback and being a valued customers for so many years...

    :bowdown:
     
    DeepSpace and whatever_gong82 like this.