OPPO .... firmware and related stuff. And also unrelated stuff.

Discussion in 'General Chat' started by Journbon, Apr 2, 2018.

  1. Pelvis Popcan

    Pelvis Popcan Well-Known Member

    That would be my guess as well, however, I would carefully remove *both* sound boards on top and check to make sure there are not ports that match the image in the guide located underneath the sound boards. I remember having to remove both of my sound boards because it wasn't really possible to properly reattach a ribbon cable unless both boards were removed. But I can't remember exactly where my TTL port was located. I agree though the port does not appear to be where it is shown in the guide. I do remember that on my 105 USA model the port location *did* match the guide.

    Make sure you only connect ground, TX, and RX.

    RX pin on board goes to TX pin on adapter, and TX pin on board goes to RX pin on adapter.

    (Are you *sure* this is a 105?)
     
    Last edited: Mar 28, 2019
  2. KBJ2007

    KBJ2007 Well-Known Member

    That doesn't look like the correct board. It should be located on the right side of the player as you view it from the rear and it will be right along the edge of that board near the side wall of the metal case.

    It's a little difficult to tell but the board in the image above looks like it's to the left of the drive assembly on the left side of the player as you view it from the rear. Unless they changed board placement radically from the 103 that it the wrong board.

    Okay, that is the right board, I was looking at it from the wrong side but I don't see the connector port where they're been located on the 103.
     
  3. KBJ2007

    KBJ2007 Well-Known Member

    Found the JVB Digital instruction sheet CN21 is the port number you want. I can't tell from that posted image which port that is as it loses resolution when I zoom in.
     

    Attached Files:

  4. zereu

    zereu Member

    I'm absolutely sure it's a 105 ! So, he told me today that the connector I have circled was the correct one (which is CN6 like the one on his picture but not at the same place). So I tried to flash the firmware and I failed. The first step was ok :
    upload_2019-3-28_23-7-10.png

    but I can't proceed the second one. I never got the
    #
    #
    #

    I just had this :
    upload_2019-3-28_23-9-0.png

    I held the enter button during 5mn but nothing came. It seems the power button is not responding because when I push on it, the led stay red.

    I also tried to restart the first step but nothing happen when I push the power button.

    I'm really worried :-(
     
  5. KBJ2007

    KBJ2007 Well-Known Member

    Sorry, I misread your initial post, I missed that you're trying to load custom firmware, I thought it was just a region-free installation.
     
  6. Pelvis Popcan

    Pelvis Popcan Well-Known Member

    The weird characters in the log window are a sign that your USB to TTL cable isn't compatible with this procedure.

    Try this: Make sure the USB to TTL cable is plugged in to a USB 2 port (not USB 3). Make sure it is plugged directly in to a USB 2 port directly on the computer, not a USB hub. Unplug the player, plug it back in, open MtkTool's log window, and power the player on.

    Do you get any text or any info? If you get legible data, please post it.

    The cable I used for my three 105 players: https://www.amazon.com/gp/product/B00DJUHGHI

    The cable will either have a Prolific chipset or a Silicon Labs chipset. Mine used the Prolific.

    Prolific PL2303 Drivers for Adafruit 954 cable with Prolific PL2303 Chipset

    Silabs CP210X Drivers for Adafruit 954 cable with Silabs CP2102 Chipset

    It is likely that Adafruit cables now have the Silicon Labs chip; Adafruit said it's supposed to be a more reliable chip. But I haven't tested it personally with this procedure.

    I found these which are supposed to use the Prolific PL2303 Chipset: https://www.amazon.com/gp/product/B07D9R5JFK

    If you can, try a new cable (personally I would buy both products linked above as they are cheap enough). After hooking up the new cable, unplug the player, plug it back in, open MtkTool's log window, hold down the ENTER key on the keyboard, and power the player on. What do you get in the log window?

    You *should* see a boot up procedure which eventually starts showing this:

    mt8580_base # ...
    mt8580_base # ...
    mt8580_base # ...
    mt8580_base # ...

    ...and it will keep repeating until you let go of the ENTER key.

    If the player won't power on at all, you SHOULD be able to send it to Oppo. In my experience they are very good about repairing their products, even when they have been modded.
     
    Last edited: Mar 29, 2019
  7. zereu

    zereu Member

    Ok, here's the continuation and end of my adventures :

    This afternoon (15h hours after my fail yesterday), I pressed the power button and I heard the electrical relay swith on and the led turned blue. After swithing off and trying to switch on again, it didn't works as yesterday. So I supposed that there is a capacitor who needs to be empty. I remembered to have read earlier in this forum that for the Oppo 205, the sound board needed to be plugged. So maybe because it wasn't, the capacitor discharge slower than normal. So I plugged back the 2 sound boards and I was able to switch on immediately after a switch off. Then I restarted the whole process from the begining and this time I successed !

    I paid the guy thinking he will send me back the activation key but he just told me to start my oppo 105 with the network cable plugged, wait 10mn and then switch off. It worked perfectly but this way of activating makes me worried now : Maybe he has an access to my network and I don't like that idea at all
    :-/
     
  8. Pelvis Popcan

    Pelvis Popcan Well-Known Member

    He doesn't have access to your network. The player just downloads the activation key from his server. That's it. The player is now permanently activated and will stay activated even if it's not on a network (i.e., network cable unplugged). You can test it by region switching, playing an ISO, etc.

    I believe with the 205 the sound boards don't need connected when flashing. I didn't try that with the 105, so I guess we now know the 105 needs to have the sound boards connected when flashing.

    Glad to hear it worked out for you! :)
     
  9. zereu

    zereu Member

    Yes, it was such a relief when I found what was going wrong ! I performed some tests obviously and it works perfectly. I just don't know how to change the zone zone for dvd and for bluray. I thought it will change automatically .
    Another question : Should I do a factory reset ?
    Thanks for all !
     
  10. Pelvis Popcan

    Pelvis Popcan Well-Known Member

    I factory reset mine. The mod is based on Russian firmware so your player's menu language will be in Russian after the reset. You can change it back to French / English / etc. afterwards.

    I *believe* region switching for DVD is automatic.

    For Blu-Ray, region is changed in "Disc Menu Language". English = Region A, French = Region B, Chinese = Region C. After changing "Disc Menu Language" for region switching, power the player off, then power it back on for it to take effect.
     
  11. RANDALL

    RANDALL New Member

    still have not found an answer or fix for DVD Shrink
     
  12. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    If you're waiting on an update to dvdshrink, you'll be waiting until hell freezes over. Development was stopped years ago due to copyright pressure. And the developer moved on to create imgburn. Part of it's technology is preset in that, but beforehand you ask no it can't handle copyprotected content.

    Sent from my Nexus 6P using Tapatalk
     
  13. Pete

    Pete Forum Admin Staff Member

    Just an observation: roughly 99.9% of this thread are more or less off-topic. Apart from a few posts at first, that actually address the title "OPPO to stop making players".
    Then it immediately turns into discussions about flashing firmwares and such.
    Which is basically fine - but: either split this up or rename the thread altogether, so the title is no longer misleading.

    Just a quick reminder why off-topic is frowned upon: no, not because the rules say so.
    It's because when someone is looking for information regarding Oppo firmware, they will most likely dismiss a thread labelled "Oppo is dead" ;)

    (And I'm not even mentioning DVDShring suddenly materializing out of nowhere - but I suppose, that post has a different ... purpose to be seen soon).
     
  14. James

    James Redfox Development Team Staff Member

    I believe the guy you are talking to is a spambot.
     
  15. Pete

    Pete Forum Admin Staff Member

    ...is what I was hinting at.
     
  16. zereu

    zereu Member

    To be admin on another forum, I just can agree with Pete's point. But I'm sorry, this is not my thread so I will continue here until it will be split if you don't mind.
    Well, I don't have a bluray from another region to try but with DVDs, I have the message "Wrong region code" when I insert DVD from region 1 (I'm region 2).
     
  17. James

    James Redfox Development Team Staff Member

    Is this a message shown by the Oppo, or a still picture coming from the disc?
    If it is a message from the Oppo, something is wrong, activation of the jailbreak did not work.
     
  18. TheEmpathicEar

    TheEmpathicEar Well-Known Member

    I could not get the above link to work. I am interested in getting a custom firmware for a LG UBK80?
     
  19. James

    James Redfox Development Team Staff Member

    The link is http://www.bd-mod.com/
    And no, it won't work with LG players.
     
  20. TheEmpathicEar

    TheEmpathicEar Well-Known Member