Operating speed message

Discussion in 'CloneBD' started by Clarity3, Mar 31, 2018.

  1. Clarity3

    Clarity3 Well-Known Member

    When transcoding to MKV and MP4 files, I get the message ‘Other applications are using a significant amount of processing time and are preventing CloneBD from operating at full speed’

    The usage indicators show:
    CPU usage by other applications at 86%
    CPU usage CloneBD at 14%

    Looking at Task Manger; Clone BD is at 98%, all other apps 0% and system ops and hosts 1% average.

    Transcoding to Partial (same disc title) shows the message ‘CloneBD is operating at optimal efficiency’ and the usage indicators show;
    CPU usage by other applications at 3%
    CPU usage CloneBD at 96%

    The overall time for conversion for MKV and MP4 are the same and for Partial 4 minutes longer, so progress does not appear hampered.

    Is Clone BD seeing itself and reporting as an ‘other application’?
     
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Moved from CloneDVD to CloneBD section. CloneBD is NOT seeing itself as other applications. What other applications are active? Browser, e-mail client etc, those all consume CPU resources
     
  3. Clarity3

    Clarity3 Well-Known Member

    Oops, sorry about that, I didn't notice initially.

    That's the interesting aspect. Nothing else is running, no other applications as seen in Task Manager. If something else was running the usage bars would be the same regardless of transcoding file type.
     
  4. Reto

    Reto Elaborate Bytes AG

    There is a very rare and purely cosmetic bug that causes CloneBD to not recognize it's sub processes (decoders and encoders) as its own and lists them as "other applications".
    Unfortunately we have never been able to reproduce this, so it's hard to fix.
    In any event - it is nothing to worry about, it only messes up this informative message.

    Are you saying that this thing happens every time on your setup?
    Maybe we can add some logging information that would help us to get to the cause.
     
  5. Fabian

    Fabian Developer

    Yes, this is a rare issue. Something, we don't know why yet, the Windows API reports processes that belong to CloneBD as Others. Every time we try to reproduce it, it's gone. And usually, if you try again it's gone as well.