NEW OPTION: 'UHD Friendly' Firmware Downgrade / Cross-Flash Using Official (Modified) ASUS Flasher

Discussion in 'CD/DVD/BD Drives' started by MartyMcNuts, Feb 19, 2019.

  1. MartyMcNuts

    MartyMcNuts Well-Known Member

    OK.Thanks. I'll keep looking at it.
     
    Marty S. McFly likes this.
  2. Marty S. McFly

    Marty S. McFly Well-Known Member

    Thanks :)
     
  3. SamuriHL

    SamuriHL Retired Moderator

    There's no reason it shouldn't work. The calibration data and encryption data are not corrupted. It's just the firmware that's screwed up. If the flash program would ignore that and flash it anyway, then it'd likely work just fine.
     
    Marty S. McFly likes this.
  4. Lazaros Velaetis

    Lazaros Velaetis Active Member

    tried this app and didnt work on LG BH16ns55... with firmware version 1.04
     
  5. SamuriHL

    SamuriHL Retired Moderator

    No app will. That's the version that is a pain in the ass. You need to flash the mk3.10 Asus firmware first then you can flash the DE 1.03 firmware

    Sent from my Pixel XL using Tapatalk
     
    martinjohannes93 likes this.
  6. Lazaros Velaetis

    Lazaros Velaetis Active Member

    tyvm 4 ure help another drive flashed successfully...
     
  7. martinjohannes93

    martinjohannes93 New Member

    I can't downgrade on newer firmware like the 1.03/1.04 directly but through the detour of the Asus firmware 3.10 is working? But only with dosflash?

    And if the LG BH16NS55 comes with 1.02 I can use the modified Asus flash tool on Windows to flash to the 3.02 Asus firmware? Do I have to modify the SATA mode to legacy? Or is this only necessary for the dos flasher?

    In general, the 1.03 allows UHD playback, but only 1.02 or lower also allows ripping? What about the 3.01 or 3.02 Asus firmware? Is ripping possible? I heard that the speed gets increased when flashing the Asus firmware
     
  8. SamuriHL

    SamuriHL Retired Moderator

    1.03 is fine to downgrade. 1.04 is convoluted. And no, you're not doing any dosflash SATA nonsense. And yes you can cross flash if you want.
     
  9. jfcarbel

    jfcarbel Active Member

    I have a BW-16D1HT manf. Feb 2017 that came with 3.00 FW. I flashed it to 3.10MK and noticed that MakeMKV does not report it as a libredrive. Are there some models of BW-16D1HT that are not libredrive capable?

    If that is case I will look to order another more recent BW-16D1HT from Amazon, but concerned since on the stock Asus 3.02FW I recently started getting failures on same media (Verbatim BD-R DL 50GB 6X DataLifePlus White Inkjet Printable) that had many successful burns from same batch of media. Still burns BD-R 25GB without a single problem, just fails on the DL write ones. So thinking its a drive failure and wondering if LG is a better and maybe more reliable drive for me to get.

    Basically would like the ability to burn BD-50 media and read UltraHD is possible in same FW on drive. Suggestions?
     
  10. SamuriHL

    SamuriHL Retired Moderator

    That version is definitely libredrive compatible so you have a makemkv issue going on. Doesn't sound like it's downloading the libredrive support. I would post on the makemkv forum to get help with that issue. No need to flash anything else though. You're good with that drive and firmware.

    Sent from my Pixel 3a using Tapatalk
     
  11. jfcarbel

    jfcarbel Active Member

    K, so I tried couple more things based on what you said. I checked the preferences box for allowing contacting server for updates. Then inserted the UHD disc first and then started the MakeMKV and this time it shows the LibreDrive Information and was able to read disc. Not sure if it was the updates checked since was already running latest version or if the program required a first start with disc inserted to do some cert initialization handshake or some other init.
     
  12. SamuriHL

    SamuriHL Retired Moderator

    Both. But that means you're good to go.

    Sent from my Pixel 3a using Tapatalk
     
  13. ichthys

    ichthys New Member

    I'm just trying to Flash my drive Asus BC-12D2HT (v3.11) to 3.0 and just getting the error "Updating Failure #4". Does anybody know what to do?
     
  14. Danutz75

    Danutz75 New Member

    Hello all,
    I am new here.
    Sorry if my question has been answered before.
    Have an LG HL-DT-ST BD-RE BH16NS40 with the code NS40.
    Tried to run the Flasher on the first page of the thread.
    Windows asked me to install Framework 3.5 (I am running Windows 10).
    Installed it and ran the Flasher. It keeps telling me that my driver is up to date and it's not running the flash: "0 : HL-DT-STBD-RE BH16NS40 1.03".
    Can anyone help me with any info to solve this issue?
    Should I not have installed the Framework 3.5?
    Thanks you for any help...
     
  15. MartyMcNuts

    MartyMcNuts Well-Known Member

    That drive is too old!! NS40 drives are not compatible with UHD and should not be flashed with NS50 firmware!!
     
  16. MartyMcNuts

    MartyMcNuts Well-Known Member

    Please try and flash BW-16D1HT 3.10MK firmware first, then you should be able to flash whatever firmware you want after that.
     
  17. Danutz75

    Danutz75 New Member

    Thank you for your answer. Unfortunately I tried a different "flash app" I found on another thread here and it "worked".
    Now my drive is bricked. Tried re-flashing about 10 times. The only thing working now is the tray.
    Had trouble logging into windows until I disabled the BH16NS40 in BIOS.
    I have an Asus BW-16D1HT arriving from Amazon today. I hope it's the 3.2 or 3.0 version.

    Found a thread about saving the drives bricked with the app I used: "BH14NS40_N1.00-A4_patched.exe".
    It requires reading the flash and cleaning eeprom before reinstalling the official LG firmware.
    Don't know if I should trust it. It requires turning of the drive signature enforcement...
    https://club.myce.com/t/dosflash-v2-0-patched-to-support-bh16ns40-bh16ns55-drives/399911

    Should I waste my time with this or just install the new Asus drive arriving today?
    Thank you for your suggestions.
    Danutz75
     
  18. SamuriHL

    SamuriHL Retired Moderator

    I've not seen anyone recover one of those drives without the use of dosflash. It's possible but it's a major pain in the ass. The thread you linked to is older but essentially describes the process more or less. You need a clean firmware for the drive which it looks like they have linked there, and then you need to use dosflash (your sata port has to be set to IDE mode and most of us boot off a win pe image when we're doing dosflash stuff because you can't use 64 bit windows with dosflash) to extract your current firmware (this is the MOST important step), use the data mover tool to copy the encryption and calibration data from the extracted firmware to the clean new firmware you're trying to flash to. This will create a new firmware bin file that must be written with dosflash. That will recover the drive and then you can put the sata port back to ahci mode. Good times, yea? sigh
     
  19. Danutz75

    Danutz75 New Member

    I may install it in my old 2005 Opteron/Tyan workstation and try to figure it out there.

    I received the Asus BW16D1HT. It's manufactured in January 2019. That probably means that I have to downgrade the flash.
    Should I just use the modified utility on the first page or should I use the more complicated version with DOS you were talking about above.

    It's 3.03, just installed and checked.

    Again, thank you very much for your help.
    All best,
    Danutz75
     
    Last edited: Jun 1, 2019
  20. SamuriHL

    SamuriHL Retired Moderator

    Personally I'd put the MK 3.10 version from MakeMKV on there. It's what I'm using on mine and it rocks.