New in PowerDVD 17

Discussion in 'Third Party Products' started by hadar, Feb 16, 2017.

  1. yungtruth84

    yungtruth84 New Member

    Gents, I dont normally join threads, yet I had to join and post in this one. I read all 26 pages. I was at a loss on getting SGX working on my new build. I am running an i7-7700k with Asus Z270-WS Motherboard. After getting the BOIS updated and the SGX only listed as "Software Controlled" in the BOIS, I could not SGX recognized using Intel's Tool. SGX PSW package wouldnt install. I then took @whirlpool's direction and partitioned my hard drive to UEFI. That got the PSW package to install. Then a new problem popped up. Intel Management Engine wouldnt work, along with SGX not being enabled. I soon got fed up and un-installed the Intel Management Engine. That wasnt smart as I couldnt get it to re-install. After doing some looking online, I decided to do an actual fresh, clean install of Windows 10. That did the trick. I took the PSW and copied it into system32. Ran Power Shell as admin. it installed with no problem. Installed POwerDvd 17, and the adviser. Ran the adviser, and got all green check marks. Popped in Sicario. Got an error the first time. Restarted PowerDvd and it played with no problem. I'm guessing that there were leftover conflicts in the system from me not doing a clean install and trying so many different methods. @triffid you can update your list and confirm that Asus z270-WS is good to go.
     

    Attached Files:

  2. triffid

    triffid Member

    Perfect, thank you for sharing the info!
     
  3. bosstime

    bosstime New Member

    What happened to plug and play? I spent hours researching to pass most tests of Cyberlink's Ultra HD blu-ray advisor. Bought myself new components but still SGX and Intel Engine test (and others) failed. I got there. I have them all green now except the blu-ray drive (it is on the way from Japan) AND what bothers me most: HDR.
    I run an I5 7400 CPU with Intel HD 630 graphics. I get no HDR option in Windows 10 and for example madvr with HDR passthrough does not send HDR signal to my TV. I tried my GTX 960 for that. HDR works fine then but no protected audio/video path there. Bummer.
    I switched back to the onboard graphics hoping there will be a fix or Windows update to get HDR working but I don't think this can be my final solution. 4k is only possible at maximum 30fps with the onboard graphic card?? I want 60fps. I will try a Displayport to HDMI switch because I read somewhere that 60fps must be possible with the onboard HD 630 card. Maybe the displayport to HDMI switch solves my last problem.
    If not: I read that the GTX 1070 has a protected video path. All models? Maybe you guys can shed some light on this. I am looking for a 100% silent solution because it is my living room HTPC. It must be quite.
    What a hassle this whole 4k blu-ray thingy on PC is...
    Thanks for yout time and advice.
     
  4. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    You read wrong. The GTX 10xx series doesn't have SGX support either. It'll have to come from Nvidia through driver update

    Sent from my Nexus 6P with Tapatalk
     
  5. edo1080

    edo1080 Member


    While the standalone players don't.....I mumble if the key or somewhat connected to it is sent through that connection, has anyone tried to wireshark it and log the traffic?

    edit: maybe this is the wrong thread for this question, mods please move this post to the AACS 2.0 there's hope thread
     
    Last edited: Aug 30, 2017
  6. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    The standalone players do that just the same.

    Sent from my Nexus 6P with Tapatalk
     
  7. veggav

    veggav Member

    I just came here to say, thank you!!

    This worked with my 6700K with Asus Maximus VIII (Z170). I can play full UHD BD from iso and folder, including menus.
    The only problem is that you need to output from intel iGPU and my motherboard is hdmi 1.4 so no HDR.

    If I could get the 1080 Ti to output it to my TV I would be good to go for UHD BD.
    I tried a few tricks like changing monitors and things like that but without success.

    When trying to use the 1080 Ti I get initiating UHD BD.. and it gets till the end but won't start the disc.

    There's must be a way to bypass this.
     
  8. veggav

    veggav Member

    Can someone explain this to me?

    I ran PowerDVD Advisor.

    When I'm using my 1080 I get this result:
    8 or 10 bit :8 bit UPGRADE

    When I'm using my intel iGPU (asus maximus hero VIII - Intel 6700k) I get this result:
    8 or 10 bit :10 bit YES

    Both using a HDR TV, same hdmi input, same cable.

    Why the HDMI 2.0 is detected as 8 bit and the hdmi 1.4 is detected as 10 bit?
    I even tried setting nvidia settings to YCbCr 4:2:2 10 bits but it's the same result.
     
  9. x7007

    x7007 Well-Known Member

    Does anyone have issue playing 3D movies with PowerDVD17 ? My TV goes into 3D - 2D loop when trying to play 3D movies, if I play 2D movies or the same 3D movies but just in 2D with 3D disabled, everything works fine... what could be the issue ?

    I had High Performance Mode Enabled - Enable High Performance mode for UHD Videos and displays.

    Something is screwed with Windows 10 1709 and PowerDVD17 ..... it just can't run 3D bluray movies . something with the HDR new settings is messing everything up. it always says HDR is enabled.

    I have LG OLED55C6 3D


    Di-interlacing was for some reason on NVidia Pixel Adaptive and not Default- (hardware de-interlacing

    What does it mean for powerdvd 17 compare to powerdvd 16 which doesn't have it ?

    Revamped Audio Rendering Engine for Windows 7 or above NEW
     
    Last edited: Oct 25, 2017
  10. Watcher0363

    Watcher0363 Well-Known Member

    I am going to vent here and at Cyberlink. So I decided to give powerdvd a shot at 47 dollars this week. What a major disappointment this software is for normal dvd playing. First off when playing from a iso file, it has to mount the file first in a virtual drive. This literally can take up to five minutes with large films. Mean while VLC gets going right away. But the one draw back with VLC is that on some movies it will not play subtitles when it should, such as the sign language scenes in Baby Driver. But that little annoyance is nothing compared to powerdvd always playing subtitles.You can turn it off for a movie but it never stays that way. When you start a new movie the always subtitles are back on. This is ridiculous especially seeing how this problem has been know for a couple of years. Yet they seem to totally ignore people on their site asking how to correct this problem. If I had paid the 149 dollars for this software I would truly be upset instead of just disappointed.
     
  11. BrianG61UK

    BrianG61UK Well-Known Member

    I've owned many versions of PowerDVD from 1.5 up to currently 16. I've never had a problem with subtitles turning on when not wanted. As to mounting ISOs taking ages, well exactly how ancient is your PC?

    Sent from my SM-N9005 using Tapatalk
     
  12. Lostname71

    Lostname71 Member

    You are a genius! Thank you so much for this fix! Worked on my Z270M MSI Mortar (no sgx options at all in bios). Now finally cyberlink advisor passed the UHD test!!!

    Thanks
     
  13. Lostname71

    Lostname71 Member

    Hi,

    I have a Z270M Mortar, it has SGX, but read that the HDMI may be 1.4 not 2.0, and it has a Displayport port but not sure what version. My objective is to play with adapter UHD disk onto either a legit 4K panel (don't own yet) or with adapter that mimics HDCP 2.2 onto my 2K panel. Possible?

    Thanks
     
  14. Ch3vr0n

    Ch3vr0n Translator NL & Mod

  15. Lostname71

    Lostname71 Member

    Its not listed in the specs. Usually if they don't advertise a feature probably means its not supported.

    Guess I'll have to open a ticket to find out..

    Next time I won't assume anything anymore.
     
  16. TeflonDon

    TeflonDon New Member

    After a format and installing the latest PowerDVD 17, I'm stuck on Initiating components for Ultra HD Blu-Ray.... The initiation is only required once......

    Any suggestions?
     
  17. hadar

    hadar Well-Known Member

    Fixed. Thanks for letting me know. :)
     
  18. chriskan22

    chriskan22 New Member

    Hi , i have the same problem , no sgx option , what exactly should i do to make it appear?