New in PowerDVD 17

Discussion in 'Third Party Products' started by hadar, Feb 16, 2017.

  1. triffid

    triffid Member

    What? 32GB RAM? I am sorry, can you just remind me what your HW is, please? ASRock Z270 ITX and S11J drive, right? I do not understand why would you need so much RAM. To play MKVs or to playback UHD BD? You mentioned i5 CPU in some older post, which model is that?
     
  2. Brian owens

    Brian owens Active Member

    Hi Triffid, it is the 7500, 3.8 ghz. max. All the specs are correct u mentioned. I just know that when I upgraded my ram, it worked fine with the videos. An older game also played very well also. 4k blurays played fine at that time before the new ram as far as I remember.
     
  3. BrianG61UK

    BrianG61UK Well-Known Member

    Perhaps the new RAM was faster RAM or maybe you changed from single channel to dual channel.

    Sent from my SM-N9005 using Tapatalk
     
  4. Brian owens

    Brian owens Active Member

    Well, I got the same type, brand and amount as the other stick. It seems the more ram, the better for the CPU to run smoother.
     
    Last edited: May 12, 2017
  5. whirlpool

    whirlpool Member



    If you want to enable SGX with the minimum steps and without resorting to building any code, here's the method which worked for me :

    1. You do need to boot UEFI, but if you are booting Legacy and have Windows 10 Creator's Build and can get the number of Primary partitions down to 3, check out https://www.tenforums.com/tutorials/81502-convert-windows-10-legacy-bios-uefi-without-data-loss.html. Using MBR2GPT.EXE you can achieve this on or offline and verify that it's going to work before you commit to using it. It worked OK for me. (But I did image my System drive before trying it !!!!!)

    2. Set SGX to 'controlled by software' in the BIOS.

    3. I was already running Intel Management Engine 11.6.0.1030, which is later than the prerequisite version, but just in case the full install is required I ran setupME.exe and elected to repair the installation. I can't confirm if this step is essential.

    4. If you run the SGX Platform Capability Tool at this point, you will get the result : 'Intel(R) SGX is not yet enabled, but will be enabled by any Intel SGX application'

    5. You only need to install one piece of software to achieve this and you don't need to install Visual Studio or the SGX SDK or build any code.

    6. All you need to install is the SGX PSW from here https://software.intel.com/en-us/sgx-sdk/download. You need to register an interest but it's a free download. You only need the first item listed. Platform software for Intel® Software Guard Extensions for Windows* (Intel® SGX SDK for Windows*).

    6 Unzip the .exe file and in the \installs folder there's an msi file. You must use the msi file from an admin commandline using the following command : e.g. msiexec /i SGX_PSW_nnn.msi. You should have a new entry in your Programs/Features list - Intel Software Guard Extensions Platform Software

    7. Reboot your machine. Run the Cyberlink UHD Blu-Ray Advisor- Intel SGX Technology Main Board - Pass
     
    triffid likes this.
  6. optical10

    optical10 Member

    Can anyone help me get 3D bluyray disks working with POWER DVD16 Ultra on my LG OLED55C6V passive glasses tv? It only seems to work via 2D - 3D conversion not true 3D!

    EDIT: it's sorted, on the LG's you need to choice 720p @60Hz in Nviida control panel setting NOT 1080p @24Hz.
     
    Last edited: Jun 13, 2017
  7. spcav

    spcav Beta Tester

    I tried this with my GB Z270X Gaming K5

    Strange thing:

    When I get the bios sgx setting at software control (as mentioned in this guide), intel sgx software refuses to install (error: not sgx compatible platform - check bios)

    I have to set bios sgx @ enable for the sgx software to be installed
     
  8. SlyRedB

    SlyRedB Member

    Reading through this tread and some other forums I am a bit confused. Can UHD disc playback on a system without SGX? Basically I was looking at building a new Ryzen system but I want to be able to read UHD Blu-rays. Sorry for asking, I just am a little confused by the info I am reading-some saying you don't need an SGX CPU with conflicting information to why not.
     
  9. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    You're better off asking cyberlink that one. The only info available I can see on the cyberlink site is Intel only with SGX support. Meaning z270 chipset or higher.

    Sent from my Nexus 6P with Tapatalk
     
  10. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    I was messing around today with my system and decided to play around with the SGX setting in my BIOS. It's there but disabled by default. I have the Maximus VIII Extreme (Z170) mobo. I switched it to software controlled. Rebooted. Ran the CyberLink UHD Advisor and it failed the test but I had the option of installing the SGX Platform Software so I did. Rebooted. Ran the test again. According to CyberLink my system now passes the SGX test but fails overall. I still can't playback UHD, however, because: (1) I don't even have a UHD drive, and (2) I am using an NVIDIA GTX 780.
    UHD.png
     
  11. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    That's because the 780 is a security leak. It doesn't support SGX and neither does my 1080 ATM. Though rumor has it Nvidia might be working on an implementation. For uhd playback SGX requires a closed system. From input (drive) to output (screen) and the only way possible right now is if the output device is controlled by SGX. In this case the CPU's graphics component. Hook your screen up to one of the onboard video ports and try again.

    Where did you find that setting btw, mine's the formula I might have a look around. Bios might be due for an update anyway.

    Sent from my Nexus 6P with Tapatalk
     
  12. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    I knew it would fail because of the 780. That was a given. I just didn't expect to be able to pass the SGX test. The CyberLink Advisor actually downloaded and installed the SGX Platform Software for me. The BIOS setting location was under Advanced > CPU in the BIOS, I believe.
     
  13. Adbear

    Adbear Well-Known Member

    No surprise it can pass the SGX test if it has SGX in the BIOS. The Z170 chipset is also supported for UHD playback as long as it has SGX and you can access the Intel GPU.

    If my Z170 chipset laptop allowed me access to the Intel GPU then it would pass everything on the list
     
  14. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    I haven't really worried about UHD so I never did much reading on all the requirements. I had thought 7th gen Intel CPUs (Kaby Lake) were a requirement. My CPU is a Skylake (i7 6700K). Apparently the early 6700K CPUs did not support SGX but subsequent ones did.
     
  15. nilsman

    nilsman Member

    Yes, theoretically a later 6700K could work but I do not think anyone has got it fully working. I sold my 6700K just before I got a UHD drive so never got to try it. Z170 motherboard is confirmed as working though I have that running with a 7700K (although HDR seems to only semi-working on Z170). But another thing to consider is that the 6700K will not hardware decode 10-bit HEVC so it would have to work pretty hard playback the contents of a UHD blu-ray...
     
  16. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    It's got something to do with the S-spec code on the 6700k box. I remember mine marching for support. But it's 'weird' your board passes at all. Cyberlink site says z270.

    Verstuurd vanaf mijn Nexus 7 met Tapatalk
     
  17. nilsman

    nilsman Member

    Z170 and Z270 are almost the same as far as I understand. I think Z270 has some re-arranged/re-configured PCI lanes, Optane support, and maybe some other minor features + newer BIOS. But the rest should be very similar. When I got my UHD drive some Z270 boards had been presented but they were not available in stores yet. So I tested with the Z170 board I already had and it worked (like I suspected it would). To be honest I don't think Cyberlink had even published their full requirements back then...
     
  18. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    The ASUS M8E has one HDMI port and it's version 1.4b. So, it fails. There is also a DisplayPort 1.2 but I don't believe DisplayPort supported HDCP 2.2 until version 1.3. So, in the end it appears UHD won't be possible.
     
  19. BrianG61UK

    BrianG61UK Well-Known Member

    Well if you only had one stick of RAM before you would almost definitely have been stuck at a low memory bandwidth.
    You nearly always need to split the memory between two (sometimes four) sticks to get the full memory bandwidth the chipset is capable of.
     
  20. triffid

    triffid Member

    No, SGX is mandatory. So no Ryzen for now.

    Z170, Z270 and Z370 chipsets/motherboards do not have native support for HDMI 2.0. That is why the manufacturers must use a LSPCON chip if they want to make a motherboard with onboard HDMI 2.0. And that is why there is so few of these boards. In theory it should be possible to do the same externally - i.e. to put an active adapter from DP to HDMI 2.0/HDCP 2.2 between your Z170 DP output and your HDMI 2.0 monitor.