New in PowerDVD 17

Discussion in 'Third Party Products' started by hadar, Feb 16, 2017.

  1. triffid

    triffid New Member

    Really interesting thread. My computer plays UHD BDs already, yet I am still curious about other people's progress on this field. It was not easy for my wallet, but in the end I decided to do exactly what CyberLink suggests and I bought new compatible components in order to use the drive from Pioneer. My previous PC was old and not very powerful, so I needed to replace it anyway. However I totally agree with many people here: the UHD BD playback is not worth it if you have - say - less than 2 years old X99 or Z170. My first BD drive was also from Pioneer, their (probably) first model at that time. It was equipped with an IDE connector, not SATA, and it was capable of burning BDs at 2x. I needed to wait almost a year before I could afford stronger CPU and GPU to be actually able to watch BD movies. So this situation is old news for me and I expected some troubles since December 2015 when I started to read about upcoming UHD discs in February. I knew from the beginning I will buy everything needed to make it work and I did it. I was playing with the idea of buying Ryzen or wait for Intel X299 and then I simply gave up and bought Z270.
    I noticed many of you found our thread at blu-ray.com, where we discuss similar matters. Again and again the same questions. If you don't mind, this is how I see the whole thing now:

    Software
    CyberLink PowerDVD is the only solution. I doubt the other BD software companies will ever get the licence. Currently only custom PDVD 14 bundled with Japanese and US Pioneer drives is working. The leaked PDVD 17 is not and its startup screen does not show the UHD BD logo (actually almost no logos at all). This will change in April, when the retail version comes out.

    upload_2017-3-17_19-47-54.png

    Support
    Do not ask for any support. You will get either a worthless generic answer or nothing (ASUS, ASRock, CyberLink etc.). Unfortunately the only country where a customer's satisfaction is above all, is Japan. Pioneer Japan answers polite, to the point and within 2 days.

    Drive
    Pioneer BDR-S11J-BK, BDR-S11J-X, BDR-211UBK and BDR-XD06J-UHD (external) are obviously OK and it seems much older LG notebook drives BU40N and BU50N are too. Now when CyberLink UHD BD Advisor is here, everybody can test their LG BH16NS55 or anything else and see if it is compatible or not. I doubt it and I also doubt any update can make it work. LG wants to sell new drives, not give you an update for free.

    Motherboard
    List of possibly compatible mobos is here: http://forum.blu-ray.com/showpost.php?p=13271422&postcount=108 The motherboard's BIOS must support SGX and it must be enabled manually because the default setting is probably Disabled. It also needs additional Intel software downloadable from the motherboard's support page.

    CPU
    KabyLake i5 or i7 with IGPU 630/640. There are some SGX compatible SkyLake CPUs with S in the code, but these should not work.

    GPU
    Only the IGPU above is available now. Any graphics card will ruin the secure environment, even if it is HDCP 2.2 compatible. If the motherboard has dual BIOS, it is possible to set one to use with a graphics card and the other with the IGPU.

    HDR
    As far as I know 4k HDR monitors are not available yet, the first are coming from LG (one model) Acer (one model) and ASUS (two models) this year.

    upload_2017-3-17_20-40-2.png
     
    Last edited: Mar 18, 2017
  2. Jeff R 1

    Jeff R 1 Well-Known Member

    So what is the advantage of having two HDMI outs on MoBo ?
    So one can connect up the audio to a non-compatible AVR and the other to the display ?
     
  3. jmone

    jmone Well-Known Member

    Any advice if the new gen NUC7 (like the NUC7i7BNH with iGPU Iris Plus 650) will met the requirements?
     
  4. Jeff R 1

    Jeff R 1 Well-Known Member

    If it's SGX enabled, it should work, but you'll need an external UHD drive, obviously.
     
  5. triffid

    triffid New Member

    No. U processors are not supported, see the Minimum requirements table https://www.pioneerelectronics.com/PUSA/Computer/Computer+Drives/BDR-211UBK#specs
    Desktop dual core i3 is not supported either. 4-core S and H CPUs only. And HD 630 graphics is not the same as Iris plus.

    Actually there is no motherboard with two HDMI 2.0 outputs. Some have HDMI 2.0 + HDMI 1.4. I did not try DP to HDMI adapter yet, I must find one in my closet. I bet the adapter will break the "protected path"...
     
    whatever_gong82 and nebostrangla like this.
  6. Adbear

    Adbear Well-Known Member

    According to the Cyberlink website they support
    Which implies they do support Iris plus 640 or above. Also no mention of it having to be higher end 'i' CPU's on the Cyberlink website just from the 'i' range so some of those NUCs should work. Hopefully when they officially release PDVD 17 they will give a more comprehensive list. It's always possible that it doesn't work with the PDVD 14 bundled version.

    With regards to the DP to HDMI, there is a DP to HDMI2 convertor available
    http://www.club-3d.com/index.php/products/accessories/audio-video-adapters.en.html
     
    Last edited: Mar 18, 2017
  7. Gizzmo

    Gizzmo Active Member

    Brian, the Cyberlink Advisor shows it supports HDR, after using the HDCP
    activation tool from Asrock, it also shows HDCP 2.2 for the Mobo HDMI port.
    So yes HDR should be fine but don't know which player to use to test the HDR
    output.

    Brian, yes I am using Club3D DP to HDMI adapter, because I can't get HD audiobitstreaming
    to work with direct HDMI port. AV-receiver can't recognize the stream and tells
    me "unknown". With that adapter the Cyberlink advisor shows me HDCP 2.2 O.K. but
    no HDR. Maybe because I think HDR is supported with DP 1.3 and not with DP 1.2.
     
  8. nebostrangla

    nebostrangla Well-Known Member

    @triffid
    Welcome to the RedFox forums community.
    Knowledge is best when it's shared.
     
  9. triffid

    triffid New Member

    You are right. I did not notice the slight difference between CyberLink's and Pioneer's requirements. Thus the U-type CPUs may be compatible after all.
    How about your LG BH16NS55 and BU40N drives? Did they pass the UHD BD Advisor test or not?

    Thank you. Actually I am not new here, but I never felt an urge to register and join the discussion before.
     
    Last edited: Mar 18, 2017
    whatever_gong82 likes this.
  10. Adbear

    Adbear Well-Known Member

    My drive does pass, but I can't test it as I have no access to the iGPU on my laptop
     
  11. Jeff R 1

    Jeff R 1 Well-Known Member

    Yes for sure, but just don't get any sea water on him. :)
     
    whatever_gong82 and nebostrangla like this.
  12. MisterXDTV

    MisterXDTV Well-Known Member

    Ok guys this in unreal:

    I ripped a UHD disc to ISO using AnyDVD Ripper, mounted the ISO with Virtual Clone Drive and tried playing it in PowerDVD 17.

    Now SGX is no longer required and I can see the main menu!!!! It even asks me if I want to play it without HDR!

    Problem is when I tried to watch the actual movie, I can see the "seeking bar" at the bottom but the rest of the screen is black.

    I have only a 1080p display and a 1080p monitor. Is it because of HDCP 2.2??

    Anyway this is very good news! it's a progress somehow
     
    Last edited: Mar 20, 2017
    Jeff R 1 likes this.
  13. Jeff R 1

    Jeff R 1 Well-Known Member

    What did you use to rip it with, one of the new Pioneer drives or one of the LG ones that can only see the files ?
    Don't remember what you have and I'm too lazy to sift through all the threads to find out. :whistle:
     
  14. MisterXDTV

    MisterXDTV Well-Known Member

    I have "one of the LG that can only see the files" BH16NS55 firmware 1.02 :)
     
  15. manixx2020

    manixx2020 Well-Known Member

    I too tried this with a ISO UHD of pan & had the same result, using that same drive to rip but pan was one off those realeses without HDR.
    But tried this on my early m series vizo 4K
    Which also does not have HDR.
     
  16. Adbear

    Adbear Well-Known Member

    It will most likely be down to the AACS encryption. You've essentially made a protected ISO, So the copy protection is still intact
     
  17. etc6849

    etc6849 Member

    So is the BU50N drive confirmed by LG to work? I can't go off what some reseller adds to the title on their site as I don't want to waste $80. Link to spec sheet stating it will work with 4k bluray discs would be appreciated. Have met all other requirements with Windows 10 preview, Asrock Fatil1ty gaming ITX board, i7 kaby lake:
    4k UHD bluray advisor.png
    May just wait until April and buy the software. Sucks as it holds up my PC build since I'd rather use a case that fits a slim optical drive if possible.

    For hooking to my AV processor, I was thinking about the HDFury Integral HDMI2.0a splitter (one output to TV other to processor) combined with an HDFury Link (to down convert for my older processor). Any better options (besides a standalone 4k player)? Not ready to buy a new $3k processor.
     
  18. imhh1

    imhh1 Member

    on my system I cant pass this using the igpu (hdmi 1.4 only):
    dxfasf.PNG

    And using my Gtx1070, i get this msg:
    1.PNG

    i7 7700k, 16gb ram
    asrock 270 pro4
    lg WH14NS40
    4k/HDR TV
    gtx1070
     
  19. etc6849

    etc6849 Member

    Please try these steps I used for my board:

    Ok, got the grey screen issue fixed unless PC comes out of standby (then need to replug HDMI cable). A few notes with my ASROCK Z270 Fatal1ty Gaming ITX board:
    1. Updated to the beta bios (copy file to USB, then update from BIOS).
    2. Set PRIMARY graphics to onboard (although I didn't have a card in the PCI-Express slot, go figure!?!)
    2.1. Remove all other graphics cards.
    3. Set graphics mode to single in bios.
    4. Set SGX to "Software" or "Enabled" in bios for Netflix 4k to work. Unfortunately, the Cyberlink UHD adviser tool wants manually enabled. Both these options still give me a periodic grey screen which requires unplugging the plugging the cable in. Using enabled now and it seems fine unless PC comes out of standby and I try Netflix app.
    5. Install windows 10 creator preview version (this is what I'm using). Supposedly this version supports HDR, but I'm not sure if this is necessary or not... Instlall latest intel 630 graphics driver and the MEISetup.exe from Asrock's website under downloads for your board.
    6. After changing any of the previous bios settings, ALWAYS reinstall the latest intel graphics driver (took me a long time to realize this).
    7. Also rerun MEISetup.exe from asrock's website if you change bios video or SGX settings and still get an error in Netflix.

    If this doesn't work, verify your motherboard has the mediatek chip for handling HDCP2.2. I am assuming it does, but you didn't paste the advisor tool results.

    Now, please try all this and let us know if your drive works ;) A PM to where you found the trial PowerDVD 17 software and version number would also be greatly appreciated ;)


    EDIT: if HDCP 2.2 doesn't work, try the asrock hdcp tool to reprogram key (found under support page for your motherboard).

    If it still doesn't work, run this tool and post a screenshot of the advisor results:
    http://update.cyberlink.com/OEM/Pat...ltraHDBlu-rayAdvisor_1313_BD_CDT170123-01.exe

    You can also try the Netflix app from the Windows Store. When playing a 4k video Control+Shift+Alt+D will show the resolution and bitrate in Netflix. I'd think if you get Netflix working in 4k (takes a minute to buffer and reach 4k), your drive is what is holding you back or you need the a different version of the PDVD 17 beta...

     
    Last edited: Mar 20, 2017
    imhh1 likes this.
  20. triffid

    triffid New Member

    Z270 Pro4 does not support HDMI 2.0 and thus ASRock is not offering the HDCP key toolkit for it.
    As far as I know, Z270 and Z170 ITX/ac are the only two compatible motherboards by ASRock.
     
    imhh1 likes this.