Neverwinter Nights 2 Mask of the Betrayer Vista Ultimate 64 bit OS problem

Discussion in 'GameJackal' started by Webslinger, Feb 26, 2008.

  1. Webslinger

    Webslinger Retired Moderator

    O.k., I am having a problem. This may be a first . . . ;)

    By the way, storywise, Mask of the Betrayer is much better than the original campaign, in my opinion. If you enjoy a good story, Mask of the Betrayer is well worth the purchase.



    1. Using GameJackal Pro 3.0.0.6

    2. Vista Ultimate 64 bit OS with all Windows Updates installed (but not service pack 1)

    3. I don't think this is a blacklisting issue with third party programs. The game runs fine without using the Game Jackal profile

    4. I hate packet writing software, so I don't have any installed

    5. nwn2main.exe SecuROM detectected - Version 07.35.0008

    6,7. Mask of the Betrayer (Neverwinter Nights 2 expansion) Game version 1.11.1153 English (latest patch updates)

    8,9. Mask of the Betrayer appears to be distributed on a single layer dvd-rom disc, and this disc was distributed in Region 1.

    Media is a DVD.
    Booktype: dvd-rom (version 1), Layers: 1
    Total size: 1018544 sectors (1989 MBytes)

    10. Intel Quad core Q6600 (nothing is overclocked at the moment)

    The Game Jackal application is using processor 2.
    Profiles (games) is defaulting to processor 1.

    11. TSSTCORP SH-S203N (Samsung SATA burner) and also tried with a Plextor PX-760a (not SATA)

    12. Kaspersky Internet Security 7.0.0.125

    13. I created a profile using the Automatic profile option--and I also created another profile using the Neverwinter Nights 2 profile option. I get this error message with both profiles I created: "Please insert the Neverwinter Nights 2 Play disc." (with Retry and Cancel button options). When I put in the original Mask of the Betrayer disc, the game runs fine.

    I have been profiling nwn2.exe. I guess I'll try nwn2main.exe next. Then I'll try capturing in .image mode.


    14.
    Code:
    Game Jackal Launcher log file
    Log date - 26/02/2008 2:58:48 PM
     
    ***********************************************
    [26/02/2008 2:58:48 PM] Launcher starting...
    [26/02/2008 2:58:48 PM] Program - C:\Program Files (x86)\Atari\Neverwinter Nights 2\nwn2.exe
    [26/02/2008 2:58:48 PM] Parameters - 
    [26/02/2008 2:58:48 PM] Directory - C:\Program Files (x86)\Atari\Neverwinter Nights 2\
    [26/02/2008 2:58:48 PM] Processor mask - 1
    [26/02/2008 2:58:48 PM] MaplomH - C:\Program Files (x86)\SlySoft\Game Jackal\85796H.dll
    [26/02/2008 2:58:48 PM] Cmdline - "C:\Program Files (x86)\Atari\Neverwinter Nights 2\nwn2.exe"
    [26/02/2008 2:58:48 PM] Process will be created in a suspended state.
    [26/02/2008 2:58:48 PM] C:\Program Files (x86)\SlySoft\Game Jackal\85796H.dll loading...
    [26/02/2008 2:58:48 PM] C:\Program Files (x86)\SlySoft\Game Jackal\85796H.dll loaded successfully.
    [26/02/2008 2:58:48 PM] Resuming process.
    Code:
    Game Jackal log file - Profile
    Log date - 26/02/2008 3:04:36 PM
     
    ***********************************************
    [26/02/2008 3:04:36 PM] Profile - Neverwinter Nights 2
    [26/02/2008 3:04:36 PM] Profile mode: 2
    [26/02/2008 3:04:36 PM] Profile CP: 1
    [26/02/2008 3:04:36 PM] Driver mode: 13534
    [26/02/2008 3:04:36 PM] Using external launcher - C:\Program Files (x86)\SlySoft\Game Jackal\85796L.exe
    [26/02/2008 3:04:46 PM] Warning, external shutdown of driver detected!
    [26/02/2008 3:04:46 PM] Media information
    [26/02/2008 3:04:46 PM] Name - NWN2MOTB
    [26/02/2008 3:04:46 PM] Serial - 2105xxxxx
    [26/02/2008 3:04:46 PM] Size - 0
    [26/02/2008 3:04:46 PM] Profile deactivated.
    
    15.


    Upper Device Filter: [None Found]
    Upper Class Filter: maplom
    Device: CD/DVD-ROM Device
    Lower Class Filter: maploml
    Lower Class Filter: ElbyCDFL
    Lower Class Filter: ElbyDelay
    Lower Class Filter: AnyDVD
    Lower Device Filter: [None Found]

    Filter Name: maplom
    File Name:
    File Version:
    File Description:
    Product Name:
    Product Version:
    Company Name:
    Copyright:

    Filter Name: maploml
    File Name:
    File Version:
    File Description:
    Product Name:
    Product Version:
    Company Name:
    Copyright:

    Filter Name: ElbyCDFL
    File Name: C:\Windows\System32\Drivers\ElbyCDFL.sys
    File Version: 5, 2, 1, 3 [5.2.1.3]
    File Description: ElbyCDIO Filter Driver
    Product Name: CloneCD
    Product Version: 5, 2, 1, 3 [5.2.1.3]
    Company Name: SlySoft, Inc.
    Copyright: Copyright (C) 2003 - 2006 SlySoft, Inc.

    Filter Name: ElbyDelay
    File Name: C:\Windows\System32\Drivers\ElbyDelay.sys
    File Version: 5, 1, 0, 1 [5.1.0.1]
    File Description: Elby Delay Lower Filter Driver
    Product Name: CDRTools
    Product Version: 5, 1, 0, 1 [5.1.0.1]
    Company Name: Elaborate Bytes AG
    Copyright: Copyright (C) 2003 - 2006 Elaborate Bytes AG

    Filter Name: AnyDVD
    File Name: C:\Windows\System32\Drivers\AnyDVD.sys
    File Version: 6.3.1.5
    File Description: AnyDVD Filter Driver
    Product Name: AnyDVD
    Product Version: 6.3.1.5
    Company Name: SlySoft, Inc.
    Copyright: Copyright 2002 - 2008 SlySoft, Inc.
     
    Last edited: Feb 26, 2008
  2. Webslinger

    Webslinger Retired Moderator

    O.k. well, profiling nwn2main.exe didn't help either.

    I guess I'll try an image this time.
     
    Last edited: Feb 26, 2008
  3. Webslinger

    Webslinger Retired Moderator


    Using the image option didn't work either. I still get the same error message.
     
  4. matthew

    matthew SlySoft Team Member

    This is one of our test games so I will take a look.

    Quick question... is this with v3.0.0.6 only?
     
  5. Webslinger

    Webslinger Retired Moderator

    Just to clarify, Mask of the Betrayer is the NWN2 expansion disc. I'm profiling using the expansion dvd.


    With 3.0.0.5 I couldn't even create a profile in Vista 64 bit Ultimate edition. The game while profiling would attempt to launch, and the game did launch, sort of: the black screen appeared, the windows mouse pointer appeared--and then while waiting for the mouse pointer to change into that thick pointy mouse icon the game uses--the game would freeze.

    With 3.0.0.6, I can, at least, create a profile, but the profile doesn't work with Vista 64 bit Ultimate edition.
     
    Last edited: Feb 26, 2008
  6. matthew

    matthew SlySoft Team Member

    I will need to get a hold of this... will do it ASAP.

    That is strange... between 3.0.0.5 and 3.0.0.6 we only changed some PNP functionality which should not have effected the drivers performance.

    Can you export the profile and send it to me (I will PM you with an email address)?
     
    Last edited: Feb 27, 2008
  7. Webslinger

    Webslinger Retired Moderator

    Okay, the one that I sent was the one that I created in image mode that doesn't work.
     
  8. Starfield

    Starfield Member

    Just did nwn2 with xp last night

    Choose the profile from the drop down
    did nwn2main_amdxp.exe (have amd processors)

    Vista 64, all updates. Game patched with all updates.

    Have not had any issues with 3.0.0.5, will update to 3.0.0.6 shortly and try.

    I know you have an Intel processor, but might be worth a shot trying the amd one just in case.
     
  9. Webslinger

    Webslinger Retired Moderator

    I am not using an AMD processor, much less Windows XP though.


    Are you creating a new profile--or are you using an old one?

    Are you profiling the Mask of the Betrayer dvd?

    I'm playing Mask of the Betrayer (and not the original NWN2 game).
     
  10. Webslinger

    Webslinger Retired Moderator

    On a whim, I went into the motherboard bios settings, and I changed the SATA devices from the "RAID/IDE" setting to "IDE". Now the Game Jackal profile is working perfectly fine. I wonder whether some people's problems are related to SATA settings in their motherboard's bios.


    Anyway . . .

    Woot! :rock:
     
  11. Webslinger

    Webslinger Retired Moderator

    Argh! I rebooted, and now my profile isn't working again. I don't get it. :(
     
  12. Webslinger

    Webslinger Retired Moderator

    Sigh

    I rebooted, and now the profile is working again. This is nuts.

    I wonder if running two hard drives in raid 0 has anything to do with this issue.
     
    Last edited: Feb 29, 2008
  13. Webslinger

    Webslinger Retired Moderator

    Rebooted. The profile isn't working again.

    I guess I'll try some other things over the weekend.

    I think switching the way SATA operated in bios had no effect.
     
  14. matthew

    matthew SlySoft Team Member

    I have PM'd you with some info.
     
  15. Starfield

    Starfield Member

    Sorry for the lack of info

    I'm using vista 64, not xp
    Created a new profile
    Used the Mask of the Betrayer DVD
     
  16. Webslinger

    Webslinger Retired Moderator

    I have done what you requested. I used Game Jackal 3.0.0.7 by the way.

    No change
     
  17. Webslinger

    Webslinger Retired Moderator

    The profile I created yesterday with an older version of Game Jackal worked sporadically (alternated from working to not working on each reboot), so I can see that Game Jackal does likely support this game properly.

    I wonder if the problem has anything to do with using Raid 0 and some sort of raid controller or caching issue. Seems like the problem might be timing related . . .
     
    Last edited: Mar 3, 2008
  18. Webslinger

    Webslinger Retired Moderator

    3.0.0.9 fixed the problem I was having. :clap:

    By the way, the 1.12 patch is out for NWN2.