MEncoder.exe error

Discussion in 'CloneDVD mobile' started by JJW, Dec 3, 2007.

  1. JJW

    JJW New Member

    When I try to convert a movie to use on my iPod Nano it tells me:

    "mencoder.exe has encountered a problem and needs to close"

    Afterwards it gives me details which are as followed:

    "File 2 "C:\Program Files\SlySoft\CloneDVDmobile\apps\mencoder.exe" - -af volume=10 -aspect 16:9 -of lavf -lavfopts format=mp4 -oac lavc -ovc lavc -lavcopts aglobal=1:vglobal=1:vcodec=mpeg4:acodec=libfaac:vbitrate=323:abitrate=128 -vf pp=fd,scale=320:180,harddup -info name="DVD_VIDEO" -ofps 25 -o "C:\Program Files\SlySoft\CloneDVDmobile\.mp4" 109 TCE

    Encoder output:

    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp."

    I have tried looking over these forums and can match my problem with theirs, although they arn't very helpful and still leave me with this problem. Can someone please diagnose my problem and please help me. I've tried finding a new mencoder.exe but can't find one anywhere using google or limewire.
     
  2. srtravis

    srtravis New Member

    I have the same error when I try to use the xbox360 h.264 profile with 2 or 3 passes. When I choose 1 pass, the encoding works fine. I was just checking to see if anyone had found a fix to this error.

    This is my error details:

    File 2 "C:\Program Files\SlySoft\CloneDVDmobile\apps\mencoder.exe" - -af volume=10 -aspect 16:9 -of lavf -lavfopts format=mp4 -oac lavc -ovc lavc -lavcopts aglobal=1:vglobal=1:vcodec=libx264:coder=1:acodec=libfaac:vbitrate=1721:abitrate=128:vpass=2 -vf pp=fd,scale=720:405,harddup -info name="lost 3 episode 1-1" -ofps 30000/1001 -o "C:\rip\clonedvdm\lost episode 1.mp4" -passlogfile "C:/rip/clonedvdm/mencmpass3136.log" 232 TCE

    Encoder output:

    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    2pass failed: reading from filename=C:/rip/clonedvdm/mencmpass3136.log
    FATAL: Cannot initialize video driver.
     
  3. alexb

    alexb New Member

    Same problem here

    Clone DVD mobile version 1.1.6.0

    On Ipod or Apple TV preset.
    1 Pass works fine. 2nd and third are getting this error:

    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    2pass failed: reading from filename=G:/***/**/mencmpass1964.log
    FATAL: Cannot initialize video driver.
     
    Last edited: Dec 27, 2007
  4. KnoWei

    KnoWei Well-Known Member

    link

    You don't need a new mencoder.exe. These are all parameters that are set probably in a master config file. I don't understand enough about how CloneDVD Mobile is put together yet. But all of the "-something" terms are the various settings used to configure MEncoder for the conversion you are running at the time.

    There is a Devices.ini file in your Slysoft program directory but the "spp" setting does not appear in that file. So I believe these are settings that Slysoft Development is setting elsewhere.

    You'll have to wait for someone with more knowledge of the internals.

    You can read about the parameters at the http://www.mplayerhq.hu/design7/info.html#docs website. The doc co-mingles MEncoder terms and MPlayer terms so be sure you know what section you are reading.
     
  5. alexb

    alexb New Member

    So what.

    I bought Clone DVD mobile that I do not have to set my parameters for Mencoder by hand...

    Exchanging the Mencoder exe will not fix the problem. Two and three pass encoding worked fine in the version before 1.1.6.0.


    Slysoft developer, please help us with this issue.

    I read in a different thread that this problem existed before and it got fixed with an update.

    Alex

    PS: To recreate this problem use a movie DVD (I tried it with my personal copy of Pete's Dragon and Sicko) and set your settings (in my case) to Ipod Gen. 5 or Apple TV and two or three pass encoding. Changing the bit rate has no effect on this error.
     
    Last edited: Dec 28, 2007
  6. alexb

    alexb New Member

    right now it works again

    I re-installed the software for the third time and yes, after each installation I restarted my PC but now it seems to work.

    Pretty weird but sometimes you can't change things the way they are.
    I will keep this problem in mind.


    Thanks to everybody!

    Alex
     
  7. jaraco

    jaraco New Member

    Getting same error

    I'm getting the same error with the XBox 360 profile (2 pass encoding).

    I've completely uninstalled and re-installed CloneDVDmobile. I've restarted the computer. The problem persists.

    I've installed CloneDVDmobile on another computer and the problem also is exhibited there.

    Alex suggested re-installing and restarting 2-3 times. Is this really the best known solution to this issue?
     
  8. jaraco

    jaraco New Member

    I don't think it matters how many times I reinstall and restart my computer. It still fails.

    I do note that after it fails, a new file has been created in c:\Program Files (x86)\SlySoft\CloneDVDmobile\x264_2pass.log (even though the 2nd pass is looking for the file in the same directory as the target file). So it seems that either the mencoder isn't working properly or the profile is misconfigured.

    Please help.
     
  9. Spanky

    Spanky Well-Known Member

    Mencoder when 2 pass is used the video bit rate should not exceed 1500 and audio for mp4 should be 24 kHz and 48kHz for H.264. This is all I know to try.
     
  10. babelfishka

    babelfishka New Member

    Is it just me?

    Shouldn't SlySoft be doing a little QA on these releases before putting them out in the world?

    I've been waiting for a fix on the AppleTV multipass error for months - I've not even bothered to write on the forum about it, because there are already so many people talking about it (or the xbox multipass, or the ipod multipass, etc). It appears the solution is either to continue waiting, or to make changes to a mysterious profile that everyone keeps talking about. Isn't that why we bought this software to begin with...? so it would just work? Or am I expecting too much from a commercial product?

    Is that problem that everyone has a different hardware setup? If so, why would changing a profile fix that?
     
  11. Peer

    Peer Redfox Development Team Staff Member

    I'm not aware that this problem exists with the current version.
    But then again: I have no idea, what version you are using ;)
     
  12. martngh

    martngh Guest

    i think you should wait for the Apple authority to resolve the problem, don't let others do some RnD.
    here, i think i would like to share - a few days back i found a article websites from which you can get plethora of articles on repairing an exe corrupt file, you can have a look.
     
    Last edited by a moderator: May 6, 2011
  13. hello friends


    May i think to you should wait for the Apple authority to resolve the problem.so don't let others do some RnD here, i think would like to share - a few days back I found a article websites from you can get plethora of articles on repairing an exe corrupt file so you can have a look.

    So Mencoder 2 pass is used the video bit rate should not exceed 1500 and audio for mp4 should be 24 kHz and 48kHz for H.264. so This is all I know to try.