medieval II total war

Discussion in 'GameJackal' started by cybmole, Dec 1, 2007.

  1. cybmole

    cybmole Well-Known Member

    slysoft latest full release.

    game version (UK) 1.0 retail patched to 1.2 with offical patch

    usign the profile option for this game from the drop down menu.

    either fails immediately - game asks for DVD to be inseted - or works for a short while then fails as before.

    DVd has safedisc protection.
     
  2. Webslinger

    Webslinger Retired Moderator

  3. cybmole

    cybmole Well-Known Member

    1. What version of Game Jackal are you running?
    latest 610
    2. What Operating system are you using? 64 bit? service pack?
    xp home SP2
    3. If you have virtual drives, disable them while profiling and playing profiles.
    n/a.
    4. Remove packet writing software from your system (including Roxio's Directcd, Nero's Incd, Roxio/Sonic's DragtoDisc, Drive Letter Access, CyberLink InstantBurn, NTI's Filecd, etc.)
    n/a- but how can burn software affect things . I don't like the implication that I can never use any of the above if I want to juse GJ???

    5. What protection does your game use? .
    safedisc ( any you guys should already now that as your program includes a profile for the game ! )
    6. What is the name of the game you're trying to run?
    medieval II total war
    7. What is the version of the game?
    1.2
    8. Is it cd or dvd version?
    DVD
    9. What region or country is the original disc from?
    UK
    10. What cpu are you running?
    pentium 4
    11. What optical drives (dvd-rom,cd-rom, burners) are you using to create profiles with? What firmware version is installed on your reader?
    as supplied my Dell with PC
    12. What security software (firewall, antivirus) are you using? Please provide version numbers.
    disabled

    13. Describe your problem, provide full error messages, and please state clearly what you were doing when you received those error messages.
    game immediately asks for DVD when lauched from GJ profile
    14. Game Jackal log file - Proc Monitor
    Log date - 02/12/2007 08:05:44

    ***********************************************
    [02/12/2007 08:05:44] No process found!
    [02/12/2007 08:05:44] Process ID 0 was not found, debouncing...
    [02/12/2007 08:05:44] Process ID 0 still was not found, searching for another process...
    [02/12/2007 08:05:44] Process ID 0 was still not found, leaving...
    [02/12/2007 08:05:44] Process method used, monitored medieval2.exe
    Game Jackal log file - Profile
    Log date - 02/12/2007 08:06:14

    ***********************************************
    [02/12/2007 08:06:14] Profile - Medieval II - Total War
    [02/12/2007 08:06:14] Profile mode: 2
    [02/12/2007 08:06:14] Profile CP: 2
    [02/12/2007 08:06:14] Driver mode: 15851
    [02/12/2007 08:10:20] Media information
    [02/12/2007 08:10:20] Name - MEDIEVALII
    [02/12/2007 08:10:20] Serial - 2857801
    [02/12/2007 08:10:20] Size - 0
    [02/12/2007 08:10:20] Profile deactivated.
     
  4. cybmole

    cybmole Well-Known Member

    I hve having to do all of this geeky stuff, but 1) I did find & delete a couple of ROXIO utiltities ( must have been on the PC whn I bought it)
    2) downloaded the imgburn thing & here's what it says about my filters:

    now is there anything else you need to know , or that I need to do before trying yet again ???
    ===============================================
    Filter Driver Load Order - ImgBurn v2.3.2.0
    ===============================================

    Upper Device Filter: redbook
    Upper Class Filter: maplom
    Upper Class Filter: NTIDrvr
    Device: CD/DVD-ROM Device
    Lower Class Filter: PxHelp20
    Lower Device Filter: imapi

    Filter Name: redbook
    File Name: C:\WINDOWS\system32\DRIVERS\redbook.sys
    File Version: 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
    File Description: Redbook Audio Filter Driver
    Product Name: Microsoft® Windows® Operating System
    Product Version: 5.1.2600.2180
    Company Name: Microsoft Corporation
    Copyright: © Microsoft Corporation. All rights reserved.

    Filter Name: maplom
    File Name: C:\WINDOWS\system32\Drivers\maplom.sys
    File Version: 2, 9, 18, 608 [2.9.18.608]
    File Description: Maplom.sys
    Product Name: Game Jackal
    Product Version: 2, 9, 18, 608 [2.9.18.608]
    Company Name: SlySoft Inc.
    Copyright: Copyright © 2007 SlySoft Inc.

    Filter Name: NTIDrvr
    File Name: C:\WINDOWS\system32\DRIVERS\NTIDrvr.sys
    File Version: 1, 0, 0, 6 [1.0.0.6]
    File Description: NTI CD-ROM Filter Driver
    Product Name:
    Product Version: 1, 0, 0, 6 [1.0.0.6]
    Company Name: NewTech Infosystems, Inc.
    Copyright: Copyright (C) 2002 NewTech Infosystems, Inc.

    Filter Name: PxHelp20
    File Name: C:\WINDOWS\System32\Drivers\PxHelp20.sys
    File Version: 3.00.43J [3.0.43.9]
    File Description: Px Engine Device Driver for Windows 2000/XP
    Product Name: PxHelp20
    Product Version: [2.0.0.0]
    Company Name: Sonic Solutions
    Copyright: Copyright © Sonic Solutions

    Filter Name: imapi
    File Name: C:\WINDOWS\system32\DRIVERS\imapi.sys
    File Version: 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
    File Description: IMAPI Kernel Driver
    Product Name: Microsoft® Windows® Operating System
    Product Version: 5.1.2600.2180
    Company Name: Microsoft Corporation
    Copyright: © Microsoft Corporation. All rights reserved.
     
  5. Webslinger

    Webslinger Retired Moderator

    NTIDrv - NTI CD-ROM Driver used by New Tech Infosystems Inc in their burning and ripping engine

    I'm pretty sure NTI FileCD, which is packet writing software, installs this driver. Packet writing software often causes problems with Slysoft software and other software in general.

    Uninstall NTI's Filecd packet writing software, and ensure NTIDrvr no longer appears in your upper filters after rebooting. If you need that drag and drop functionality, use dvd-ram instead.

    But if you can't figure out how to remove (or uninstall that program) that filter (or how to check your filters), do this:

    i) Create a backup of your registry
    ii) Download imgburn. It's a free program: http://www.imgburn.com/index.php?act=download
    (it's also an excellent program imo)
    iii) Go to Tools > Filter Driver Load Order. Select "NTIDrvr". Click "Remove Selected Filter". Click "ok".
    iv) Reboot


    Also, you may want to try profiling in image mode.

    Other than that, I`d wait to see what Matthew has to say.
     
  6. matthew

    matthew SlySoft Team Member

    Also, the proc monitor.log indicates that no process was found and therefore shutdown the profile straight away. Make sure you are launching the correct game exe. You can also test this by un-checking the "auto stop" option of that profile.
     
  7. cybmole

    cybmole Well-Known Member

    I don't understand how I can not be launching the corerct game exec. game is installed in default location and profile is as supplied by yourselves int he drop down menu

    I found this launcher log file, showing that Gj is using the correct exe - ( unless it is suppoed to use the file launcher.exe in the same program directory ???

    anyway I will remove the NTI stuff & try again while waiting for your feedback. But please note that software has been installed for a long time while I've been playing NWN2 via GJ(maplom version) with no problems).

    Game Jackal Launcher log file
    Log date - 02/12/2007 11:50:10

    ***********************************************
    [02/12/2007 11:50:10] Launcher starting...
    [02/12/2007 11:50:10] Program - C:\Program Files\SEGA\Medieval II Total War\medieval2.exe
    [02/12/2007 11:50:10] Parameters -
    [02/12/2007 11:50:10] Directory - C:\Program Files\SEGA\Medieval II Total War\
    [02/12/2007 11:50:10] Processor mask - 1
    [02/12/2007 11:50:10] MaplomH -
    [02/12/2007 11:50:10] Cmdline - "C:\Program Files\SEGA\Medieval II Total War\medieval2.exe"
    [02/12/2007 11:50:10] Process will not be created in a suspended state.
    [02/12/2007 11:50:10] MaplomH.dll/MaplomHL.dll not in use!
     
  8. Webslinger

    Webslinger Retired Moderator

    You don't need to remove all of it. Just Filecd

    By the way, I don't work for Slysoft.
     
  9. cybmole

    cybmole Well-Known Member

    update:

    removed the NTI filter. tried the profile that I made yesterday & it seemed to work.

    (webslinger: I couldn't find an option to remove only NTIfile CD - it was all or nothing in control panel. And after removing all of it the filter was still there accorind to imgburn! so used imgburn to remove it). I sitll have roxio media creator installed which will do for me what NTI Vd DVD maker used to do)

    the new slysoft launcher.log looks just like the one posted above & new proc monitor log is:
    Game Jackal log file - Proc Monitor
    Log date - 03/12/2007 07:02:38

    ***********************************************
    [03/12/2007 07:02:38] Monitoring process ID 3592
    [03/12/2007 07:02:57] Process ID 3592 was not found, debouncing...
    [03/12/2007 07:02:57] Process ID 0 still was not found, searching for another process...
    [03/12/2007 07:02:57] Process ID 0 was still not found, leaving...
    [03/12/2007 07:02:58] Process method used, monitored medieval2.exe
     
  10. cybmole

    cybmole Well-Known Member

    update: latest profile seems stable - i've tried it several times & it's worked every time.

    I guess messing with the filters did make a difference though I still don't understand exactly how.

    The real test will be when my son returns from university & plays the game constantly in his Xmas holiday - I've just been setting it up for him so I've not gone deep into the game myself.

    I also managed to find & rename the annoying logo.bik type fiiles so the game loads really fast now, without running its nvidia & other adverts first.
     
  11. Webslinger

    Webslinger Retired Moderator

    I'm glad it's working for you.