Lost access to physical DVD/CD drive - shows error with elbysoft

Discussion in 'Virtual CloneDrive' started by Todd Christensen, Aug 17, 2016.

  1. I have a Dell Latitude E6540 laptop with a DVD+/-RW drive. I've been running AnyDVD HD (7.6.9.5) along with Virtual CloneDrive and ImgBurn for years. I also have a Latitude E5440 that has the same issues since version 1607 came out.

    Win10 Pro 64bit version 1607 (anniversary release). Now I can't get to my DVD drive, it doesn't show in "My PC" and in Device Manager it shows a yellow warning. Looking at events in it it talks about the elbysoft driver, etc. Drive still has power, can eject the door, etc. I have found various posts about "filters" or other things that mess up Windows from dealing with the optical drive.

    I uninstalled Virtual CloneDrive, AnyDVD and ImgBurn and still can't get access to the DVD drive. I've uninstalled it in Dmanager and rebooted and still not able to get to it. I've checked Disk Management to see if it just needed a new drive letter assigned and it's not visible.

    I've swapped out the internal DVD drive with a brand new one and still having the same problems. I need to figure out how to do a "clean removal" of everything from Virtual CloneDrive and AnyDVD HD so I can get access back to my drive.

    TIA-

    *Edit* - fixed the actual release version of AnyDVD HD that I was running, it wasn't right.
     
    Last edited: Aug 17, 2016
  2. James

    James Redfox Development Team Staff Member

    Reinstall AnyDVD & Virtual CloneDrive. This should fix it.
     
  3. I had tried that already and when I reinstalled them - it didn't fix it. So I removed them again.
    Not too interested in running any of that software if it takes control and doesn't let go when I want to run the drive. Besides, Win10 now can mount ISO files and can burn directly - so it's easier to go w/o 3rd party apps. And with the reputation of ImgBurn and spyware it brings with it....it's getting sketchy.

    I just put on VCD 5.5 and still no change. I do have AnyDVD HD on as well.
     
  4. Is there a diff version that will fix this? There's got to be a fix, regedit or something that will bring back control of the drive under windows. I don't think it would really warrant a reinstall just to get the optical drive working again....but I'll need some help from smarter people or Redfox developers for me to get this figured out. Everything I've tried has just run me around in circles with the same result.

    James - any ideas?
     
  5. James

    James Redfox Development Team Staff Member

    Virtual CloneDrive has no influence on physical discs, you can leave that out of the equation for now. What makes you say "shows error with elbysoft"?
    Who or what shows an "elbysoft" (whatever that means) error when?
    Please post an AnyDVD sysinfo file. Check Window's eventlog to see, which driver failed to load or start.
     
  6. Device SCSI\CdRom&Ven_HL-DT-ST&Prod_DVD+-RW_GU90N\4&395ba125&0&010000 could not be migrated.

    Last Device Instance Id: SCSI\CDROM&VEN_ELBY&PROD_CLONEDRIVE\1&2AFD7D61&0&000000
    Class Guid: {4d36e965-e325-11ce-bfc1-08002be10318}
    Location Path:
    Migration Rank: 0xF000FC000000F120
    Present: false
    Status: 0xC0000719
     

    Attached Files:

  7. Happy to post sysinfo.txt file - but can't find one. how or where it the file stored or generated?
     
  8. Another screenshot of the Device Manager with the errors under DVD/CD-Rom drives
     

    Attached Files:

  9. whatever_gong82

    whatever_gong82 Well-Known Member

    Post an AnyDVD log or sysinfo log file. Many times the answer to your question is visible to experienced users or SlySoft support or a developer right away.

    Ensure Anydvd is running.

    1. Put the problematic original disc in your optical drive/reader-- or you just have no disc at all in your PC/laptop. Wait for Anydvd to scan the disc or empty drive.
    2. Right click the red fox icon on your system tray (to the lower right).
    3. Select "Create Logfile"
    4. Wait for Anydvd to create a log file. In some circumstances this might take 5 minutes or longer.
    5. A pop-up screen will appear. Take note of the location where Anydvd created the logfile "Anydvd_Info_<xxxxxxx>.zip" (or something similar)
    6. Click "ok". A Windows Explorer will open. You will see a zip file called "Anydvd_Info_titleofmydisc.ziplog"
    7. Look for the icon that looks like a paper clip after clicking "quote" or when creating a new thread). If you don't see that paper clip icon, click the "go advanced" button. You should see that icon now. Click the paper clip.
    8. A small pop-up screen should appear (if it doesn't please ensure your browser is enabled to allow pop-ups from the Slysoft forums)
    9. Click the "Browse" button, and locate and select the .ziplog file you created.
    10. click "upload"
    11. Close the window. When you submit reply, or submit a new thread, the .ziplog file will be attached automatically for the mods to take a look at.
     
  10. James

    James Redfox Development Team Staff Member

    Looks like a filter driver is not loading. May have nothing to do with AnyDVD at all. Check Windows system eventlog for errors. You have to creat a syslog. Windows key -> type "AnyDVD" -> AnyDVD System Information
     
    whatever_gong82 likes this.
  11. James

    James Redfox Development Team Staff Member

    AnyDVD can't create logfiles without drives.
     
    whatever_gong82 likes this.
  12. whatever_gong82

    whatever_gong82 Well-Known Member

    I didn't realize that the OP still can't get to his/her physical drive via Windows.

    :oops:
     
  13. Bingo - that worked in creating a log file (not fixing the issue). Right clicking on the AnyDVD in the tray and saying create log file just didn't do anything.

    I've attached the ziplog file.
     

    Attached Files:

    Last edited: Aug 18, 2016
  14. James

    James Redfox Development Team Staff Member

    I don't see anything wrong. Maybe overly active security software preventing proper install / uninstall of AnyDVD?
     
  15. It definitely seemed to coincide with version 1607 of Windows 10 Pro. May be I'm grasping at straws. I've tried just about every combination on removing and uninstalling/reinstalling and high pass and low pass filters and nothing seems to work. It's frustrating that just getting a DVD/CD drive to work has that many obstacles.

    For right now I got it working, I took a few hours last night since I've already spent 3-4+ hours trying to get it fixed and wiped out the OS and started over with a fresh install of Win10 Pro v1607. For the time being - no more AnyDVD HD (old version) or VCD will get reinstalled on this system (staying away from ImgBurn too since Win10 will mount ISOs and burn them too). Optical drive works great.

    My other Latitude E5440 with similar problems will just have to wait. I don't have time to get that one rebuilt right now with a new copy of Win10. But it's still got the same yellow bang (!) warning in DManager and doesn't show up as an avail drive.

    I'm still interested in looking into a lifetime license of AnyDVD HD 8.0.3 from RedFox like I had earlier of the older AnyDVD HD (7.x) as that helps me continue to work on my private DVD-to-Plex library but got too many other things going on right now to worry about that right now and really had to get access back to the optical drive.
     
  16. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    AnyDVD & VCD work just fine here on 10 pro build 1607
     
  17. FurryGuy

    FurryGuy Well-Known Member

    Same for Win 10 Home 1607, x86 and x64.

    When I first upgraded my PCs from Win 7 to Win 10, one of them had a common "disappearing CD drive" issue.

    No CD /DVD player in Windows 10 - Microsoft Community

    Maybe the registry hack would work for this problem?
     
    Last edited: Aug 19, 2016
  18. Lost physical DVD/CD drive access now on 2 more machines on my home network. All run RedFox software. Of the other 300+ systems I manage - not seeing these issues with Win10. Only with WIn10 Pro 64bit v1607. One is my primary desktop. Not too happy about it. I wonder if it's tied to a windows update? But all have a commonality of Slysoft/redfox software.

    no bueno.

    I need some help figuring this out. I was willing to respin my Dell Latitude, but not 3 more computers. That's too much work for what must be a simple fix.
     
  19. I've tried most of the links and pages from that site.

    I even took registry settings of my freshly rebuilt Latitude E6540 with Win 10 Pro 64bit v1607 and have tried to import them for the \atapi and \class areas that are referenced. no luck.

    I have gotten to the point on 1 machine I've been testing with that I can remove the CD/DVD device it will be found and work when scan for changes and it works - up until I restart and then it's gone again. So I think something is interfering with the way windows interfaces with the drive. if I remove the device and refreshing for hardware changes finds it and works now - then I just need to figure out what's changing it during a restart cycle.

    mmh - stumped again. I've gone back through programs and features and looked for anything that would be interfering with the hardware. I also checked for startup programs in task manager (one of the tabs to look for in task manager in win10 now controls startup programs).

    I've even looked at services to see if something might be glaringly wrong there. I'm getting closer - but still not solid fix.