"License Retrieval failed" with paid version

Discussion in 'AnyStream' started by critterlovr, Oct 18, 2020 at 8:44 PM.

  1. critterlovr

    critterlovr Member

    Hey folks! I purchased the license a few days ago, and have been able to save Netflix movies just fine, prior to just now.

    Now when I try (Superman Returns) I get an error box that says "License retrieval failed. Please try again".

    I confirmed under the '?' at the top that it shows license "Expire: never".

    I have tried reapplying the license - no success.

    I have also tried closing and reopening AnyStream - no success.

    Help, please?
     
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Been doing some big download sessions?

    Sent from my Pixel 3 XL using Tapatalk
     
  3. Prospere

    Prospere RedFox Development Team

    The message is a bit confusing, I have to admit. It refers to a Widevine license for media decryption, not to your AnyStream license.
    However, in order to identify the reason, I still need your log file.
     
  4. critterlovr

    critterlovr Member

    @Ch3vr0n - Single downloads, and back-to-back. I thought the full license took away the download limits?

    @Prospere - I'm hoping I'm copying the correct ones. Please tell me if I didn't.
    .
    ---------------------------------------------------------------------------------------------------------------------------

    ... and since I see it's saying 'no license in response', I'm showing the About information, in case that helps. I'm blacking out some info that I assume is identifiable info. If you need me to paste the entire thing, let me know:

    upload_2020-10-18_15-4-48.png
     
    Last edited by a moderator: Oct 18, 2020 at 10:11 PM
  5. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    That's the debug log, not logfile.

    Post edited and debug log removed (not that you didn't do anything wrong but uncoded is full of hot links to netflix which we obviously don't want to attract attention of.

    Please click menu - create logfile. Post that. As to the 'back to back', you thought wrong. A licensed version still has limits (clearly explained in the FAQ as well as in the product page), they're just a lot higher than trial versions and are replenished much faster. I'm guessing at this point, you may have hit the download limit and used up your tokens for the time until it's refilled a bit.

    Sent from my Pixel 3 XL using Tapatalk
     
  6. critterlovr

    critterlovr Member

    If I hit the limit, fair enough. I did see it mentioned in the trial version, but I obviously must have missed it in the licensed version. I'm going to assume that's what this is. If it is, is there a way to know how long I need to wait? (12, 24 hours I assume?). I'll also be going back to read the FAQ, slower this time)

    Thank you for removing the stuff I shouldn't have included. :) Let's see if I got it right this time.
     

    Attached Files:

  7. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    That's all explained in the FAQ and product page.

    Trial users get an initial 10 tokens, then 1 ever 24h for the entire trial duration of 21 days. Thus a max of 31.

    Licensed users start with 100, and after using tokens, 1 token is replenished every 36min. Using up all available tokens, takes about 2.5d to refill back to 100. This averages out to about 280/wk

    Not saying that IS the problem here, prospere will need to look at the logfile for that. I'm just guessing that's a plausible culprit.

    Sent from my Pixel 3 XL using Tapatalk
     
  8. critterlovr

    critterlovr Member

    Ok I definitely know I haven't hit 100...less than 25 (including both Trial and Licensed versions). I'll wait to hear the results. In the meantime I'll go back and educate myself more. Thank you for the clarification!
     
  9. Prospere

    Prospere RedFox Development Team

    @critterlovr Again, this is not related to your AnyStream license. The license in question is the one AnyStream is trying to obtain from Netflix for data decryption but fails.

    Thanks for the log, by the way!
     
    whatever_gong82 likes this.
  10. Prospere

    Prospere RedFox Development Team

    @critterlovr Netflix complains about your concurrent streaming quota exceeded. That means that "Your Netflix account is in use on too many devices. Please stop playing on other devices to continue"
     
  11. critterlovr

    critterlovr Member

    Great, thank you for that clarification! By the way, it looks like it's working again. In the future I'll know not to worry thinking it's on my end. :D
    Thanks again to both of you!
     
    whatever_gong82 likes this.
  12. Sophie

    Sophie Active Member

    Usualy restarting anystream the error goes away i have no problems with that title
     
  13. critterlovr

    critterlovr Member

    @Prospere - I posted before I saw your 2nd comment. Netflix is confused, we're only streaming on 2 devices which is within my limit. Ah well, it seems to have resolved itself now, so all is good. Thank you again for everything, I learned something new today which is always good. :D
     
    whatever_gong82 likes this.