John Wick 2 audio sync issues

Discussion in 'AnyDVD HD (Blu-ray issues)' started by AnyDVDIsGoodForMe, Jun 12, 2018.

  1. I have had this come up with a few discs, but the current one is John Wick 2. I also saw the same issue with the new Power Rangers movie disc. I have done a little of my own digging before posting here, and it seems it has to do mostly with Lionsgate discs and how they do audio branching or something along those lines when it comes to Dolby Atmos (correct me if I am wrong). The way I rip a disc is just pulling the M2TS file(s) on a system with AnyDVD installed, and then I run the M2TS file through handbrake converting it to my desired format. John Wick 2 is one of those discs where the movie is cut up into multiple M2TS files and has dozens of playlists to I guess try to prevent ripping properly.

    I had read in another thread that was pretty recent (but about a different disc) that a RedFox developer had said they had identified what was going on and will have a fix soon. I wasn't sure if that applies to all discs where this issue occurs or just that one title in the other thread. Just wonder how long I should expect before I can safely rip these discs and have the audio be in sync.

    Just to note the issue, the audio starts off OK, and as the film progresses, it gets more and more out of sync.
     
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Wherever you read it, it wasn't in the anydvd section. Anydvd cannot cause sync issues. That requires some form of auto processing and that's not something anydvd can do. Not an and problem.

    what are you using to encode?

    Sent from my Nexus 7 with Tapatalk
     
  3. Thanks for the reply. Maybe the issue I saw in the other thread was only with CloneDB (although they mentioned the issue with AnyDVD as well)

    https://forum.redfox.bz/threads/braveheart-audio-out-of-sync.75152/

    You replied in that thread so maybe you can clarify for me.

    I use Handbrake to encode, but the issue perists before I do the encode. The only intermediate step which maybe is causing the problem is that I usually use TSMuxer (specifically TSMuxer GUI 2.6.12) when I get a disc where the film is not a single M2TS file to combine them into a single file. So if the issue is with TSMuxer, then I suppose I could either convert the individual files in handbrake and then try to use a combiner utility to merge the files together, or maybe you have another suggestion on how to go from disc to handbrake for a disc that uses a playlist and multiple files and get a single output file (I encode to MP4). I am willing to try whatever will work since this has been bugging me for a while and I just have some time now to actually try to solve it.
     
  4. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Sorry, we cant assist with third party (tsmuxer / handbrake) encoding issues. You'll have to ask the developers of those tools. If you want a single file, use CloneBD.
     
  5. Not asking you to troubleshoot other people's programs. Just looking for a method to get from point A to B without an issue. I will try CloneBD and see if it can replace one or more of the programs I am using now, and more importantly, if it resolves the issue I have been having. Thanks.
     
  6. fornit

    fornit Member

    Hm,

    that's interesting. Are you sure it's John Wick 2, which is consisting of multiple m2ts files?

    I do encoding in a similar way as you do. I.e.: I copy the respective m2ts file to my hard disc and then I use ffmepg on CLI (instead of handbrake) to encode it.

    I've ripped and encoded John Wick 2 in July 2017 and I still have the m2ts file on my disc. It's a single file of 31,6 GB with 5 audio tracks. I haven't experienced any audio issues with that blu ray.
     
  7. Yeah, and not only is it multiple m2ts files, it has dozens of playlists on the disc, and only one is the correct order. A lot of times discs with multiple M2TS files are done that way to have extended versions on the disc with theatrical versions, so it doesn't take up too much space. However some of these discs, it seems like a copy protection measure to split up the film and then make tons of playlists where only one is the correct ordered list. AnyDVD does a good job at letting you know which is the correct playlist, but that is the case with this disc either way. After a little more messing around, it does seem like maybe the tsMuxer program I am using to combine the files is causing the audio issue. It isn't handbrake because the issue occurs once I combine the files into a single one. What do you use when you do have a disc where the feature is split? Does ffmpeg handle that for you?
     
  8. fornit

    fornit Member

    I've just described that at https://forum.redfox.bz/threads/uhd-backup-wie-und-womit.74354/page-12#post-489369

    Unfortunately that post is in german language, so I will try to repeat the same in English.

    First you have to find the appropriate playlist. To do so I sort the mpls-files in the PLAYLIST folder by descending size and look into them with a text editor until I find one that looks plausible. That's a bit of trial and error but if you look into the corresponding m2ts files you'll have identified it soon.

    After identifying the right m2ts files I use ffmpeg in conjunction with its "concat" option.

    Doing so, I have experienced audio problems, too. Obviously concatenation of m2ts files with multiple audio tracks can lead to audio issues.

    To avoid that I convert the respective audio tracks at the same time when I concatenate them.

    The "Equalizer" blu ray has been such a multiple m2ts candidate.

    It consists of the files: 00002.mts, 00003.mts, 00004.mts, 00005.mts, 00006.mts, 00007.mts, 00008.mts, 00009.mts, 00010.mts and 00011.mts.

    To make things working it needs a txt-file listing all m2ts files needed. I've named it equalizer.txt:
    file 00002.m2ts
    file 00003.m2ts
    file 00004.m2ts
    file 00005.m2ts
    file 00006.m2ts
    file 00007.m2ts
    file 00008.m2ts
    file 00009.m2ts
    file 00010.m2ts
    file 00011.m2ts

    THen I can concatenate the video parts:
    ffmpeg -f concat -i equalizer.txt -map 0:v:0 -c:v copy -an -y equalizer_video.m2ts

    Usually I'm interested in the german and the english audio tracks only. That's why I concatenate those the same way but convert them at the same time:
    ffmpeg -f concat -i equalizer.txt -map 0:a:0 -c:a aac -b:a 192k -ac 2 -vn -y equalizer_audio_en.m2ts
    ffmpeg -f concat -i equalizer.txt -map 0:a:1 -c:a aac -b:a 192k -ac 2 -vn -y equalizer_audio_de.m2ts

    Finally everything can be muxed together. Please note, that I've placed the german audio track as first audio track:
    ffmpeg -i equalizer_video.m2ts -i equalizer_audio_de.m2ts -i equalizer_audio_en.m2ts -map 0:v:0 -map 1:a:0 -map 2:a:0 -c:v copy -c:a copy -y equalizer.m2ts

    Hope that can help!
     
  9. Thanks for the detailed reply. Do you use AnyDVD? I never knew this for a while, but if you open the disc.inf file that AnyDVD shows in the file structure of the bluray disc, it will give you the correct playlist for the film.

    For example, John Wick 2 has

    [disc]
    type=BD-ROM
    version=AnyDVD HD 8.2.5.0 (BDPHash.bin 18-01-30)
    totalsectors=11456608
    label=JOHN_WICK_CHAPTER_2
    speedmenu=0
    region=-1
    playlists=934
    3D=0
    fps=23


    Which tells me that 934.mpls is the playlist for the film and the rest are decoys (and the disc I have has maybe 50 fake playlists on it that are the same files, out of order). I guess maybe you got a German or at least European version of the disc and that is why it was not like this for you? I have tried both the rental and retail discs in the US and while both use a different playlist, they both have the same multi fake playlist setup, as well as the audio issue when I combine the files.

    My normal procedure is to copy files to disc after AnyDVD decrypts the bluray, if needed use tsMuxer to combine the multiple m2ts files into a single one, then run through handbrake at whatever settings I want (I use better settings for movies I care more about and want in better or lossless quality). I have 2500 movies on my server (about 1200 are bluray) and for the most part, this method works no problems at all. It has just been these discs from Lionsgate that seem to have the audio lag issue. After testing a few more things, it DOES seem that tsMuxer cannot properly handle the streams and that is what is causing the lag once I combine the files. I am going to try to just convert all the M2TS files to MP4 and then combine the MP4 files afterwards (which doesn't cause a reencode). If I still have no luck, I am going to try using ffmpeg to see if I can get a better result.
     
  10. fornit

    fornit Member

    Thank you for the hint with respect to the disc.inf file. That will save a lot of my time when processing the next multiple-m2ts-disc :)

    As said my normal procedure is similar as yours. I copy the m2ts file to my hard disc and after that I look into it with the help of MediaInfo to see if there are any specials and how many audio tracks are there.

    After that I play the m2ts in VLC to identify the german and the english audio track. Usually that's it and I encode it e.g. as follows:

    ffmpeg -i jumanji.m2ts -map 0:v:0 -map 0:a:2 -map 0:a:0 -aspect 1920:816 -r 23.976 -vf crop=1920:816:0:132 -c:v libx265 -preset fast -crf 18 -ac 2 -c:a aac -b:a 192k -metadata:s:a:0 language=ger -metadata:s:a:1 language=eng -y jumanji.mp4

    That means:
    • I remove the black bars via crop
    • The encoding is done with the help of x265 at crf 18 quality. That's a quality level near transparency. I.e.: It becomes hard to see a difference when you compare it to the original.
    • The audio tracks are tagged with the language.

    I guess that tsmuxer is causing your problem. If the audio is ok at start but gets out of sync when the video progresses that's a typical problem. It can e.g. occurr if during a conversion frames are dropped or inserted and the audio is not adjusted according to that.

    I don't work with tsmuxer but I guess it only concatenates and doesn't do any conversion? Then it could be that after applying tsmuxer some info about frame rate or sampling rate is not set correctly.

    Have you compared the length of video and audio tracks and are they equal?

    There are some possibilities how such a/v sync problems can be handled. If nothing else works one can try to reset the timestamps or stretch or squeeze the audio a bit.