James's scripts installation questions

Discussion in 'AnyDVD HD (Blu-ray issues)' started by schlim66, Jan 10, 2008.

  1. schlim66

    schlim66 Active Member

    I am trying to use my 3319a and 3516 together. I first installed 3516, copied everything from the folder "C:\Program Files\CyberLink\PowerDVD" to "C:\Program Files\CyberLink\PowerDVD3514" and left the original folder unchanged. Next I installed 3319a, which asked me if I wanted to uninstall the previous version, I clicked yes and installation continued into "C:\ProgramFiles\CyberLink\PowerDVD". It seems as if both folders contain the 3319a files, so when I run the scripts, they both are 3319a. What did I do wrong, was I supposed to copy everything to a completely different directory and then move it back after the second installation?
    Any help appreciated,
    Schlim66
     
  2. gn2

    gn2 Member

    I've experienced this same problem, can anyone clarify the procedure for getting 3319a and 3516 to BOTH work on the same WinXP installation ??

    Thanks very much...
     
  3. mobileh264

    mobileh264 Active Member

    I don't think patching powerdvd to previous versions works properly.

    I've just finished working on and tested the following sequence for WinXP:

    1. Wipe out all current powerdvd instances, uninstall using control panel add/remove programs. Then install base version of PowerDVD and apply license.

    2. Install first desired version of Powerdvd (lowest number version , eg 2911 but change number to whatever version you want). Reapply licence if necessary and test.

    3. Open an MS-DOS window and enter: cd "C:\Program Files"

    4. Enter: copy Cyberlink Cyberlink.2911

    5. Install second desired version of Powerdvd (highest number version, eg 3516 but change number to whatever version you want). Reapply license if necessary and test.

    6. You should now be left with version 3516 whenever you run powerdvd.

    7. Copy the below script to your desktop in a new file called powerdvd_swapover.bat

    C:\
    cd "C:\Program Files"

    IF EXIST Cyberlink.2911 (
    echo Backing up current version to 3516.......
    rename Cyberlink Cyberlink.3516
    echo installing version 2911..................
    rename Cyberlink.2911 Cyberlink
    ) ELSE (
    echo Backing up current version to 2911.......
    rename Cyberlink Cyberlink.2911
    echo installing version 3516..................
    rename Cyberlink.3516 Cyberlink
    )

    8. Don't forget to change the version numbers in the above script to your desired versions you wish to swap between.


    If you follow this, you should be effortlessly and instantly swap between two different versions of Powerdvd 7.3 by just double clicking the powerdvd_swapover.bat file on your deskop.

    NOTE: make sure PowerDVD is closed down before running the batch file or you may encounter problems due to file locking.
     
  4. SamuriHL

    SamuriHL Retired Moderator

    Closing PowerDVD is not enough. There are services running that will not stop just by closing PowerDVD. And those files WILL be locked by the services.
     
  5. schlim66

    schlim66 Active Member

    Can you tell us how to fix that issue?

    Thanks,
    Schlim66
     
    Last edited: Jan 15, 2008
  6. SamuriHL

    SamuriHL Retired Moderator

    James' script has a line with a very long GUID that he does a net stop on. Then he net starts it. Copy that line.
     
  7. YaniD

    YaniD Well-Known Member

    Whilst I haven't used James's scripts, I have copied v2911 to another folder, installed v3516 and copied that to another folder. Now I just stop the obvious processes, delete the PowerDVD folder, make a copy of the 2911 or 3516 folder and rename it to PowerDVD.

    However, when I restart, the version mentioned in the "about" section is always 3516 regardless of whether I have copied the 2911 or 3516 folder. The different versions actually run, because when I have 2911 installed (even if it says 3516), I can disable hardware acceleration and have it stick, whereas if I copy the 3516 folder, hardware acceleration is always forced. Hardware acceleration disabled is the only way I know which version I have installed now at any one time. It's annoying not to know which version is actually installed, but I can live with that for the ability to switch between hardware enabled and disabled.
     
  8. mobileh264

    mobileh264 Active Member

    You should get a different background inside PowerDVD.

    2911 should have a red background only, wheras 3516 should have the word "ULTRA" in a big light blue font at the top-right.

    You can't trust the version information in this hack as it is not stored in the program files folder.

    With regard to file-locking, I have had no problems so far. Try disabling the web updates in both installed versions to reduce the number of processes that might lock up. Mine works okay on XP

    I haven't seen James script but would like to if it's better than my own lash-up.

    Can anyone point me to the thread.
     
  9. SamuriHL

    SamuriHL Retired Moderator

    That's because you're not copying the shared folder but only the PowerDVD folder. As you've seen, it's not a real problem not to copy the shared folder as it works, but, the version information is stored in there.
     
  10. schlim66

    schlim66 Active Member

  11. schlim66

    schlim66 Active Member

    Can you point me to the shared folder location please?

    Thanks,
    Schlim66
     
  12. SamuriHL

    SamuriHL Retired Moderator

    Go up a level. It's at the same level as PowerDVD. Should be in the Cyberlink directory. \Program Files\Cyberlink\Shared files and \Program Files\Cyberlink\PowerDVD.
     
  13. mobileh264

    mobileh264 Active Member

    Thanks for pointing me to that thread.

    Now I can see what James script is doing!!!
     
  14. andy o

    andy o Well-Known Member

    Hey guys, I installed these scripts a few days ago, and they're working great. Had to do a little editing, my versions are 3319a and 3516 -not 3514 (?)-, but otherwise they are working fine. One question though. I am working in Vista 32, and I have them on my desktop. I always need to right-click and run as Administrator. I can't set the properties in the "Compatibility" tab to run always as Administrator (the checkbox is greyed out). I have tried with shortcuts and they're also greyed out. Anyone knows if this can be changed, short of disabling UAC?

    Thanks.