Issues with Fantastic Four - The Rise of The Silver Surfer

Discussion in 'Third Party Products' started by Ozziebloke, Nov 5, 2016.

  1. Ozziebloke

    Ozziebloke Member

    Hi everybody,

    I have currently issues with the above blu-ray region B. Searching through old forum threads, it became clear to me that this release was one of the first one with BD+ protection.

    Got the latest release of ANYDVD, use it very happily to rip every blu-ray I buy. I store them on my NAS and pack the disc away for safekeeping.

    My process is normally to use BDInfo for selecting the MPLS files of interest while using tsMuxer to copy them over while at the same time dumping all audio and subtitle tracks I don't require. After that I push the video track through Handbrake and merge the audio and subtitle tracks with MKVToolNix.

    I followed exactly this process and I am ending up with a pixelated picture throughout the movie. Initially I thought it was Handbrake, but then I discovered that the source file from tsMuxer had the same problem.

    However when the original disc is in the blu ray player in my PC, I can play the 00001.m2ts file in the \BDMV\STREAM folder without any problems in any player (VLC, PowerDVD and Wondershare). The original disc also plays fine in any blu ray player.

    Further worth mentioning, ANYDVD creates a dt1 file in my cache. Just as a fact, no concern there.

    Currently copying with Explorer the 00001.m2ts to my local hard drive to see if the problem than also exists. That way I can exclude tsMuxer as the cause of the problem. I will post the outcome of this action as soon as it is available.

    Also there seems to be an issue with menus when playing the disc through PowerDVD. I will try to work out the behaviour once the copying is finished.

    Some further technical details:
    AnyDVD HD 8.0.5.0, BDPHash.bin 16-09-05
    PIONEER BD-RWBDR-206 1.56 11/05/06PIONEER

    Any help is highly appreciated.
     

    Attached Files:

  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Rip the disc, does the rip play in powerdvd WITHOUT pixels? If so, then anydvd did it's job and the pixels are the result of whatever you're doing in those other programs. Anydvd could cause pixel issues if bd+ isn't removed correctly. However with a title THAT old, that's impossible. As to the dt1 file, that's normal. That file contains the decryption info for bd+ protected discs. So the next time that disc is inserted, anydvd uses its local database instead of the online database.
     
  3. Ozziebloke

    Ozziebloke Member

    Hi Ch3vr0n,

    Thanks for your response.

    Copy action with Explorer of 00001.m2ts is finished now, file on local hard drive plays fine with PowerDVD, VLC and Wondershare. Indeed no problem with AnyDVD it seems. The only thing I did, was deleted the cache before the copying. This is why I noticed the creation of the dt1 file.

    Still want to know the cause of the problem so I am copying now again with tsMuxer just to verify if the problem is indeed with txMuxer or just incidental. Will post again in about 1 hour.
     
    Last edited: Nov 5, 2016
  4. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Moving this out of the Blu-ray section. As you said yourself, the rip plays fine. This is not an anydvd problem and such this thread is in the wrong section. Moved.
     
  5. Ozziebloke

    Ozziebloke Member

    Indeed, I stated the rip played fine now after cleaning the catch of ANYDVD.
    This cannot lead to the conclusion if it is yes or no a ANYDVD problem.

    Extracted the video stream from the original m2ts-file with eac3to and the stream is pixelated. It is no muxing problem. To me it is strange, that a entire stream can be pixelated without it being coded and without it producing one error. It appears that the m2ts file was readable in structure but not as video stream. Wonder what it did with the sound. Let's extract that.
     
  6. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Cleaning the cache has no effect on pixelation. You can even verify proper playback without ripping. Insert disc, play disc directly with anydvd active in powerdvd. Correct playback: not an anydvd issue. There's no difference between doing that and playing the anydvd rip. In both cases protection is removed.

    If you say the stream is pixelated after extracting it with eac then it IS a muxing problem. You have demuxing (extracting) and remuxing (combining). Whatever you're doing in eac, that's the problem. You do know that handbrake can do all that at once right? Removing audio, subtitles, output to mkv...
     
  7. Ozziebloke

    Ozziebloke Member

    I again used tsMuxer and the video stream is indeed pixelated again.
    This time I also checked one of the AC3 streams and this is rubbish too.
    So it is clearly a tsMuxer problem. You are right Ch3vr0n.

    I know the differences between demuxing and remuxing, and I also know that Handbrake can do that all at once.
    It is only that I add some SRT subtitles and a few other attachments (artwork) so everything works neat on all playback devices I have in the house.
    Especially the two Sony Blu-ray players I have are very particular, they expect included SRT streams. They don't work with separate SRT-files.
    This combination of tools worked fine for me, until I encountered this disc. But I am well aware that it is probably not the most efficient one. :)

    It looks that I have to follow a different approach for this disc. Thanks for your help and assistance!
     
  8. autodidact

    autodidact Well-Known Member

    Sadly tsMuxer isn't developed anymore, rumours says it might continue but no sign of that yet.
    There are many bugs and I've come across the issue you're having with pixalation.
    You could try an older version of tsMuxer, I use 1.10, 2.11 and 2.12 because they have different bugs.
    Also you could rip the complete title to HDD, then running BD-title, movie only, through BD-RB to get a "clean" BD folder.
    Then use tsMuxer and MKVToolNix.

    http://www.videohelp.com/software/tsMuxeR
     
  9. Ozziebloke

    Ozziebloke Member

    That's odd, the next disc got the same problem. Too much coincidence.
    Can I download somewhere the previous version of ANYDVD?
     
  10. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    It's not a good idea to go backwards in versions. You'd be increasing the chances of anydvd not fully supporting that bd+ version, and introduce pixelation issues. That's just a bad idea, but the link can be found on the forums. @autodidact just an fyi bdrb uses tsmuxer.
     
  11. autodidact

    autodidact Well-Known Member

    Yes I know that... erm... tsMuxer 2.12 that is....
     
  12. Ozziebloke

    Ozziebloke Member

    The reason I asked for a previous version, was because I wanted to test if the problem is related to ANYDVD.
    I do not so easily accept that it is a tsMuxer problem. But I was lucky and I found some older versions in my download folder. So I did the testing.

    I grabbed some other blu-rays which were already done successfully in the past by the above process.
    Followed the same process on the latest installed version from ANYDVD, all the same problem, pixelated.

    Installed the previous version, followed the same process, no problems at all. No pixelated problems.
    Went even back to a few more versions, again the same process. No problems.

    Resume, this problem of pixelating is related to the latest ANYDVD version and not to tsMuxer.
    Just try it out on your own computer and you will have the same result. I did on a different computer.

    It is easy to point the blame at tsMuxer but it is better to do some thorough testing before making any conclusions.
    At any case, the fault can be reproduced and is related to the latest ANYDVD version.
    Doesn't mean to say it is a problem of ANYDVD, but it is too simple to state it is a problem of tsMuxer.

    Subject of the thread should be changed as the issue is NOT related to this specific disc title.
     
  13. Ozziebloke

    Ozziebloke Member

    Much the opposite as is clear from my previous post.
     
  14. nebostrangla

    nebostrangla Well-Known Member

    The bd+ is not fixed by the version. It is fixed by the OPD and BDPhash.bin. To make that be redone delete the dt1 file that corresponds with it.
    Then re-insert the disc. It will connect and apply the fix from the OPD again.
    But you can test that by using the disc in PDVD or another player without ripping or deletion of the dt1 file.
    Just let AnyDVDHD scan the disc and make it available to your system. Then point your player software to the drive containing the disc.
    If there's no pixelated frames then it's not the BD+.
     
  15. Adbear

    Adbear Well-Known Member

    There's definitely something weird going on. I just tested with the US version of the same disc, and found the pixelating problem. I ripped to ISO and if I mount the ISO without AnyDVD running in the background and try to play the stream it's pixelated, but if I then start AnyDVD it scans the ISO and the stream then plays without pixelation. It's as if it's ripping to ISO but leaving the protection in place even though it's not set to do that

    What's stranger is that if I update from 8.0.5.0 to 8.0.5.3 and make a new ISO then the stream in the mounted ISO then plays fine, but TSmuxer still makes a pixelated file with AnyDVD disabled.

    OK, think I figured it out. In TSmuxer under 'General Track Options' set it to 'Do not change SEI and VUI data' then should then give a clean output
     
    Last edited: Nov 5, 2016
    ErichV likes this.