Issue with Refresh rates in reclock

Discussion in 'ReClock' started by robl45, Sep 23, 2016.

  1. robl45

    robl45 Member

    I've been using reclock for years and it worked fine and now I"m having a strange issue on my new PC. Reclock keeps wanting to grab the wrong refresh rate. Like if the refresh is 23.970 or 23.976, refresh says the refresh rate is 24hz and I get 1 drop every 30 seconds or so. So I cleaned up the video clock database or whatever its called and then it appears to work, but when I watch a 3d movie, it decides to switch the refresh rate to 48hz which isn't correct either and then gets stuck on that. So no matter what I do, when I switch from non 3d to 3d it starts grabbing the wrong refresh and gets messed up.
     
  2. robl45

    robl45 Member

    Bump, can anyone help with this?
     
  3. James

    James Redfox Development Team Staff Member

    What is wrong with 48 Hz? Two eyes with 24fps make 48. Who or what "switches" to 48Hz refresh rfate?
     
  4. robl45

    robl45 Member

    Well first its 23.976 *2 so the actual refresh rate is 47.952 but its reporting 48. And when not doing 3d it should be showing 23.976. So as I said I reset the video clock database and it works correctly until I try to watch 3d and then it gets messed up again. It basically appears to be grabbing like the windows refresh setting of 23 or 24 instead of the actual refresh rate. When I just kept it at one refresh rate all the time, i didn't have any issues. I would use 23.970 which nvidia clocks at and reclock would grab the correct refresh rate and do its magic and all was good. I used pal slow down and never had to change the refresh rate. But now that I need to change refresh rates sometimes its getting messed up. I think a switch on the program that emptied the video clock database each time its started would solve the problem. I don't know if thats possible.
     
  5. James

    James Redfox Development Team Staff Member

    I understand now. Please try to disable "use GDI or PowerStrip for faster refresh rate detection" in Config -> Video Settings -> General and clean the video clock database in advanced settings.
    Please let me know, if this fixes the problem.
     
    nebostrangla likes this.
  6. robl45

    robl45 Member

    I tried this just now, unfortunately, it does not fix the problem, the first time after cleaning the video clock database it works fine, the next time I try to use it, it picks the wrong refresh rate. Essentially, 3d uses 23hz windows refresh rate and 2d uses 24hz windows refresh rate and thats what it ends up picking instead of the actual refresh rate after the first time when it picks the correct rate after cleaning the video clock. So windows resolution that I would pick in display or whatever says 24hz but its actually 23.976 and reclock for some reason just keeps locking on the windows 10 display values and not the real values. Frankly I wouldn't care too much as the intel gpu does perfect 23.976 but I'd rather use my GTX950 which is a much better card but I can't use that without reclock.
     
  7. robl45

    robl45 Member

    any other ideas?
     
  8. robl45

    robl45 Member

    Bump