Issue with AnyDVD 8.1.x.x and above when not running in Tray +CloneDrive

Discussion in 'Virtual CloneDrive' started by x7007, Sep 13, 2017.

  1. x7007

    x7007 Active Member

    It doesn't detect cd sometimes, randomly, I need to unmount and dismount. it only Auto Open the action selection only after going inside This PC window and then it detect it after refreshing and also shows the icon of the disk/Iso or which ever. I don't know when it started, but it happens al the time.

    Ye sorry Virtual Clone Drive .

    When trying to mount a movie ISO or any other ISO , bluray or anything, even windows ISO file. the only way that I am able to get the AutoRun opening or the Auto option to choose is by entering This PC and then do refresh,




    EDIT : when using AnyDVD 8.0.9.0 + CloneDrive 5.5.0.0 Everything works fine with it on Tray icon or not. anything above it have an issue which corrupt the mounting process and doesn't mount properly.
     
    Last edited: Sep 14, 2017
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    There's no such thing as an AnyDVD virtual drive. I think you're referring to 'virtual clone drive' by elby. Wrong section, moved.

    Sent from my Nexus 6P with Tapatalk
     
  3. x7007

    x7007 Active Member

    Windows 10 1703 15063.608 x64

    When mounting anything the only way it will open is when going to This PC then it shows the icon as mounted automatically even without refresh. but need to go to This PC with windows BACK or just open it.
    When changing between ISO too quickly without unmounting first ,the only way to get it updated is to go to This PC and it will open a new windows saying to INSERT DISC because it's he tries to access the DISC only when going to This PC which is not available because I just switch to other ISO so it's ejecting first the other one without finishing to mount the other one.

    Unmount/eject is possible from anywhere , but mounting, I can only access the Disc only when going to This PC.

    Even after uninstalling the Anydvd Clone Drive when I try to mount images using the own windows 10 image ISO , it still shows me Anydvd Clone Drive Mounting icon , the Sheep on the image of the Drive.

    Even when I remove Anydvd Virtual Drive , I still have the icon when using other programs.

    Do you guys have this registry keyword ?
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDriveTypeAutoRun"=dword:00000091

    Does AnyDVD or Virtual CloneDrive remove those registries ?

    They says it needs to be there to make autoruns works properly and if it's not there it won't .
    they says Antivirus might delete it.
    http://windowsreport.com/autoplay-not-working-windows-10/

    Solution 2 – Check Registry Editor values
    Windows 10 manages Autoplay settings using registry, and speaking of registry, there’s one specific key that is in charge of Autoplay settings. Sometimes this key can be changed when you install a new antivirus software, so let’s check this key and see if it has been changed.

    1. Open Registry Editor. You can open Registry Editor by pressing Windows Key + R and typing regedit. After typing regedit press Enter to run it.
    2. When Registry Editor opens in the left pane navigate to the following registry key:
      • HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3. Find the NoDriveTypeAutoRun value name in the right pane.
    4. Check its data. Make sure that it’s set to 0x00000091 (145).
    5. If the data is not 0x00000091 (145) double click the NoDriveTypeAutoRun.
    6. In the Value data enter 91. Click OK to save changes.
    7. Now go to the following key in the right pane:
      • HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    8. Search for NoDriveTypeAutoRun value. If that value exists change its data like we explained in steps 4-6 using the same numbers.

    I'm using ESET 10.219.0, could this be the issue ?

    When AnyDVD is running on the tray everything works fine..... it replaces the ISO image without going to This PC , I just wait and it auto opens.
    Uninstalling AnyDVD doesn't help. using 8.1.8.1 beta it happens with older versions too.


    LowFilters AnyDVD
    UpperFilters edevmon
     
    Last edited: Sep 13, 2017
  4. x7007

    x7007 Active Member

    After searching in the registry and removing all unwanted Anydvd CloneDrive it works now fine ...

    There was registry that kept using Virtual CloneDrive Icon and also the name even without it installed.

    And all many different registry location I don't understand what is their purpose but I removed everything with this program and after restart and reinstallation it works fine.
     
  5. x7007

    x7007 Active Member

    As soon as I installed Anydvd the problem came back ...... what's up with Anydvd 8 and above ? Do I need to have Anydvd always running just to mount normal files and not Protected Bluray ?

    I need to go back to This PC all the time to have Autoplay or the mount to work. before installing Anydvd , the mount was autoplay as soon as I mounted the image without going back to This PC location.
     
  6. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    absolutely nothing. Running AnyDVD 8181 and latest VCD just fine on Win10 Pro x64
     
  7. x7007

    x7007 Active Member

    Do you have Anydvd running on tray Icon , or it doesn't running ? because I don't have the issue with it's on the Tray Icon, but as long as it installed and not running I have the problem. Can you test ??

    To check, please exit AnyDVD Tray icon and try to mount couple of images. explain then what happens. please don't have any window opened with This PC location while you are testing.
     
  8. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    yes, tray icon is active permanently for me (it's actually the default) everything works just fine, tray icon and anydvd accessing images on the virtual drive
     
  9. x7007

    x7007 Active Member

    So yes, there is a problem, I repeat , please watch the words I'm saying.

    WHEN and only when the TRAY ICON is NOT running , then there is the issue, could you please check this ? because you skip whatever I'm trying to pinpoint and you didn't check.

    WHEN TRAY ICON is Running , then every thing is FINE.

    When AnyDVD is NOT installed . then CloneDrive works fine same as TRAY ICON is Running.

    Tried to explain it as much as I could.
     
  10. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    exited anydvd, mounted multiple images. Get mounted just fine
     
  11. Adbear

    Adbear Well-Known Member

    No issues here either. I only ever run AnyDVD when I need it and I have no issues with VCD under Windows 10
     
  12. x7007

    x7007 Active Member

    Does autoplay also work fine ?

    It mounted for me only when I have This PC is opened .
     
    Last edited: Sep 14, 2017
  13. Adbear

    Adbear Well-Known Member

    Not sure what you mean by your second sentence, but it works fine for me with or with out autoplay on in Windows.

    If this was an issue for everyone we would be seeing a lot more people complaining about it, as it is it appears to be just an issue with your system. I have tested across multiple PC's and none of them give me an issue
     
  14. x7007

    x7007 Active Member

    What windows version do you use ?

    1607 or 1703 ?

    Do you have ESET Internet Security 10.1.219.0 ? I also uninstalled Eset and it still the same not working properly , I also reinstalled it and it's the same not working properly.

    I don't understand it.

    If I mount for example an image from my E:\ . then it won't mount till I go to This PC , you know what I mean This PC ? just opening it and it starting to mount it properly.
    That's just a picture from the internet, not mine
    21877d1434704983-add-remove-folders-pc-windows-10-a-withreg.png

    If AnyDVD is opened then everything is opened correctly like it should no matter where I'm mounting the image.

    When AnyDVD is not installed then also it opens correctly no matter where I'm opening it.

    Again, It can't be an issue with my computer, I've tried it all.

    It can't be anything else when AnyDVD is installed, nothing on my computer doing that only when AnyDVD is installed.
     
    Last edited: Sep 14, 2017
  15. x7007

    x7007 Active Member

    It's AnyDVD fault when it is installed , again no one else seems to try to test it. Why without AnyDVD installed the mounting is working perfectly.

    Why when AnyDVD installed and is RUNNING on TRAY ICON mounting is working properly ?

    Why only when AnyDVD is installed and NOT running on the TRAY ICON then mounting is not working properly.

    There are 2 ways that mounting is working when AnyDVD is INSTALLED but NOT Running on TRAY ICON . when I RESTART Explorer.exe then the mounting is working or when I go/open This PC
     
  16. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    No it's not, any we tested it per your instructions. Neither of us have issues. If this was an issue that affected multiple users there would be a lot more topics/posts about it. You're the only one so far

    Sent from my Nexus 6P with Tapatalk
     
  17. x7007

    x7007 Active Member

    Not one have yet said which windows they are using or if they have any antivirus or such installed. I'm trying to figure the issue because it only happens with AnyDVD installed and not running, who could I check more ? where could be the issue ?

    All I know it could be an update that windows had but not one says. I can't see any software that have conflict . I only use ESET which I tried to uninstalled and AdGuard which has nothing to do with this.



    Or it just takes so long to mount the image when AnyDVD is not running, it takes almost 30sec to 1 min. I can't understand why.
     
  18. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    I'm running 1607 and afaik adbear is running 1703 along with hundreds of other users. My av is Avast and if there's any issues with AnyDVD and av's it's usually DURING install that they either block it partially or completely. AnyDVD has NOTHING to do with it. AnyDVD has no virtual drive, all it does is WAIT until the operating system tells it an image is being mounted to virtual clone drive and then scans the disc and presents it to Windows. And yes 30sec to 1minute is nothing abnormal. Depending on the protection on images/original discs, it can take MULTIPLE MINUTES for AnyDVD to do its job. Perfectly normal. If you still don't get this, all that's left to say is try contacting support through a ticket, but they'll tell you the exact same thing. AnyDVD and virtual clone drive behave just fine. Regardless of windows version and with or without AnyDVD running.

    Sent from my Nexus 6P with Tapatalk
     
  19. x7007

    x7007 Active Member

  20. x7007

    x7007 Active Member

    I just installed AnyDVD 8.0.9.0 and it works fine !!! it's something with the new version ! It can't be me if 1 version is working fine others are not