Invalid MS-DOS function

Discussion in 'AnyDVD HD (DVD issues)' started by rananaos, Mar 22, 2008.

  1. rananaos

    rananaos New Member

    I'm attempting to backup Second Hand Lions and I get a hard error during a basic windows copy process. Invalid MS-DOS function. I downloaded a new version of AnyDVD 6.4.0.0 and the error remains. The error only occurs on VTS_02_1.VOB. I bought AnyDVD to keep my kids from destroying disks and it has worked well until now. The log files appear to indicate where the error is since the file shows in the directory.
     

    Attached Files:

  2. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Your drive region isn't set. Please set your drive region setting to where you live. Your setting is not set and this can cause problems when handling CSS for some discs.

    Above is just a snippet of the log. AnyDVD failed to obtain titlekeys for some titles. If the titlekey isn't obtained then the title cannot be decrypted and the process will end up failing.

    Please set the region of your DVD drive and try again.

    Do the following:

    (1) Right click the fox on your toolbar. Exit Anydvd
    (2) Click start. Right click on "My computer"--->select "properties".
    (3) Click on the 'Hardware' tab--->click the 'device manager' button.
    (4) Open the dvd/cdrom branch---> right click on your optical drive
    (5) Click "properties".
    (6) You should have a region tab. From there you can select a region.
    (7) Select the region that you're in
    (8 ) Start Anydvd

    PS: I just want to commend you for posting your log files. Many posters including those who have posted numerous times don't automatically post the log files even though they should. Thank you!
     
    Last edited: Mar 22, 2008
  3. rananaos

    rananaos New Member

    I followed your directions and they work perfectly to set the region code. Here is the logfile snippet

    Summary for drive F: (AnyDVD 6.4.0.0)
    TSSTCORP DVD-ROM TS-H352C HP02
    Drive (Hardware) Region: 1

    Media is a DVD.
    Booktype: dvd-rom (version 1), Layers: 2 (opposite)
    Size of first Layer: 2019520 sectors (3944 MBytes)
    Total size: 4017252 sectors (7846 MBytes)

    Video DVD (or CD) label: SECONDHAND_LIONS
    Media is CSS protected!
    Video Standard: NTSC
    Media is locked to region(s): 1!

    RCE protection not found.
    AI scan forced, heuristic scan detected no protection!
    Found & removed structural copy protection!
    Found & removed invalid cell pieces!
    Found & removed Autorun from Video DVD!
    Found & removed 1 potential bad sector protections!
    Emulating RPC-2 drive with region 1!

    I tried to copy the one offending file VTS_02_1.VOB again and I get the same error. The error occurs a little less than half way through the file copy.
     
  4. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Please create a new logfile and post it as you did before. I want to see if the errors are in the same location again.
     
  5. rananaos

    rananaos New Member

    Here is the associated logfile.
     

    Attached Files:

  6. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    On the good side I see that the titlekeys are now being obtained correctly. That's one possible issue down. It's not a good thing if the titlekeys can't be obtained. On the downside I am seeing nothing that would make me see why the problem is occurring.

    Could you please try using the AnyDVD ripper or CloneDVD instead of copying from the DOS prompt? CloneDVD would be preferable since it can give a more detailed error message. Post the error message when you reply. :)

    Just for clarification we are talking about Secondhand Lions from 2004 starring Michael Caine, Robert Duvall, Haley Joel Osment and Kyra Sedgwick that was released by New Line Home Video?
     
  7. rananaos

    rananaos New Member

    I used CloneDVD and it made the backup with no errors. You have all of the information correct on the movie, it's a kids movie that they love to watch. This is actually the second copy I have bought because it gets a lot of damage.

    Here is the dirctory after cloneDVD
    Directory of C:\SECONDHAND_LIONS\VIDEO_TS

    03/22/2008 <DIR> .
    03/22/2008 <DIR> ..
    03/22/2008 18,432 VIDEO_TS.BUP
    03/22/2008 18,432 VIDEO_TS.IFO
    03/22/2008 81,920 VTS_01_0.BUP
    03/22/2008 81,920 VTS_01_0.IFO
    03/22/2008 1,073,739,776 VTS_01_1.VOB
    03/22/2008 1,073,739,776 VTS_01_2.VOB
    03/22/2008 1,073,739,776 VTS_01_3.VOB
    03/22/2008 840,536,064 VTS_01_4.VOB
    03/22/2008 71,680 VTS_02_0.BUP
    03/22/2008 71,680 VTS_02_0.IFO
    03/22/2008 315,392 VTS_02_1.VOB
    03/22/2008 14,336 VTS_03_0.BUP
    03/22/2008 14,336 VTS_03_0.IFO
    03/22/2008 133,120 VTS_03_1.VOB
    14 File(s) 4,062,576,640 bytes

    Total Files Listed:
    14 File(s) 4,062,576,640 bytes
    8 Dir(s) 31,513,616,384 bytes free

    Here is the directory from the DVD
    Directory of Y:\VIDEO_TS

    11/25/2003 03:58 PM <DIR> .
    11/25/2003 03:58 PM <DIR> ..
    11/25/2003 03:50 PM 18,432 VIDEO_TS.BUP
    11/25/2003 03:50 PM 18,432 VIDEO_TS.IFO
    11/25/2003 03:50 PM 20,035,584 VIDEO_TS.VOB
    11/25/2003 03:50 PM 81,920 VTS_01_0.BUP
    11/25/2003 03:50 PM 81,920 VTS_01_0.IFO
    11/25/2003 03:50 PM 52,502,528 VTS_01_0.VOB
    11/18/2003 04:27 PM 1,073,731,584 VTS_01_1.VOB
    11/18/2003 04:28 PM 1,073,405,952 VTS_01_2.VOB
    11/18/2003 04:30 PM 1,073,561,600 VTS_01_3.VOB
    11/18/2003 04:31 PM 841,056,256 VTS_01_4.VOB
    11/25/2003 03:54 PM 71,680 VTS_02_0.BUP
    11/25/2003 03:54 PM 71,680 VTS_02_0.IFO
    11/18/2003 04:32 PM 1,073,590,272 VTS_02_1.VOB
    11/18/2003 04:33 PM 1,073,143,808 VTS_02_2.VOB
    11/18/2003 04:35 PM 1,073,358,848 VTS_02_3.VOB
    11/18/2003 04:36 PM 840,796,160 VTS_02_4.VOB
    11/25/2003 03:58 PM 14,336 VTS_03_0.BUP
    11/25/2003 03:58 PM 14,336 VTS_03_0.IFO
    11/18/2003 04:36 PM 133,120 VTS_03_1.VOB
    19 File(s) 8,195,688,448 bytes

    I did a quick scan at 32x and everything seems to be there from the CloneDVD. The sizes on VTS_02_1.VOB, VTS_02_2.VOB, VTS_02_3.VOB seem odd.
     
  8. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    I can only assume that CloneDVD is correcting something in the process that can't be done with the copy command from the MS-DOS prompt. Using the AnyDVD ripper should also work, as well, since they both share the same ripping code.

    I'm glad to hear you managed to make your backup but I can't speak as to the exact cause other than what I already said. I'd recommend using the AnyDVD ripper or CloneDVD over the copy command in the future.
     
    Last edited: Mar 22, 2008