Incorrect audio

Discussion in 'AnyStream' started by David-SP, Apr 3, 2021.

  1. David-SP

    David-SP Member

    When downloading some movies or series from Amazon Prime, sometimes the wrong audio is downloaded. I live in Spain, Madrid but download the Latin American Spanish [Not Spanish Spain]. However, on my TV I watch the same series and movie in Spain Spanish. The problem exists for a long time. Now I am using the version [SetupAnyStream_1.1.0.0_64bit]
     
    Last edited: Apr 5, 2021
  2. Ch3vr0n

    Ch3vr0n Translator NL

    AnyStream downloads the tracks you select, ant nothing else. It's also limited by what tracks the provider makes available to AnyStream. Let's start by you providing a logfile for such a supposedly problematic title.

    Sent from my Pixel 3 XL using Tapatalk
     
  3. David-SP

    David-SP Member

    To all users. Please read before replying.

    Anyway thank you very much for your answer.
    I have been using the program for a long time and I know how to select the desired language. I must say again. On my Phone & TV I watch the same series and movie in Spain Spanish.
    here I attach the log file.
     

    Attached Files:

    Last edited: Apr 5, 2021
    whatever_gong82 and Gummigutta like this.
  4. Prospere

    Prospere RedFox Development Team

    @David-SP Thanks a lot for the logs!
    I am on it now.
     
    whatever_gong82 likes this.
  5. David-SP

    David-SP Member

    Now I have installed the version 1.0.9.0_64bit and everything is perfect. Now is downloading the correct language. Not the language that does not appear in the content. But the download speed is very slow. [dowload speed I set unlimited]
     
    Last edited: Apr 9, 2021
  6. David-SP

    David-SP Member

    This Same problem with SetupAnyStream_1.1.0.2_64bit. The last 2 versions of AnyStream downloads wrong audio. Although it does not appear in the program option even in the mobile application and the TV, the downloaded audio does not match the chosen audio. However as I said on TV and mobile it is heard correctly. I am currently using the v1.0.9.0_64bit.
     
  7. Ch3vr0n

    Ch3vr0n Translator NL

  8. David-SP

    David-SP Member

    Thanks for your answer, but it is different. Latin American Spanish is downloaded and not Spanish Spain. Latin American Spanish is not listed in the audio option. That happens with the last two versions 1.1.0.0 and 1.1.0.2. But with version 1.0.9.0 everything is fine. It is slow but with the correct audio.
     

    Attached Files:

  9. Ch3vr0n

    Ch3vr0n Translator NL

    Which makes it the same problem.
     
  10. David-SP

    David-SP Member

    Soppy but, it is not the same. For "Nacho Man" the language is missing, for me download Latin American Spanish which does not appear in the download option. I have modified the registry, adding the language codes. [HKEY_CURRENT_USER\SOFTWARE\RedFox\AnyStream\Media] "PrefAudioLanguage" are set only: es es-ES I added:
    es_ES
    es_es
    es_SPA
    es_spa
    SPA
    spa
    ES
    es
    In some series it is fixed, in most series no.
     
  11. Ch3vr0n

    Ch3vr0n Translator NL

    That's because your registry entries arent the fix. AnyStream lists the audio tracks its being offered by the streaming provider (and there can be an error in the anystream code identifying them), not the ones based on your system locale or your region.
     
  12. David-SP

    David-SP Member

    No no. With this modification I fixed it. I have tried everything. Edit, delete, reinstall, clear registry key and it only works fine with my modification except the versions 1.1.0.0 and 1.1.0.2.
    The registry key I have modified 1 hour ago.
     
    Last edited: Apr 9, 2021