Help with GameJackal 2.9.18.590 and profiel not working?

Discussion in 'GameJackal' started by Dyslextic, Oct 2, 2007.

  1. Dyslextic

    Dyslextic Active Member

    Hello,

    I have been a long time user of Game Jackal. I am currently running Game Jackal version "2.18.17.500". I purchase a upgrade from SlySoft and when I install Game Jackal version 2.9.18.590, it install but when I run that version, none of my profiles work except "Company of Heroes" and "Super commander". All the rest of my profiles (for example, Age of Empires III and it expansion pack, Heroes of Might and Magic 5, Oblivion, Caesar IV, plus many others) fail to run.

    Every one of them comes up with a dialog box asking for the CD/DVD to be inserted. I have even inserted the CD/DVD and play the game for a hour or so, the exit it. Game Jackal then process to profile it but when it done, the profile still does not work.

    What really is strange is that all these profiles work just fine using the old version of Game Jackal (version 2.18.17.500). Any one know what to do? I have email SlySoft tech support.

    Note, I have Acronis TrueImage and have restore my PC back to the pre Game Jackal upgrade and all my profiles once again work. I have been thought this upgrade/restore process a many times. Always the same results.

    Also, I have check to make sure that after the upgrade, GameJackal.exe was the right version and that MaplomH.dll was also install and the right version. I also check to make sure that my profile key was the same as before and it is.

    Thanks for your help,
    ~Dyslextic
     
  2. Webslinger

    Webslinger Retired Moderator

  3. Dyslextic

    Dyslextic Active Member

    1. What version of Game Jackal are you running?

    2.8.17.50 currently as 2.9.18.590 does not work with my already created profiles.

    2. What Operating system are you using? 64 bit? service pack?

    Windows XP Pro (32Bit edition), Service Pack 2, plus all patch to date.

    3. If you have virtual drives, disable them while profiling and playing profiles.

    Do not have virtual drives.

    4. Remove packet writing software from your system (including Roxio's Directcd, Nero's Incd, Roxio/Sonic's DragtoDisc, Drive Letter Access, CyberLink InstantBurn, etc.)

    Do not have packet writing software.

    5. What protection does your game use? Don't know? Find out before posting about issues (and include that information)! Use Protection ID. It's a free program. Use ProtectionID and scan your HD directory where the game is installed (right click the icon on your toolbar, and select "scan files/folders"). Or just scan the main program .exe(s) that you find in the game directory on your hard drive. Provide the protection name and the version number.

    Well it depends on the game being played.

    6. What is the name of the game you're trying to run?


    7. What is the version of the game?


    8. Is it cd or dvd version?

    Does not matter.


    9. What region or country is the original disc from?

    All games disk are from USA.

    10. What cpu are you running?

    Core2Duo.

    11. What optical drives (dvd-rom,cd-rom, burners) are you using to create profiles with? What firmware version is installed on your reader?

    LG DVD burner model GSA-H62L.

    12. What security software (firewall, antivirus) are you using? Please provide version numbers.

    NOD32 version 2.7

    13. Describe your problem, provide full error messages, and please state clearly what you were doing when you received those error messages.

    As stated early, when I upgrade to Game Jackal 2.9.18.590, the program will not run any of my existing profiles (except for "company of Heroes" and Supreme Commander") that work just fine under the previous version (2.8.17.500). When I use Acronis to restore my system to be it state before the upgrade, Game Jackal 2.8.17.500 runs the existing profiles just fine.

    Any ideas how to fix this??

    ~Thanks for your help,
    Dyslextic
     
  4. matthew

    matthew SlySoft Team Member

    Do you have any Arcsoft software installed on your PC?
     
  5. Dyslextic

    Dyslextic Active Member

    No, I do not have any ArcSoft software installed.

    Any ideas how to fix this?

    Thanks for your help,
    Dyslextic
     
  6. Webslinger

    Webslinger Retired Moderator

    1. a) Download imgburn. It's a free program: http://www.imgburn.com/index.php?act=download
    (it's also an excellent program imo)

    b) Go to Tools > Filter Driver Load Order. Click "Clipboard". Then paste the information you pasted into your clipboard into your next post (ctrl-v).

    2. Have you tried creating new profiles?

    3. Try the latest beta version that is stickied at the top of the forum please.
     
    Last edited: Oct 5, 2007
  7. Dyslextic

    Dyslextic Active Member

    Hello,

    I have download the new beta version of Game Jackal and still have the same problem with the profile asking for the CD/DVD. I have download and run the IMGBurn software. Here is the info from "Tools > Filter Driver Load Order"

    ===============================================
    Filter Driver Load Order - ImgBurn v2.3.2.0
    ===============================================

    Upper Device Filter: redbook
    Upper Class Filter: maplom
    Device: CD/DVD-ROM Device
    Lower Class Filter: [None Found]
    Lower Device Filter: imapi

    Filter Name: redbook
    File Name: C:\WINDOWS\system32\DRIVERS\redbook.sys
    File Version: 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
    File Description: Redbook Audio Filter Driver
    Product Name: Microsoft® Windows® Operating System
    Product Version: 5.1.2600.2180
    Company Name: Microsoft Corporation
    Copyright: © Microsoft Corporation. All rights reserved.

    Filter Name: maplom
    File Name: C:\WINDOWS\system32\Drivers\maplom.sys
    File Version: 2, 9, 18, 591 [2.9.18.591]
    File Description: Maplom.sys
    Product Name: Game Jackal
    Product Version: 2, 9, 18, 591 [2.9.18.591]
    Company Name: SlySoft Inc.
    Copyright: Copyright © 2007 SlySoft Inc.

    Filter Name: imapi
    File Name: C:\WINDOWS\system32\DRIVERS\imapi.sys
    File Version: 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
    File Description: IMAPI Kernel Driver
    Product Name: Microsoft® Windows® Operating System
    Product Version: 5.1.2600.2180
    Company Name: Microsoft Corporation
    Copyright: © Microsoft Corporation. All rights reserved.


    I have not try creating new profile and am really hoping I don't have to recreated all my profiles. Does any one any more ideas on how to fix this problem??

    Thanks for your help,
    Dyslextic
     
  8. Webslinger

    Webslinger Retired Moderator

    Your filters look fine.

    Other than double-checking the following, I would try creating a new profile to see if it works:

    1. If you have virtual drives, disable them while profiling and playing profiles. This includes Daemon Tools, Alcohol 120%, Virtual Clonedrive, Clonecdtray, and possibly Anydvd.

    2. Remove packet writing software from your system (including Roxio's Directcd, Nero's Incd, Roxio/Sonic's DragtoDisc, Drive Letter Access, CyberLink InstantBurn, etc.)

    Otherwise, I'm out of suggestions. Perhaps Matthew might have some other ideas.
     
  9. matthew

    matthew SlySoft Team Member

    Unfortunately... for the fixes to the "Insert cd" error to be effective, you will need to re-profile the games.
     
  10. Dyslextic

    Dyslextic Active Member

    Hello,

    Just wanted to let you folks know that I solved the problem. What happen was that when I upgrade Game Jackal, I did an "over the top" upgrade and did not first uninstall the old version of Game Jackal (the version I had been running until this upgrade was 2.8.17.500 - last one released by the previous owners before SylSoft folks acquired the software). Therefore all my short cuts where pointed to "maplom.exe" and not "GameJackal.exe". Once I change the shortcuts to point to the correct executable, it all work correctly. So even thought I had upgrade the software, it was still trying to run the old executable with the newer ".dll's" which was causing my problem.

    I have now uninstall the old version of Game Jackal (2.8.17.500) and then install SlySoft version of Game Jackal. Once I had the new version license and pointed to the correct location for the profiles, all profiles are working as before. :)

    Sorry for the problem, my mistake, I must have miss the direction to uninstall the pre SlySoft version of Game Jackal before I install any version of SlySoft Game Jackal.

    Thanks for all your help,
    Dyslextic
     
  11. matthew

    matthew SlySoft Team Member

    Good to see you go it sorted ;)