GameJackal v4 won't install

Discussion in 'GameJackal' started by balrog9, Dec 26, 2009.

  1. balrog9

    balrog9 Member

    I am unable to install GJP v4.0.1.5. I am running the beta of W7 (x64) and receive the following error:

    Error Creating Registry Key:
    HKEY_LOCAL_MACHINE\Software\Slysoft\Gamejackal\key
    RegCreateKeyEx failed code 1021:
    Cannot create a stable subkey under a volatile parent key

    I use Trend Micro Internet Security but have it turned off. I have tried installing under Vista SP2 compatibility, and failed, as well as running the install file as Administrator without success. This is a clean installation of GJP as I have not had it installed in W7 before.
     
  2. matthew

    matthew SlySoft Team Member

    Did you have v3 installed? The simply solution here is to manually create these keys(let me know if you need help with this).
     
  3. balrog9

    balrog9 Member

    No I have had no prior version of GJP installed in W7. I have been waiting for Slysoft to catch up to W7 before I installed. I know how to modify registry, have done it under XP numerous times before, but I am clueless what entries are required and what format they require. Could I install v4.0.1.5 under XP, export the reg string and then import it under W7? I have not looked at the W7 registry file so I don't know if that would work or not.
     
  4. matthew

    matthew SlySoft Team Member

    Hmmm a little odd. You could try manually creating to keys.

    Open regedit, and navigate to "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\"

    Then create a "SlySoft" key. Under that create "GameJackal" and "GameJackalv4" keys. Finally, under the GameJackal key create a "Key" key.

    Let me know if that helps.
     
  5. Agrajag

    Agrajag Member

    Same issue for me here. Trying to get around it now.

    UPDATE: That approach did allow it to work. I had to remove the keys you were able to create as Win7 wouldn't allow me to do anything with them as they were. Once I wiped them and recreated them it worked. This should get fixed.
     
    Last edited: May 8, 2010
  6. Mickey21

    Mickey21 New Member

    I found in this case that I got the error, installing the version 3 file first, then installing the version 4 worked fine... Of course subsequently uninstalling version 3 leaving 4 working fine...
     
  7. Agrajag

    Agrajag Member

    I also have other issues and I suspect it's x64 or x64 Win7.

    I didn't get any Manager icons. Just the server stuff and the Diagnostics so I had to create the manager icon myself. I also often lose all site of the Manager when it is running. If another window goes over it that's generally when I can no longer get it back. I can see the task bar item but clicking it does nothing.
     
  8. matthew

    matthew SlySoft Team Member

    Does this happen after you minimize the manager window?
     
  9. Agrajag

    Agrajag Member

    Minimize, it turns out, doesn't always work for me. I click it and nothing happens. Then, at other times, it does work.

    However, when it works I am able to them bring back the app to the foreground.
     
  10. matthew

    matthew SlySoft Team Member

    Unfortunately I have no idea what is going on here. Most likely a conflict with some other software. Can you think of anything installed on your system that could cause this type of issue?
     
    Last edited: May 11, 2010
  11. Agrajag

    Agrajag Member

    None really. I have ESET's NOD32 installed. Carbonite and not much else.

    What's worse for me is that the two games I needed this for (Company of Heroes and X-Plane) both fail using the profiles GJ created for them.

    Kinda down on GJ right now.
     
  12. matthew

    matthew SlySoft Team Member

    Well I'm happy to help you try and sort out these issues.
    First see this thread and give us some details. Mainly interested in point 3 (protection used), but any other info you have would be great also.

    In the meantime we'll look into the minimize issue.
     
  13. matthew

    matthew SlySoft Team Member

    Ok we have been over the code and cannot find an issue.

    I want to clarify the existing functionality.
    1) When Game Jackal is display and a profile IS NOT active, minimizing the window simply minimizes it to the taskbar. It should also restore accordingly.
    2) When Game Jackal is displayed and a profile IS active, minimizing the window moves it to the system tray (it should be displayed as an icon). Clicking this icon should restore it.