GameJackal 3.0.0.5 release

Discussion in 'GameJackal' started by Tom, Feb 15, 2008.

  1. Tom

    Tom Redfox Team Member Staff Member

    http://www.slysoft.com/download.html

    Known bugs: The context menu option for “Create a Game Jackal profile” does not work under Vista 64.

    Release v3.0.0.5 - release (2008-02-15)
    • Addional advanced profile options.
    • Further driver bug fixes and enhancements.
    • Language updates.

    Release v3.0.0.4 - beta 4
    • Improved profiling speed.
    • Fixed a number of bugs with profile maps and "automatic" mode.
    • Fixed a corruption issue when profile is re-captured.
    • Fixed "No DVD inserted" message that some games have been experiencing.
    • Fixed a bug in the "profile update" option.
    • Fixed BSOD and driver lock up issues under Vista 64.
    • Fixed a bug that could cause a slow shutdown on Vista 64
    • Numerous driver bug fixes.

    Release v3.0.0.1 - beta 3
    • Fix to the installer which copied 64 bit drivers to the wrong location.
    • Fixed intermittent BSOD under Vista 64.

    Release v3.0.0.0 - beta 2
    • Change to the version number format (to bring it into line with other SlySoft products).
    • New driver architecture.
    • 64 bit support.
    • Driver and application signing.
    • Improved Vista support (new manifest added which should force Vista to prompt for elevation if required).
    • Improved profile map support.
    • Improved advanced profile options including date fixing for a profile.
    • New interface skin.
    • Profile library location can now be explicitly set to a new location (this can currently be done by modifying the registry entries "Profile Library" and "Profile Library Dir")
    • Fixed a bug that was reporting invalid disk space when creating a profile.
    • Fixed a bug that could cause the "missing file" message to be displayed at startup.
    • Numerous interface changes and updates.
     
  2. Charlie

    Charlie Well-Known Member

    Thanks Matt. Thanks Tom for Posting :)
     
  3. d.chatten

    d.chatten Well-Known Member

    Does this version fix the BSOD when installing/uninstalling the KB943899 update from Microsaoft.

    Thanks!
     
  4. Charlie

    Charlie Well-Known Member

    Not sure I have all the latest hotfixes for vista. I'll reboot and see.
     
  5. Charlie

    Charlie Well-Known Member

    No lags in Vista 64 with SP1 now as it was in the beta. :)
     
  6. FFLenny

    FFLenny Member

    Parameter passing to BF2142

    Hello, I have been a GJ user since April 2005 but this is my first post to these forums.

    Regarding this latest release, it appears that GJ is still not properly passing shortcut parameters to BF2142, at least not for me. This has been happening for the past several official releases if I'm not mistaken.

    For example these are my BF2142 profile parameters:

    +menu 1 +fullscreen 1 +szx 1280 +szy 1024 +eaAccountName xxx +eaAccountPassword xxx +soldierName xxx

    The game should load straight into the main game menu but instead I'm prompted for my EA account login. If I use this same parameters on the regular BF2142 (not GJ) shortcut it works as expected bypassing the EA account login and soldier selection screens. This indicates to me that there is a problem in the way GJ is launching the game.

    Is anyone else experiencing this or is it just me?
     
  7. Tony474

    Tony474 Member

    I've this bug even with Windows Vista 32 Bit Home Premium. “Create a Game Jackal profile” does not work and putting the shortcut from the desktop to Game Jackal does not work too.

    I can't still make a working profil with cod4sp (mp is working!), Anno1701 and Trackmania United.

    Regards

    Tony474
     
  8. Blazkowicz

    Blazkowicz Well-Known Member

    CoD4 MP is not protected. CoD 4 SP is protected with SafeDisc 4.81.000. The other both games has Tages as copy protection and GameJackal doesn't support Tages yet.
     
  9. bundeva

    bundeva Member

    Great, this latest release solved my problem with San Andreas. Thanks :)
     
  10. FFLenny

    FFLenny Member

    Parameter passing to BF2142 - possible fix

    I think I might have a fix for this.

    I experimented with different variations of bf.bat and came to the following conclusions:

    1. This normal bf.bat does NOT correctly pass the parameters to BF2142:

    rem Battlefield launcher [2/16/2008 12:31:58 AM]
    C:
    cd \Program Files\Electronic Arts\Battlefield 2142\
    start "Battlefield" "C:\Program Files\Electronic Arts\Battlefield 2142\BF2142.exe" "+menu 1 +fullscreen 1 +szx 1280 +szy 1024 +eaAccountName xxx +eaAccountPassword xxx +soldierName xxx"


    2. This bf.bat WORKS and appears to pass all parameters properly. Note the differences in the START command syntax. It doesn't like the quoted title "Battlefied" nor the other quotes as well and the full path before BF2142.exe is unnecessary.

    rem Battlefield launcher - Fixed version
    C:
    cd \Program Files\Electronic Arts\Battlefield 2142\
    start BF2142.exe +menu 1 +fullscreen 1 +szx 1280 +szy 1024 +eaAccountName xxx +eaAccountPassword xxx +soldierName xxx


    3. Since every time BF2142 is launched from GJ the bf.bat appears to be recreated I don't see any easy way for the user to use the fixed version of bf.bat. But I'm far from an expert on the internal workings of GJ so perhaps there is.

    Could the developers please investigate this and consider fixing it in the next release?
     
  11. Bifford

    Bifford Member

    Beautiful guys! Neverwinter Nights 2 now loads fine and doesn't BSOD on me so yay! :D

    Thanks.
    Sam
     
  12. g@m3rz

    g@m3rz Member

    The "Fix date" option under Advanced options still doesn't accept a date.
     
  13. matthew

    matthew SlySoft Team Member

    We could not find an issue with this. Can you post the date you are trying (and the format)?
     
  14. FFLenny

    FFLenny Member

    Parameter passing to BF2142

    Matt, did you see my posts from a few days ago regarding Battlefield 2142 parameters back on page 1 ?
     
  15. g@m3rz

    g@m3rz Member

    I am using the example format, yyyy/mm/dd. Specifically; 2008/02/13.

    Thanks
     
  16. g@m3rz

    g@m3rz Member

    OK - I got it to accept the date by changing the date format in Windows to match that date exactly. It doesn't seem to matter to World in Conflict though. I still need to change the current date back to the profile date in order to get the game to start. Then I can change the computer date back to the correct date and play.

    Any suggestions?
     
  17. Roper's Minion

    Roper's Minion New Member

    Diablo I, Diablo II

    This latest version fixed the insert disk error with Vista-32 for Diablo II, but Diablo I (and Hellfire by definition) still don't seem to work.
     
  18. matthew

    matthew SlySoft Team Member

    Yes... we are looking into it.
     
  19. olong

    olong Member

    UAC problem, Help!

    -------------------------
    1) Make sure the game has been patched with the latest updated available.
    2) Run Game Jackal as administrator. To do this right-click the Game Jackal icon, select "Properties", followed by the "Compatibilty" tab. Then check "Run this program as administrator".
    3) If you still experiencing problems, turning off UAC will fix most issues (we only recommend this option for experienced users).
    ------------------------
    .
    I did step (1) but don’t know which patch?
    I also did step (2) but won’t work!.

    Question: Is there a way to Disable UAC for GameJackal ONLY (instead to turn off UAC completely)?

    Thanks up front.:confused:
     
  20. matthew

    matthew SlySoft Team Member

    What is the problem exactly?
    FYI you can not disable UAC for a specific application.