GameJackal 3.0.0.0 beta (64 bit support)

Discussion in 'GameJackal' started by Tom, Jan 8, 2008.

  1. Tom

    Tom Redfox Team Member Staff Member

    http://sandbox.slysoft.com/gj/SetupGameJackal.exe

    Users installing this on 64 bit systems
    This beta does not work with Vista 64 (the drivers were not signed correctly).
    However, this beta should work with XP 64 providing you move the files as directed below.

    Important note when installing on 64-bit system
    The installer is coping the Game Jackal drivers to the wrong location. After installing (and before rebooting), you need to copy the 2 Game Jackal drivers maplom.sys and maploml.sys from
    C:\WINDOWS\SysWOW64\Drivers
    to
    C:\WINDOWS\system32\drivers


    Release v3.0.0.0 - beta 2

    • Change to the version number format (to bring it into line with other SlySoft products).
    • New driver architecture.
    • 64 bit support.
    • Driver and application signing.
    • Improved Vista support (new manifest added which should force Vista to prompt for elevation if required).
    • Improved profile map support.
    • Improved advanced profile options including date fixing for a profile.
    • New interface skin.
    • Profile library location can now be explicitly set to a new location (this can currently be done by modifying the registry entries "Profile Library" and "Profile Library Dir")
    • Fixed a bug that was reporting invalid disk space when creating a profile.
    • Fixed a bug that could cause the "missing file" message to be displayed at startup.
    • Numerous interface changes and updates.
     
    Last edited by a moderator: Jan 11, 2008
  2. Webslinger

    Webslinger Retired Moderator

    WOOOOOOOOOOOOOOT! :bowdown: :clap:

    I'm going to give this a try tomorrow on Vista 64 bit Ultimate edition.
     
  3. evlncrn8

    evlncrn8 Well-Known Member

    ---------------------------
    Error
    ---------------------------
    Error creating registry key:

    HKEY_LOCAL_MACHINE\Software\SlySoft\GameJackal\Key

    RegCreateKeyEx failed; code 1021.

    Cannot create a stable subkey under a volatile parent key.

    Click Retry to try again, Ignore to proceed anyway, or Abort to cancel installation.
    ---------------------------
    Abort Retry Ignore

    happens during installation.....
    ---------------------------

    also, when adjusting the class filters, its a good idea to PRESERVE the ones existing, and not just put in
    maploml / maplom into it...

    now i cant read from my dvd drives..

    awesome...

    Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

    and all my cd/dvd drives (incl. virtual ones) now have the lovely yellow exclaimation mark infront of them
    in device manager....simply because pxhlpa64.sys was removed from the class filters...

    sigh
     
    Last edited: Jan 8, 2008
  4. Starfield

    Starfield Member

    Some Issues.

    Installation finished on my machine.

    Upon a reboot, all of my dvd drives were now non-functional. Removing the drive and telling windows to find it again did not work, it still failed to install the proper driver for it. Rebooting did not fix the issue. Upon uninstalling 3.0 my DVD drives were detected and functioning fine in Vista x64.

    Hope this helps some.
     
  5. Charlie

    Charlie Well-Known Member

    Thanks Tom. Will be testing it out today on Vista 64.
     
  6. Charlie

    Charlie Well-Known Member

    Installed just fine with no errors. Then I rebooted ad got this...

    [​IMG]

    [​IMG]

    So now what? I rebooted twice. Bios sees my Samsung 203N SATA drive but not my BenQ 1620 or my LG H55L.
     
  7. Charlie

    Charlie Well-Known Member

    Save yourself this time and wait for beta 3.
     
  8. Tom

    Tom Redfox Team Member Staff Member

    argh! I sent Matt (main GJ developer) an e-mail. Hopefully he'll show up soon...

    :bowdown:
     
  9. Charlie

    Charlie Well-Known Member

    Thanks Tom. I am eager to try it again and again. :D
     
  10. evlncrn8

    evlncrn8 Well-Known Member

    issue is caused because it completely hoses the class filter keys :(
    i tried manually adding the maplom filters, still no result, cd/dvd not present, removing the maplom and reverting to the backup i made (might be a good idea if gj does this too) got the drives back... happened on xp64

    surprised this wasnt noticed during testing....
     
  11. Webslinger

    Webslinger Retired Moderator

    Errr . . .

    O.k., I'm not going to try this beta then on Vista 64 bit Ultimate edition.

    The beta does work on XP (32 bit).
     
  12. evlncrn8

    evlncrn8 Well-Known Member

    yup 32 bit is fine, its the 64 bit thats the problem
     
  13. lostinlodos

    lostinlodos Well-Known Member

    Vista x64 Ultimate (SP1 FR). All my SCSI devices showed up as "removable disk" and can't be accessed. My SATA drives work fine but my IDE/ATA drives are gone.
    Um...oops!?

    For some reason I can't get it to install on XP x64? It says that the software is not supported for this version.

    This version can not be ghosted (run from one OS on another) in VirtualPC.
    "The Following Errors Have Been Detected;
    Invalid Instruction Set, ICO 3333333
    Fatal Stop Error"
    VPC then shuts down
    I click help, to find out what the hell all those 3s are and it says Microsoft doesn't support ANY software on a computer running beta (Service Pack 1) services. Argh.
    Not sure if any of the developers have SP1 FR but it would be useful to test that out with SP1 being released shortly. Not sure who's fault that issue is though.
     
  14. Charlie

    Charlie Well-Known Member

    Just a bump so when a user clicks on the last post they can see that the 64 bit has issues.
     
  15. matthew

    matthew SlySoft Team Member

    Hmmm... well not the start I had hoped for :doh:

    From the posts it looks as if the updating of the registry's class filter drivers is causing the issue and / or the drivers are not loading. This was tested (quite heavily) without issue.

    For those users that have reported drives no longer visible, open the following key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}" and remove the maplom and maploml entries and then reboot. This should get your drives back. Then can you do a search for maplom.sys and maploml.sys to find their location and let me know if they are found or not (and location).
     
  16. matthew

    matthew SlySoft Team Member

    Ok... have found the problem.
    The class filter registry setting are being created correctly. This issue is that the drivers are being copied to the wrong location during installation. See post http://forum.slysoft.com/showpost.php?p=78917&postcount=1
    This is the reason the cd/dvd drives are missing upon reboot (the drivers could not be loaded).
     
  17. pxmm

    pxmm Member

    The fix posted doesn't work for me on vista home premium 64. I copied the files over before rebooting just like you said.
     
  18. Charlie

    Charlie Well-Known Member

    I haven't tried just yet but don't like the sound of the fix being that it is manually. No offence. Are we working on this so it'll install as needed?
     
  19. evlncrn8

    evlncrn8 Well-Known Member

    erm nope, that key can sometimes need extra data its MULTI_SZ type key, when i installed, it wiped out the pxhlp64 filter too and just had 'maploml' in its place... so they're far from created correctly... and the drivers were copied to the wow64 'node' of the system, as they should be... i guess you didnt pay attention to the file shadowing in 64 bit, especially concerning 32/64 bit executables and the system folder...
     
  20. matthew

    matthew SlySoft Team Member

    Well... I have tested this again and again and have not had an issue... no existing filter driver values were removed or changed. And given that this code has never cause an issue (as far as I know)... I'm not sure what has happened on your system. Has anyone else seen this?

    Hmmm... comments like " i guess you didnt pay attention to the file shadowing in 64 bit" aren't very productive. Maybe you should do a little reading on the "File System Redirection/OS protection" feature of x64 before making such a comment. If you are not happy with moving the drivers as suggested... then that is up to you.