GameJackal 2.9.18.590 released

Discussion in 'GameJackal' started by Tom, Sep 20, 2007.

  1. Tom

    Tom Redfox Team Member Staff Member

    http://www.slysoft.com/download.html

    Release v2.9.18.590 - release (2007-09-20)
    - Updated blacklisting support.
    - Improved German language support.
    - Improved dynamic extended profiling.
    - Inclusion of the Battlefield Performance Plugin. This will fix the performance issue
    some users have been experiencing with the Battlefield series.
    - Minor interface updates.
    - Update to the plugin interface (added extended event types).
    - Small changes to improve Enterprise support.
     
  2. Targon

    Targon Well-Known Member

    Neverwinter Nights 2 DVD still doesn't work under Vista with this new version. I get the same 9 minute "finalizing profile" which results in a bad profile.
     
  3. d.chatten

    d.chatten Well-Known Member

    @Tom

    Regarding the ussue with Acronis TrueImageMonitor.exe, with this new version of Game Jackal does the registry value "Use MaplomHSW" (under "HKEY_LOCAL_MACHINE\SOFTWARE\SlySoft\GameJackal") need to be reset back to (1) or should we leave it set to equal (0).

    Thanks!
     
  4. matthew

    matthew SlySoft Team Member

    Leave it as "0".
     
  5. matthew

    matthew SlySoft Team Member

    Interesting... This is one of our test games and it works fine here. What are the specific details of the issue?
     
  6. Targon

    Targon Well-Known Member

    I will try again after a full reboot, but Windows Vista Home Premium, 4 gigs system memory, Asus M2R32-MVP motherboard, and obviously using 2.9.18.590.

    When you did YOUR tests, how long does the profile take to create? Does it take the 5-9 minutes? I use the NWN2 profile within Game Jackal with auto mode.

    Edit: Rebooted, tested again:

    Ultra High Scan: Fast Drive takes 55-59 minutes
    Auto: Takes 9 minutes

    Results:
    On trying to run NWN2 with Game Jackal after trying both methods above, I get the "Neverwinter Nights 2 has stopped working" garbage.

    The following is from the details:
    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: nwn2main.exe
    Application Version: 1.0.6.980
    Application Timestamp: 00000000
    Fault Module Name: nwn2main.exe
    Fault Module Version: 1.0.6.980
    Fault Module Timestamp: 00000000
    Exception Code: c0000005
    Exception Offset: 0092a33a
    OS Version: 6.0.6000.2.0.0.768.3
    Locale ID: 1033
    Additional Information 1: 2309
    Additional Information 2: 62d79df7d790999d51cc9f537eb5220e
    Additional Information 3: 9186
    Additional Information 4: 96116c192735bc551d1ac69a081f2371

    Read our privacy statement:
    http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409
     
    Last edited: Sep 21, 2007
  7. d.chatten

    d.chatten Well-Known Member

    Thanks for clarifying.
     
  8. evlncrn8

    evlncrn8 Well-Known Member

    end result - game crashed itself, check drivers, direct x etc..
    also, does it happen if you dont use game jackal? (if not, its possibly some of gamejackals hooks)
     
  9. Fazuul

    Fazuul Member

    The download link is giving me version x.570, not 590.
     
  10. Targon

    Targon Well-Known Member

    While there are some people here that would post without checking, I am not one of them. This is a problem with Game Jackal(game works perfectly if I launch the game without GJ).

    This problem tends to show up if Game Jackal is not able to create a profile correctly due to problems with Game Jackal itself. From experience, if Game Jackal needs more than 1-2 minutes to create a profile, the profile will NOT be created properly, and trying to use a "broken" profile will cause problems like this. When Game Jackal had problems with Civilization 4 under Windows Vista for example, the same problem would show up, the profile would take over 5 minutes to be created, and then would not work.

    Crashing of the app is a bad reaction between the copy protection mechanism and Game Jackal. Some apps may not crash but may just demand the original CD/DVD. Others, like NWN2 will just crash.

    This problem is also a Windows Vista and Game Jackal problem since I have used Game Jackal with Neverwinter Nights 2 under Windows XP without a problem. There have been a good number of updates since Slysoft took over Game Jackal, most of them due to Vista issues. As a result, I do not blame Slysoft, and actually thank them for their hard work on the problems caused by Vista.
     
  11. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    Still having both problems... If you need more information, I will give it to you, but I provided all the initial information in the "do not work" thread.
     
  12. Bifford

    Bifford Member

    I can also confirm what Targon says. I'm running the latest Vista Home Premium, up-to-date NVidia drivers and direct x drivers.

    Under windows XP and GJ NWN2 worked fine.
    Under windows Vista without using GJ NWN2 loads fine (needs CD of course) but with GJ I get one of three problems - "Insert DVD" or a BSOD's and crashes out. Or else "NWN2 has stopped working..."

    Creating the profile also takes 10 mins here. This latest version of GJ does some sort of profile creation before running NWN2, then loads NWN2 (i let it run all the way to the game menu without skipping anything). After quitting the game it then took 10 mins to profile.

    Here's the details given by windows:

    Problem Event Name: APPCRASH
    Application Name: nwn2main_amdxp.exe
    Application Version: 1.0.5.912
    Application Timestamp: 00000000
    Fault Module Name: nwn2main_amdxp.exe
    Fault Module Version: 1.0.5.912
    Fault Module Timestamp: 00000000
    Exception Code: c0000005
    Exception Offset: 0072b553
    OS Version: 6.0.6000.2.0.0.768.3
    Locale ID: 2057
    Additional Information 1: 1e7e
    Additional Information 2: a1f99e0ddb2c69e681ffd418df1a19bd
    Additional Information 3: 4401
    Additional Information 4: d37616dedbf251d674f81bdf7ac61e6c


    Having looked at Targons' data I think i'll check to see if there's an update to my version of NWN2 :) But the same problem exists.

    Thanks.
    Sam
     
  13. Bifford

    Bifford Member

    I'll post this one as a seperate item as it's a "across the board" GJ problem I have.

    90% of the games I run or try to profile refuse to be deactivated. I run a profile or I try to profile a game and when I quit the game GJ refuses to notice and is still flashing it's icon and I have to select "deactivate ##{game}##" to end the process and then start profiling, but by hitting deactivate the profiling goes wrong most of the time.

    I love GJ but that problem is doing my head in!

    Sam
     
  14. matthew

    matthew SlySoft Team Member

    All those having problems with NWN2, please try :-
    Open regedit, head to "HKEY_LOCAL_MACHINE\SOFTWARE\SlySoft\GameJackal" and change the value "Use MaplomH" to 0 and then test again.
     
  15. matthew

    matthew SlySoft Team Member

    There is a file called "Proc Monitor.log" located in the GJ directory, can you post it here please (after you run a game that requires you to manually deactivate).
     
  16. Targon

    Targon Well-Known Member

    I shut down Game Jackal, set Use MaplomH to 0 using regedit, restarted Game Jackal, same results. 9 minutes to create the profile using Auto.
     
  17. pdp

    pdp Member

    Reboot required?
     
  18. Targon

    Targon Well-Known Member

    Most applications read the registry settings when they start, so what I did SHOULD have worked. Of course, if there is a service involved, then rebooting after the registry change might be required. I will wait for a Slysoft post before spending another ten minutes trying to make another profile though.
     
  19. matthew

    matthew SlySoft Team Member

    9 minutes is not out of the ordinary for a DVD (there is many... many sectors to scan). What i need to know is if you are still getting the error when the game starts??
     
  20. Bifford

    Bifford Member

    Hi Matthew.

    I did the regedit thing to 0 and now all NWN2 does when trying to make a profile is BSOD (did it twice in a row).

    Data on BSOD as below:

    Problem signature:
    Problem Event Name: BlueScreen
    OS Version: 6.0.6000.2.0.0.768.3
    Locale ID: 2057

    Additional information about the problem:
    BCCode: 50
    BCP1: FB42BB83
    BCP2: 00000000
    BCP3: 82037A34
    BCP4: 00000002
    OS Version: 6_0_6000
    Service Pack: 0_0
    Product: 768_1

    Files that help describe the problem:
    C:\Windows\Minidump\Mini092407-01.dmp
    C:\Users\Bifford\AppData\Local\Temp\WER-87250-0.sysdata.xml
    C:\Users\Bifford\AppData\Local\Temp\WERBB4C.tmp.version.txt

    ---
    [EDIT to include more comp info]

    GJ : 2.9.18.590
    DVD Version of NWN2. LAWFUL GOOD UK version.
    32 bit version of Windows Vista
    Mobo: MSI K7N2 Delta ILSR ( http://msicomputer.co.uk/index.php?func=proddesc&prod_no=546&maincat_no=1 )
    Chipsets: NVIDIA® nForce2 SPP Chipset
    NVIDIA® nForce2 MCP2/MCP2-T Chipset
    AMD Athlon XP 2000+
    NVIDIA GForce 6800 (Driver date 06/07/2007; Driver version 7.15.11.6222)
    NEC DVD RW ND3500AG ATA - DVD Rom
    1x SATA HD (C: and D: (NWN2 in C: most other games in F: ) and 2x IDE and external USB HDs
     
    Last edited: Sep 25, 2007