Forgien Films, Subtitles, SRT vs Bandwidth vs multiple stereo/5.1 tracks

Discussion in 'AnyStream' started by lajoes, Nov 2, 2020.

  1. lajoes

    lajoes Active Member

    Netflix Video: Saladin (Egyptian)

    I bought my Anystream license around 18 Oct and after trial and error, and looking through the forum, figured out how to get subtitles to show up.

    The video "lemonade Kid" (Czech) works fine. I downloaded the file as MP4 and the SRT.

    Now for some reason, I can not get it to work with this video. I have tried using different soundtracks, 5.1 instead of stereo, etc, made sure SRT was selected, heck, I event tried EMBEDDED and TTML, but I still can not get the subtitles to show.

    I've burned up a lot of my download allowance on this to get this far.....

    If I view the video on Netflix proper, they are there.....

    The only thing that I know was changed is that Anystream had a version upgrade to 10.5.0

    I am using Chrome Browser because I keep getting error messages when I use Firefox.

    It gets even hairier when there are even more sound tracks to choose from, like those in "my honor MY loyalty" (German).
     

    Attached Files:

  2. Prospere

    Prospere RedFox Development Team

    What player?
    I just tried Saladin on VLC and had no problem at all.
     
  3. lajoes

    lajoes Active Member

    I just loaded VLC and figured out how to get the subtitles to show while playing back on the laptop.

    Now, how can I get it to play on my OPPO 203.

    I was able to get it to accept the SRT file for Lemonade Kid, but I can not for these two flicks.

    This old cat has to learn all this on his own, I don't have any youngins' around to help me.

    Also, all the other [foreign] films I've opened and played back on the laptop just open up and play. Not sure what program it is, but I know it is not VLC.
     
    Last edited by a moderator: Nov 2, 2020
  4. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    you'll first have to figure out what subtitle formats that thing supports. Once you do that, you need to check up on how they need to be named and where they need to be located. There's a few ppl on here that have oppo's. I think @SamuriHL or @James are 2 of them
     
    lajoes likes this.
  5. lajoes

    lajoes Active Member

    Right now, I'm just burning everything to HD or flash drive, not burning discs. Just my physical media are all being backed up to HDD as ISO and MP4s, using using AnyDVD ripper & CloneDVD2 if I want a full copy or CloneDBD for only English sound tracks and subtitles (to save space).

    I've had a couple of lifetime licences over the years, just could not afford the HHD's or a powerful enough PC to push through quick backing up until recently. Now, I'm feeling comfortable with the programs until I can not find a solution in the forums.

    Got a big task ahead of me....
     
  6. lajoes

    lajoes Active Member

    ChevrOn, I got the OPPO 203 to work with the Lemonade Kid mp4 & SRT, so I thought I had everything under control. I don't see how to know the difference between SRT in the Anystream selection. It appears that it has something to do with the audiotrack....which I have no way of knowing.

    Is it possible to download all the audio tracks in one download with Anystream in order to make the selection during playback?
     

    Attached Files:

  7. SamuriHL

    SamuriHL Moderator

    I don't own one.
     
  8. Prospere

    Prospere RedFox Development Team

    No. Not yet, at least.

    However, could you upload a part of any of the SRT files that did NOT work?
     
  9. lajoes

    lajoes Active Member

    What I've been doing with my media is to create an ISO (either a full copy or selected parts (only Eng and subtitles - no Spanish, French, etc) and put each on its own HDD. The foreign films that I have copied were created with CloneBD or CloneDVD2/CloneMobile.

    I'd connect the HDD or flash drive directly to the OPPO and it would work.

    Anystream is the first program that I've used that uses a separate SRT, so that is a learning curve there.
     
  10. lajoes

    lajoes Active Member

    Once I get several HDD's filled, I'll start thinking about some type of server. It would be nice to have one that can decode the ISO's on the fly. That 'll free up an equal amount of HDD's for use as ISO's.
     
  11. whirlpool

    whirlpool Well-Known Member

    I found a problem with the downloaded SRT file and the Oppo 203 (on Netflix only).
    (Make the file name of the SRT file match the name of the mp4 file, with extension .srt)

    The time format seems to be unacceptable to the Oppo.

    I fixed the time format using a subtitle fix utility.
    The downloaded SRT has the format 0:0:0
    Needs to be 00:00:00 for the Oppo.
     
    Last edited: Nov 2, 2020
    lajoes likes this.
  12. Prospere

    Prospere RedFox Development Team

    Thanks for pointing out this problem!
     
    lajoes likes this.
  13. lajoes

    lajoes Active Member

    Morning whirlpool. I tried the renaming option, no luck. Originally, the SRT downloaded as "Netflix-Saladin.en.srt". I deleted the '.en' so it just listed as 'Netflix-Saladin.srt' Unfortunately that did not work.

    I don't know how to change the timing, but when I hit the info button on the OPPO, it shows the audio as "1/1 AAC" - which I believe means that it thinks it is showing the subtitles.
     
  14. lajoes

    lajoes Active Member

    I would upload the file if I could. Could you explain how I can do it? The 'upload a file' function says that it is not an accepted file format.
     
  15. whirlpool

    whirlpool Well-Known Member

    There's a better test for detection of the srt file. It's always the last entry in the subtitle dropdown list.
    Hit the subtitle button on the remote, you should see the last subtitle entry as 'other'.
    When you scroll down and select 'other' the subtitles are taken from the srt file.

    If you don't see 'other' when you hit the subtitle button, your srt file is not being detected.

    But, the default Netfix srt file format causes the red forbidden symbol on the top right of the TV screen. (Time format is 0:0:0 and the Oppo needs 00:00:00)
    Try subtitlefix.com and select option 'expand and narrow'
    Select your srt file (In a text editor note the last timestamp in the srt file)
    Make BOTH Hour Min Sec,nnn entries the same .
    Hit the send button, this saves the reformatted srt file.
    It doesn't change any timings but re-writes the times in the form HH:MM:SS.

    The Oppo is happy with that.
     
  16. lajoes

    lajoes Active Member

    Prospere and Ch3vr0n, I'd like to say "Thank you" for helping fix this subtitle problem. Everything fell in place when whirlpool joined the conversation and my light bulb stopped flashing and went steady.

    He was correct on the fix for the Netflix's red forbidden symbol with that link to "subtitlefix.com". That site made fixing the problem (changing the time format from 0:0:0 to 00:00:00) in one easy click. The site is in plain language and easy enough to figure out after what you guys said I should fix, so I knew what to look for.

    I selected the "expand and narrow" option and browsed to where my bad SRT file was. Then I used Windows file explorer to find the length of the flick and plugged in that time for both the start and stop times. I left the fps and removeHTMLflags options blank. Hit the send button and a second later, a file was returned with ALL the times in the Netflix SRT converted to the double ought format. I saved the new file to the movie's folder.

    As you'll notice the new fixed file has a different file suffix format "-2.txt" added to the original file's name as saved. I soon realized that I had to delete those changes and safe the file again. I left the "_exp." in the title before the ".srt" --- it works, so I'm not gonna get fuzzy. So, to clarify, the SRT file that works is, "Saladin_en_srt_exp.srt"

    Also, since this all started, I've learned that I can download the flicks without the originator's name listed in the file's name.

    Can I make a suggestion?

    I know I'm not the only inexperienced user to go through this, so my suggestion is: Add a highlighted topic area at the top of the Anystream forum (in yellow) so people can see the fix right off. But, I know there will be some that wont and eventually go searching. Maybe use the tags, "audio track, subtitles, foreign films, SRT, Netflix SRT" for example to steer people to it?

    Once again, Thank you to all once again for your time and patience.


    UPDATE: 2020 11 03 - I have to update that "fuzzy" feeling I had about leaving the modified SRT file from subtitlefix.com:

    Earlier I said that I just left the underscores in the corrected file, well I ran into one flick that did not really like them, "my word MY Loyalty".

    At first is just left it as My_Honor_Was_Loyalty_en_srt_exp.srt" after deleting the ".txt" sometimes it liked it, other times it did not.

    Therefore, I just retyped it to read: "My Honor Was Loyalty.srt" and that cleared up all the clitches.
     
    Last edited: Nov 3, 2020
  17. lajoes

    lajoes Active Member


    I also sent "subtitlefix.com" a 'Thank you' and they responded with:

    great!
    thanks for your feedback
    now it was worth making that site :)

    Me:

    I recently ran into a problem with Netflix's SRT files not working on my
    [OPPO] blue ray player.

    A moderator at Redfox suggested I try your program.

    It changed the SRT times from 0:0:0 to 00:00:00 format in one click.
    What a time saver!

    Thank you
     
  18. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    i can't help but to think it weird. The shows i downloaded (Star trek Discovery) for example from netflix, all had double digit timecodes.
     
  19. whirlpool

    whirlpool Well-Known Member

    Here's a snippet from Netflix-Star Trek- Discovery_S03E01_That Hope Is You, Part 1.en.srt...……………………………….
    (The Oppo doesn't like that timecode format, but other players could be OK)

    1
    0:0:12,012 --> 0:0:14,473
    [narrator]
    Last season on Star Trek Discovery:

    2
    0:0:15,098 --> 0:0:17,309
    [Burnham]
    As long as there's any possibility

    3
    0:0:17,392 --> 0:0:20,020
    of Control gaining access
    to Discovery's Sphere data,
     
  20. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    well i'll be damned. Must have overlooked it on my end. It's that way for me too; could have sworn it wasn't. It's picard that doesn't have that problem, but that's on prime. Plex doesn't have a problem with it though. Which option from the site above did you use (and how) to fix that timecode?