Failed to init ElbyCDIO!

Discussion in 'AnyDVD HD (DVD issues)' started by Jeff-, Sep 10, 2017.

  1. Jeff-

    Jeff- Member

    I've tried the last version that SlySoft released, and the most recent version from RedFox. I have tried uninstalling AnyDVD, I've rooted around in RegEdit to remove all keys that contain AnyDVD, ElbyCDIO, and I still cannot get it to run after installing.

    I've installed it as Administrator, and I've tried running it as Administrator. All fail with this message.

    I have run it on the exact same hardware before using Windows 7, 8, 8.1 and 10. But this last time I had to reimage the computer, now it doesn't work.

    Any advice would be greatly appreciated.
     
  2. antipodes

    antipodes Well-Known Member

    I assume you cannot produce log files but what is the message you get with the failures?
     
  3. James

    James Redfox Development Team Staff Member

    Do you have any anti-malware / virus software installed?
     
  4. Jeff-

    Jeff- Member

    Sorry, should have put the title in quotes. The error I get is: "Failed to init ElbyCDIO!"

    I am using Windows Defender, which I have used for years. It installs OK, but won't run.
     
  5. James

    James Redfox Development Team Staff Member

    What happens, if you enter this from a command prompt with administrator rights:

    net start elbycdio

    Do you see any messages in Windows' system event messages? Like

    Service Control Manager: Failed to start elbycdio, because ....
     
    nebostrangla likes this.
  6. Jeff-

    Jeff- Member

    At the command prompt, I get:
    The service name is invalid.
    More help is available by typing NET HELPMSG 2185.
     
  7. James

    James Redfox Development Team Staff Member

    This means, that Windows doesn't know the elbycdio driver. It probably isn't present in the Windows registry.
    Please take a look. Open regedit and navigate to
    Code:
    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
    
    Scroll down to "E". There you should find the key "ElbyCDIO". I have a feeling, it is missing on your machine.
     
    marlowe likes this.
  8. Jeff-

    Jeff- Member

    Correct. I do not have that key. How do I get it on there? Is there an export I can add to my registry?
     
  9. mike20021969

    mike20021969 Well-Known Member

    Here's the export from my registry.
    Extract ElbyCDIO.reg from .rar archive. Importing (by double-clicking) ElbyCDIO.reg may/may not work for you...
     

    Attached Files:

    Last edited: Sep 11, 2017
    whatever_gong82 likes this.
  10. James

    James Redfox Development Team Staff Member

    I suggest you remove "security" and "enum" from the file.
     
  11. Jeff-

    Jeff- Member

    That worked! I did remove the Security and Enum sections.

    I'd love to know what that key wasn't added the dozen or so times I tried to install, but thrilled it works again.

    Thanks!
     
  12. James

    James Redfox Development Team Staff Member

    Trust me, I would love to know the reason. You are not the only person with this problem, and I have no clue, why the key isn't added sometimes.
     
  13. mike20021969

    mike20021969 Well-Known Member

    Done. Re-uploaded file minus those entries.
     
    whatever_gong82 likes this.
  14. alexxwishez

    alexxwishez Member

    @James @mike20021969 Thank you so much for your help, guys!

    IT'S ALIVE!!

    I mean, it finally works now :dance::thankyou:
    The registry entry did the magic.
     
    whatever_gong82 likes this.
  15. x7007

    x7007 Well-Known Member

    Should I need to add this service if I don't have it on my windows 10 1703 services ? Anydvd works fine.
     
  16. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    It's not a service, it's a registry entry to fix a missing one that doesn't tell windows to load the driver. Completely different issue.

    Sent from my Nexus 6P with Tapatalk
     
  17. James

    James Redfox Development Team Staff Member

    No.
     
    Tourist likes this.