Failed file to decrypt returns wrong file name?

Discussion in 'AnyDVD HD (DVD issues)' started by dbminter, Jan 24, 2018.

  1. dbminter

    dbminter Active Member

    There appears to be a possible bug with the returned file name being given when AnyDVD fails to decrypt a VOB.


    I'm using the latest final version, 8.2.1.0, and came across a DVD where I could not fully extract VTS_01_2.VOB. When AnyDVD failed to decrypt the file, it returned that it failed on VTS_01_1.VOB.


    It seems the title stream where it's failing, the VTS has 3 VOB's: VTS_01_1.VOB, VTS_01_2.VOB, and VTS_01_3.VOB. I chose not to delete the files AnyDVD created. It created VTS_01_1.VOB, which was 0.99 GB, so that seems to have fully decrypted. VTS_01_2.VOB was only 525 MB, so it actually failed on VTS_01_2.VOB, but AnyDVD returned it failed on VTS_01_1.


    I don't know if this means there's a bug here, but it seems to be. With AnyDVD running, I tried copying and pasting VTS_01_1.VOB and VTS_01_2.VOB from the disc in File Explorer and it did fail to copy on VTS_01_2.VOB after successfully copying VTS_01_1.VOB. So, it seems that AnyDVD was returning it failed on VTS_01_1.VOB when VTS_01_1.VOB was actually successfully decrypted and AnyDVD should have been returning it failed on VTS_01_2.VOB.


    Thanks!
     
  2. StoneyJSG

    StoneyJSG Well-Known Member

    Possibly a bad disc (scratches, factory defect, etc.) or it needs to be cleaned. Do other discs work? You might want to try another copy of the disc that gave the error. You should also post a log file for AnyDVD so the people that know more about this stuff than I do (James, Pete, etc.) can narrow down your issue.
     
  3. dbminter

    dbminter Active Member

    I cleaned it twice. First with 90% isopropyl alcohol and, when it still failed, a 2nd time with a mixture of cleanser and "soap" used to clean eyeglasses. Failed on the 2nd attempt, too. The cleaning solution actually helped a little bit. Before I was only getting 3x read speed. After cleaning with the "soap" solution, I got 8x until it failed on the same VOB.


    So, yeah, it's a corrupt disc that is causing the read failure. Other discs do work, but even if it's because of a bad disc, why would AnyDVD return the wrong VOB file name for a failed decrypt?


    Oh, there's a log file? Shows what I know. I wasn't aware there was a log file generated by AnyDVD. Where is the log file stored? I'd like to take a look at it. See if there's anything there that might be "contradictory." e.g. does the log file show the erroneous file name being returned as unreadable in that?


    Maybe I read the error window wrong. Maybe instead of VTS_1_01.VOB it said VTS_1_01 VOB, meaning one of the VOB's in the VTS_1_01 stream was undecryptable. That that stream referenced as VTS_1_01 was not fully readable and that a particular, but unnamed, VOB file was unreadable. Looking at the log would probably tell me if I misinterpreted the error message.


    Thanks!
     
  4. Art Masson

    Art Masson Active Member

    Insert the disk and right click on the AnyDVD icon in your taskbar. There is an option to create a log file...select that and the log file will be created and you'll see a pop up with the file's location that you can upload. Good luck.
     
  5. dbminter

    dbminter Active Member

    Found it! Thanks!


    Unfortunately, the log is not in a human readable format, it seems. I tried loading it in Notepad and it was all gibberish. But, I have a log now I can send if necessary for debugging purposes.
     
  6. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    You need to attach it to a post. It's not a simple text file

    Sent from my Nexus 6P with Tapatalk
     
  7. Art Masson

    Art Masson Active Member

    Just use the "upload a file" feature here...and perhaps it will help someone knowledgeable here confirm the problem.
     
  8. dbminter

    dbminter Active Member

    But is it an actual log or just disc information? I saved a "log" renaming it to retain it and reran the decryption. After it failed, I tried taking a 2nd log but the log creation option is greyed out as long as the interface window for the actual decrypting function is open. When closed, the log creation function is available again and I created the 2nd log. But, it was the same file size as the first log, indicating to me that the "log" is not a true log, but a collection of information about the disc being decrypted. I doubt that will help here because the issue here is not that I can't decrypt the disc. I know I can't because the disc itself is corrupt. The issue is AnyDVD seems to be returning the wrong file name it says can't be decrypted. But I'll attach the log anyway.


    Oh, also, the error window when it fails says "AnyDVD Ripper - FileIO 3 - VTS_01_1.VOB 1625700352 313344" However, AnyDVD actually decrypted VTS_01_1.VOB fine. It is VTS_01_2.VOB that is only partially decrypted before encountering the bad area of the disc. Does that error message not actually return the file it failed on but returns the last VOB it fully successfully decrypted instead?


    Thanks!
     

    Attached Files:

  9. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    logfiles are used for diagnostic purposes only. They cannot be used for decrypting in any way. Being such an old title, i'm going with dirty/defective disc if the drive reads other titles just fine
     
  10. dbminter

    dbminter Active Member

    I know why I can't decrypt the disc. It's damaged in some way. It's not dirty, because cleaning didn't fix it, so it must be corrupt in some fashion. I'm trying to figure out why AnyDVD is returning it could not decrypt a file that it obviously did decrypt. It's saying it couldn't decrypt VTS_1_01.VOB when it did decrypt VTS_1_01.VOB fully. It's VTS_1_02.VOB that it fails to fully decrypt. It seems to be an error in the program. I can't see a dirty or damaged disc causing this. Although it could confuse AnyDVD, I suppose, into thinking it couldn't fully decrypt the wrong file that it did decrypt.


    As for the "logs," I was hoping it would contain the results of the actual decrypt, like where it failed. It appears the log is just general information of the source disc. I know they wouldn't be used for decrypting. I was expecting more like an ImgBurn log, where the log contains all the output messages from AnyDVD's actions during ripping. When I generated a log, it just says AnyDVD is scanning the disc and then generates a "log."