Error with Ghost in the Shell Bluray

Discussion in 'AnyDVD HD (Blu-ray issues)' started by simon_lefisch, Jul 5, 2019.

  1. simon_lefisch

    simon_lefisch New Member

    Hey everyone,

    I finally broke down and purchased the lifetime license after using the trial a while ago. Anyway, I get an error message when scanning my Ghost in the Shell bluray (not UHD, see attached screenshot). Everything works fine when I insert my Rogue One or Captain Marvel bluray so not sure what the issue would be. Also Tried Bumblebee and the same issue. I attached the log file for Ghost in the Shell and Bumblebee since it showed the same as the screenshot.

    Btw, this is a Region 1 disc and I am using a Windows 10 KVM.

    Screen Shot 2019-07-04 at 3.25.41 PM.png
     

    Attached Files:

    Last edited: Jul 5, 2019
  2. Pete

    Pete Forum Admin Staff Member

    The KVM seems to be the problem.
    It virtualizes the drive, but not correctly - rather not entirely (the required commands for authentication are not implemented, so they don't reach the drive).

    It's a problem, because those discs (as do nearly all recent titles) require bus encryption and your drive supports it. So it encrypts the data before it gets passed on to the host.
    AnyDVD wants to decrypt, but the communication fails.

    If you had an older BD drive, that doesn't support bus encryption, it would work.

    Or - maybe someone who has more experience with your specific VM can say how to make the drive virtualization function properly, possibly with something as simple as a driver update.
     
  3. James

    James Redfox Development Team Staff Member

    Code:
    HL-DT-ST BD-REWH16NS40 1.00
    Drive (Hardware) Region: free
    
    It seems that several commands are not forwarded correctly.
     
  4. simon_lefisch

    simon_lefisch New Member

    It seems you are both correct. I tried the same disc on my Windows 7 VirtualBox VM and the disc is able to be read. Kind of a bummer, but someone can help me setup the drive on my Windows 10 KVM properly as you suggested (trying to move away from VirtualBox).

    Thanks to you both for bringing that to my attention


    Sent from my iPhone using Tapatalk
     
    whatever_gong82 likes this.