Error Message: Cannot process request at this moment, please try again later!

Discussion in 'AnyDVD HD (Blu-ray issues)' started by Mustafa23, Aug 15, 2019.

  1. Mustafa23

    Mustafa23 New Member

    Hello,

    if I wan't to rip BDs, I get alway this error message.
     

    Attached Files:

  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    AnyDVD isn't designed to run in a virtual environment.

    Your virtual drive isn't properly identifying and communicating with the actual physical drive. Thus it cannot retrieve the disc's unique identifier (AGID) which anydvd needs in order to find the decryption info in the online database. Fix the drive problem and things should solve itself
     
  3. Mustafa23

    Mustafa23 New Member

    Thanks for the reply. It was no problem with earlier versions. So I have to find now another way.
     
  4. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Suit yourself, but I doubt even a revert if an anydvd version would be available option. You need to fix communication issue. Should be somewhere in your virtualbox settings

    Sent from my Pixel 3 XL using Tapatalk
     
  5. testiles

    testiles Well-Known Member

    Ch3vron, I can't read logfiles, but is there any chance Mustafa23 has a UHD mounted? Because that is the Unsupported message...

    I know that message may occur for other situations, but he did say he never had this problem before.... ???...



    T
     
  6. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    It's not, but doesn't matter. The log clearlly indicates a virtual machine setup

    And that's with a BD25 inserted, right no CD holds 25GB and VBOX is the classic model name for optical drive emulation in Oracle's "Virtual Box" software. And no, that message isn't restricted to UHD, but it IS an indication that IF an UHD is inserted, it's unsupported. That AGID message can happen on standard BD's too, if the optical drive can't read the physical disc's unique identifier or if the user is using a protected image that anydvd hasn't seen before.
     
  7. testiles

    testiles Well-Known Member

    Oh ok, got it.


    Thanks for the great explanation!



    T
     
  8. Pete

    Pete Forum Admin Staff Member

    While it wasn't explicitly designed to, it usually does work with a few caveats:
    • Yes, virtualized drives can be a problem, if either
      - the disc is unknown (AnyDVD then needs to authenticate with the drive and most virtualizations simply don't support that feature, though they could)
      or
      - the drive supports bus encryption (which also requires authentications, same reason)
    Your old drive doesn't support bus encryption, which is good. That is why everything worked fine so far.
    The disc you've inserted now, though, isn't yet in our database, that is the problem.

    Once anyone inserts it on a PC with a fully featured Blu-ray drive, it will work for you, too.
     
  9. James

    James Redfox Development Team Staff Member

    The trick to make it work, is NOT to virtualize the drive in the VM (and share it with the host) but to give applications within the VM exclusive access to the drive.
    This should be possible with most VMs. Easiest done with USB based drives, may be more difficult with SATA drives.
    Ask the VM experts howto...
     
  10. thetoad

    thetoad Well-Known Member

    get a usb drive, share the usb bus / drive with your VM, anydvd can then use it as physical disc. If you already imaged the disc, all you have to do is insert it for anydvd to get the keys and then can mount the image you already made. In KVM its simple.

    And when this happens be happy to know that you are the first person to ever rip this disc with anydvd (at least on an internet connected machine). I'm not ripping anymore (move out of the US, so had to give up my supply of physical BRs), but it worked for me.