Encoding cuts of first 0.5-1.5 seconds

Discussion in 'CloneDVD mobile' started by TM2-Megatron, Feb 7, 2007.

  1. TM2-Megatron

    TM2-Megatron Well-Known Member

    I've gone through a couple e-mails with the Slysoft tech support team about this a few weeks ago, but haven't heard back about my most recent reply in a bit... so now that these forums are open and Slysoft representatives post here I figured I'd try here; perhaps also see if anyone else has experienced this.

    Basically, the problem is this: I'm encoding files for my iPod video (late 2006 model), or what CloneDVD mobile refers to as "5. gen (hires)". Originally, I was encoding the videos at the highest resolution (generally 640xsomething, depending on the original video's aspect ratio) and with the highest quality setting. I'm running the most recent versions of AnyDVD and CloneDVD mobile. I've tried encoding the video through various methods... straight from the original DVD... ripped to the hard drive, alternatively with CloneDVD and DVDShrink and then encoded... and every time, I had the same issue.

    Essentially, the encoding seems to cut off the first 0.5-1.5 seconds of the video... I haven't measured it precisely. I'm not even sure whether or not it occurs on every video that I encode, since some of them begin with enough of a black lead-in to make it impossible to tell. Also, sometimes when it does this and the video begins on an actual frame instead of just black, the first frame or two (literally only the very first frame or two) of the video has a slight pixelation which then immediately vanishes and the video plays normally.

    The real kicker is that I've since tried the same tests on my grandfather's computer (a newer system than mine), and the same thing occurs... so it's hard for me to believe it's an isolated problem with my system alone. I've also done a clean windows install in the time since first noticing the issue, and took advantage of that to re-test... and it still occurs.

    The last e-mail from Slysoft asked me to try encoding the videos with lower quality settings, which I did, and it still occured. I replied back to tell them this, but haven't heard back in about a week; so I decided to try here. Some of the titles I've noticed it on so far have been:

    "Jack-Jack Attack" (from 'The Incredibles' 2-disc set, region 1)
    "Crazy" music video (from Deluxe Ed. of 'St. Elsewhere' album)
    "Luxo Jr." (from 'Toy Story 2', region 1)

    As I've said, it may occur on everything and just be difficult to detect on many. I'm also not sure whether or not it occurs when encoding in other formats, for other types of devices than the iPod. Also, around half a second (or even a full second) isn't the kind of thing everyone would notice. However, it does seem to be happening. I'm hoping others will be able to post here if they've noticed this as well (or noticed it after reading this post). And perhaps Slysoft can come up with some kind of resolution.
  2. Scarpad

    Scarpad Well-Known Member

    Happens to me as well I do alot of TV DVD's and if the episodes star faitly quickly you'll get what appears to be a frozen pixelly frame and then the show starts. It does'nt happen on all encodes, but most of them.
  3. TM2-Megatron

    TM2-Megatron Well-Known Member

    It's good to know that I'm not the only person having this trouble, and that I'm not just going crazy.

    I hope someone from Slysoft has noticed this thread, and put this issue on the agenda to be dealt with.
  4. Matt

    Matt Well-Known Member

    Snap, I get that too.
  5. pawtracks

    pawtracks Member

    I see this same issue:

    Working right now on converting my season 1 Prison Break from DVD to iPod.
    -Ripped each episode using AnyDVD & DVD Shrink to a folder (Video_TS)
    -If I play the ripped episode it shows 100% of the file (just like on the DVD)

    When I shrink the file for my iPod using CloneDVD mobile it cuts off the first second (maybe even more) of each file

    Dvd file is nice looking, starts with a black screen
    CloneDVD mobile just jumps right in to a blurry image :mad:
    Hopefully this issue can be addressed.

    If the developer needs more data, please let us know how we can help.
  6. leigh

    leigh Member

    I do get that too..I have nothing worry about it
  7. TM2-Megatron

    TM2-Megatron Well-Known Member

    This is a pretty good result so far... if all of us have noticed this, the odds are the issue exists on most (if not all) systems, but most people simply haven't noticed it.

    Could anyone from Slysoft possibly post in this thread, and say whether there's been some investigation into this problem; or plans to look into it in the near future?
  8. pawtracks

    pawtracks Member

    I posted a tech support question about this last week and I DID get an email response from someone. He asked me what quality settings I was using. Before I responded I tried encoding the same original file 3 times using 3 different quality settings on 2 different computers.

    It didn't matter, all three cut off the same amount from the front end of the file.

    No other response from anyone yet. No official acknowledgement that the bug exists (from our posts here I would say it definitely does)

    I'm sure they are busy working on ANYDVD HD.
    Hopefully we will see some fixes soon 8)
  9. gianluca

    gianluca Active Member

    I see this problem as well.
    I use all the default quality settings, and the first 1/2 sec, or so, gets chopped off, and the first frame is always a badly pixellated.
  10. TM2-Megatron

    TM2-Megatron Well-Known Member

    Hopefully someone from Slysoft will post in here eventually, to at least let us know the issue is being looked into... perhaps after they're finished perfecting AnyDVD HD.

    It's good to know it isn't just a problem isolated to my own videos, though.
  11. gianluca

    gianluca Active Member

    Hmmmm... The more I look at this problem the more I think this is a bug in a the 3rd party software encoder (called mencoder.exe) that us ysed by CloneDVD Mobile, so I suspect this may take quite a while longer to fix.
    Just a thought.
  12. TM2-Megatron

    TM2-Megatron Well-Known Member

    That's definately a possibility, and in that case I'm not sure how it would ever be resolved. I suppose the developers of mencoder (the guys who do MPlayer, I think) would have to be the ones to fix the issue. It's odd that it hasn't been noticed before, though.
  13. gianluca

    gianluca Active Member

    I'm resurrecting this thread to show just how old this problem is.
    Is there anyone from SlySoft that posts on these forums and can give us an answer?
    Thank you,
  14. TM2-Megatron

    TM2-Megatron Well-Known Member

    Yes indeed. It's unfortunate that this is still an issue. Of all SlySoft's products, CloneDVD mobile is the most neglected; and the only example of somewhat lacking customer support on their part.

    I can understand why it wouldn't be a priority at the moment, with the new AACS key almost totally cracked, and BD+ on the horizen. However it's been a pretty long time since I first made this post. It would be nice if someone from Slysoft could post in here and let us know of any possible future updates to address this issue, as well as adding things like H.264 support for iPods and profiles for the newest iPod line.
  15. Webslinger

    Webslinger Retired Moderator

    Slysoft representatives do not read every single thread on the forums.

    Perhaps you should send Slysoft another email and ask for an update to your question.

    Unfortunately, while I bought Clonedvd mobile, it's a program I rarely use, as I do not enjoy watching movies on portable devices (I suppose my 17" widescreen laptop is one exception, but that doesn't really qualify). I apologize for not being able to assist further.
  16. gianluca

    gianluca Active Member

    I sent a message to SlySoft last week.
    A tech support person answered and asked me for specific log file, which I provided to them. I haven't got an answer back yet.
    I'll let you know what happens.

    Funny thing is that he asked me for an AnyDVD log file, and not a CloneDVDmobile log file.
  17. gianluca

    gianluca Active Member

    Got this reply from SlySoft tech support:
    And this was my reply to them:
    And then this additional reply (always from me to them):
    I'll keep you posted on what happens.
    Last edited: Nov 10, 2007
  18. TM2-Megatron

    TM2-Megatron Well-Known Member

    I never got anywhere when I was communicating with Slysoft about this issue back before I even started this thread... CloneDVD mobile seems to be the poor cousin of Slysoft's products, lol.

    And yeah, I never believed this problem to be caused by AnyDVD. When I first encountered the issue, I tested it in various ways. One involved ripping the desired VOB to my HD using DVDShrink (w/ AnyDVD disabled from the beginning), and encoding with CloneDVD mobile from there... and the problem persisted.

    If the issue is with the encoding, then, there might not be much Slysoft can do other than to completely rebuild the program around a different encoder. Currently, I believe it uses mencoder, which is your basic free command line thing released under the GNU General Public License. I suppose, though, if mencoder had such a serious flaw, there'd be complaints among users of the many other programs that use implementations of it as well. Since that's clearly not happening, perhaps there's something quirky in the specific way it's implemented in CloneDVD mobile. Or maybe the issue has been resolved in a later version of mencoder that has yet to be incorporated into CloneDVD mobile.

    Whatever the issue, clearly more work on this has to be done. As I've said before, I wish someone from Slysoft like Peer or somebody would post in this topic, and perhaps try to communicate with the people supposed to be working on this in person; because our e-mails clearly aren't making an impression.
    Last edited: Nov 10, 2007
  19. Webslinger

    Webslinger Retired Moderator

    I am sympathetic to your complaints, and I wish there were something I could do to help. But unfortunately, I'm not a developer (nor do I work for the Slysoft support team). There's not much I can do. I'm just a mod.
  20. gianluca

    gianluca Active Member

    :) I've run a few tests and I discovered more information, which I passed to SlySoft's support. Let's see if it helps them fixing this bug.
    Here's the latest message I sent: