dvd burner runs slow

Discussion in 'CD/DVD/BD Drives' started by rrguy04, Mar 7, 2007.

  1. rrguy04

    rrguy04 Member

    I got a samsung sh-s182 dvd burner around x-mas and it works and makes great copies but it takes about an hour and a half. Any suggestions??
     
  2. jvc

    jvc Well-Known Member

    Many times, slow burning is caused by the rom and/or burning drives, being in PIO mode, instead of DMA mode. Try this:
    To ensure your drives are operating in DMA mode: (1) Control Panel, (2) System, (3) Goto the Hardware Tab, (4) Device Manager, (5) IDE ATA/ATAPI Controllers, (6) Right Click on Primary IDE Channel --> Properties, (7) Goto the Advanced Settings Tab, Make sure both drop down boxes say 'DMA if Available', Click OK,(8) Right Click on Seconady IDE Channel --> Properties, (9) Goto the Advanced Settings Tab, Make sure both drop down boxes say 'DMA if Available', Click OK, (10) Reboot.
    Good luck!
     
  3. rrguy04

    rrguy04 Member

    I tried that and i dont have anything that says secondary IDE channel. The primary checks out ok though.
     
  4. TPLAT

    TPLAT Well-Known Member

    In the IDE channels check and see if any say PIO mode in the current transfer mode box, if one does then thats the one you need to uninstall then restart your pc and Windows will recognise it as new hardware and reinstall the drivers for it.
     
  5. rrguy04

    rrguy04 Member

    in the primary ide channels properties, the first box says device 0- transfer mode, DMA if available and current transfer mode-ultra DMA 2. The second box, device 1, says transfer mode-DMA if available and current transfer mode says PIO mode, but its all under Primary ide channel. so should i uninstall th primary and restart????
     
  6. TPLAT

    TPLAT Well-Known Member



    Yes uninstall the one that say PIO mode, having a drive in PIO can cause really slow read speed and burn speed along with some other problems.
     
  7. mike20021969

    mike20021969 Well-Known Member

    what is DMA anyway? (my setting is for DMA without having to change any settings).
    i have a top spec laptop and dont have any problems burning dvd's (+ or -).
    it seems that most people who have problems burning dvd's are using desktop pc's???or am i wrong?
     
  8. oldjoe

    oldjoe Well-Known Member

    DMA (Direct memory access) mode is a high performance mode for transferring data to and from devices, in particular, to CD and DVD burner devices.
    By default, PC's are set to DMA Mode.....that's why you never had to change any settings. A PC can change to PIO Mode when there is a problem or error on that IDE Channel and that happens more frequently with DVD burning.
    The reason you see the most problems with DMA-PIO Mode on desktop PC's is because there are far more people using them than Laptops.
     
  9. oldjoe

    oldjoe Well-Known Member

    0 is the Primary and 1 is the Secondary.
     
  10. oldjoe

    oldjoe Well-Known Member

    What software are you using and what media?
     
  11. rrguy04

    rrguy04 Member

    I uninstalled it and restarrted, i then went in and changed both of those drop sown boxes under transfer mode to DMA if available but where it says current transfer mode they both say PIO mode now and there is no drop down arrow to change this. Can you change this or is it automaticaly set by the computer?
     
  12. rrguy04

    rrguy04 Member

    The software im using is anydvd and clonedvd2. As far as the media, if you mean the discs im using they are compusa dvd+r.
     
  13. oldjoe

    oldjoe Well-Known Member

    Try some better media (discs). What are the specs on your PC? Processor & RAM(Memory) It could be that your system is the problem. Also, what applications (Programs) are running while you are burning?
     
    Last edited: Mar 9, 2007
  14. rrguy04

    rrguy04 Member

    My pc is a newer Dell dimension 8400 it has 1gb of ram and a Pentium(R) 4 cpu with a 140 gig harddrive with about 85% free space. I generally try not to run any other applications when im burning.
     
  15. McstylisT

    McstylisT Member

    Make sure you are using a 80/40 pin IDE cable. Although the sammy only runs in UDMA2 i think its still a important component.

    Regarding your DMA - If you are unable to reset and activate it then you dont have the drivers installed. My setup i built came with a cd for the motherboard and i had to install IDE and SATA nforce4 drivers to allow the motherboard to operate my devices. But might not be relevant to yours.


    Hope you get this sorted soon. :D
     
  16. rrguy04

    rrguy04 Member

    i was looking online and found some info that said certain Dell models came from the factory with PIO as default for the secondary drive, whichis my problem right now, it says you have to go into BIOS to set for DMA. How do i get into BIOS to fix this?
     
  17. oldjoe

    oldjoe Well-Known Member

    To get into the BIOS..shut down your PC. Push the "Power" button to boot it. while it is trying to boot, press the "Delete" key repeatedly and the BIOS will come up. I don't know what to tell you from there because I don't know what Motherboard the PC has (Most likely a proprietary Intel)or what BIOS Revison it has.
    If you are comfortable working in the Registry, this will also work:
    If you are not familiar with Registry Editing. LEAVE IT ALONE!

    Run REGEDIT. Go to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

    It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. You have to go through these subkeys and check the DriverDesc value until you find the proper IDE channel.

    Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

    Note that many CD and DVD drives only use UDMA-2, because their data rate is much lower than that of a hard disk. This is normal and no reason to worry.

    You can empty the content of these values. But you can also delete the values entirely. Windows will automatically recreate them anyway, with new content.

    Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).
     
  18. oldjoe

    oldjoe Well-Known Member

    IDE cables are either 40 or 80 pin... Perhaps that is what you were referring to? 40 pin requires the jumpers to be set on Primary(Master) and Secondary(Slave) 80 wire cables add the use of CS(Cable Select) and are color coded for connection. Blue=Motherboard..Black=Primary...Gray=Secondary.
     
  19. TPLAT

    TPLAT Well-Known Member

    If your pc is still under warrenty I would contact Dell tech support for going into the BIOS.
     
  20. rrguy04

    rrguy04 Member

    It works ok now, from what i read online it sounds like Dell doesnt like you to have two drives so i unhooked the one that came with it and am only using the samsung, 18 minutes to make a backup now! Thank you to everyone who helped me.