Dumping & Downgrading firmware on UHD Friendly Devices.

Discussion in 'CD/DVD/BD Drives' started by TeddyRaspin, Feb 4, 2018.

  1. hendra

    hendra New Member

    Hi, I've following this thread a couple days. I'm trying to make lg BU40N/Buffalo uhd friendly and i'm trying to see if anyone has succesfully convert it.
    I saw and tried the test.bin from here and tried eeprom_Data_mover but no luck. i upload the dump file from dosflash, if teddyraspin can help me. thanks
     

    Attached Files:

  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    No he can't, as has been stated a few times now. He no longer modifies firmwares. You either need to use the guide, out hope someone else will do it for you.

    Sent from my Nexus 6P with Tapatalk
     
  3. theosch

    theosch Well-Known Member

    Well I've enough time, I don't have to work.
    It hurts myself denying help to other person who's probably totally lost in technical issues, when I can.
    It's probably also to feel "needed", I tried not to answer any request, but couldn't resist.

    But I'm pretty sure if I'd get dozens help request all the time and you had helped them for free, I'd feel stressed and utilized, too.

    Mattering the uploads, I'll delete those, or have them deleted no problem.
    If the people, I uploaded the firmware don't check the forum regulary it can't be so important.
    OK last help dump was just around 18 h ago ;)
    If he doesn respond in a week I'll delete it. Maybe on vacation for now, or got frustrated cause didn't get help at once, and couldn't help himself for now.

    A reason was that I wanted s.o. to test if his WH16NS60->BH16NS55 with your hexrange and with "dd" hexediting method works with UHD ripping.
    (But afaik you tested UHD ripping already succesfully with WH16NS60->BH16NS55 via the hexeditor-method.)
    The negative side effect is, that more and more people think they can always come, just not to spend a few hours/max a couple of days themselves for making firmware backups +modding.

    Some people used the EEPROM data mover method for modding, also for official WH16NS60 UHD drive <=but here it gives different/strange/unusual result, some report here UHD to not work with some specific ripping software, but with a competitive copy software.

    So I'd expect, it's because it was not done with the other hexrange from Teddy's navigating UHD official/real drive-to-UHD-friedly drive conversion, but not sure.
    --

    Yes. Sry I know you're right. It's frustrating to see, that quite some few people are just too foul to read your guide.

    Maybe there are some that have just too few basic knowledge, have too few trust in themselves, and don't want to send back a bricked device in case.
    --
    There are also many that profit from your guideline, some of them perhaps not mentioning it in the forum.

    And some people brick their device. But if they can't follow your instructions and they are too impatient, I wouldn't have bad conscience about it :)
    Then they'll have to wait a few months, maybe tourist will have an emergency rescue firmware in some time from other unit, working.
    The bad thing is those people will perhaps RMA it, and it's known some online shops resell those devices without testing and repairing from manufacturer.

    I'm not really the cleverest person, if even I can follow your tutorial, then most others also can.
     
    Last edited: Aug 9, 2018
  4. Don Tong

    Don Tong New Member

    hi,
    I am really new to the UHD ripping, I got a LG BE16NU50 and its have firmware v1.02, so I try to downgrade it to v1.01. I made a dump by dosflash, follow the instructions in this page to make a new firmware from a untouch v1.01, and I flash it again with success. The drive show v1.01 in anydvd, and UHD disk ( plant earth II )show up in the file explorer. But when I try to rip it to ISO or file, it will have read error in the middle of the process, and make it not possible to make a iso or copy the folder of the UHD, when I try to play it directly form the disc, it will skipping frame and not reading well too. I try to rip a Blu-ray disc and everything work fine.
    I am doing anything wrong in the flashing process? Someone can help me to check if my firmware have anything wrong? I will try with another UHD disc, just want someone to make sure my firmware is good to go, thanks a lot.
     

    Attached Files:

  5. Foppa21

    Foppa21 Well-Known Member

    Hi Teddy,

    I finally got access to an old PC and was able to download the firmware.
    Could you please modify the firmware (BH16NS55) here?

    many, many thx in advance,
    Foppa
     

    Attached Files:

  6. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    No he can't. See post 442

    Sent from my Nexus 6P with Tapatalk
     
  7. kufo

    kufo Well-Known Member

    If you download the requiered flash tools, a clean 1.02 FW is included. ( As far as i know )
    Look at the atached file form the german forum.
     

    Attached Files:

  8. Rayians

    Rayians New Member

    I completed the steps to dump the firmware using DOS method. I am not comfortable with hex editing so I prefer to use the automatic method of importing data. I open EEPROM Data Mover, select my dumped file, then clean NS 50 compatible firmwares.7z file noted in first post, and get an error "Incorrect file size". Anyone have any ideas as to what Im doing wrong?
     
    Last edited: Sep 11, 2018
  9. Terramex

    Terramex Well-Known Member

    First you have to extract the clean bin-firmwares from the 7z with WinRAR, 7Zip, etc.
    Then at step 2. of the EEPROM Data Mover select the clean firmware you want.
     
    kufo likes this.
  10. Rayians

    Rayians New Member

    Thank you for the reply, Terramex. Process completed, I now own a WH16NS40 with 1.02 firmware!
     
  11. gumby1974

    gumby1974 Member

    Hi all,

    I only have laptops (no desktop) and connect to the Asus BC-12D2HT drive (running, unfortunately 3.01) via USB3. Are there any options in my case or must you actually have a SATA connection?
    I have tried DOSFLASH booted via USB-stick and it reports no ATAPI devices, and flasher.exe finds the drive Ok but will not read from it or flash it.

    thanks.
     
  12. kostas

    kostas New Member

    Thanks very much TeddyRaspin. I was able to flash my LG.

    If only something could be done about the crippling DRM in PowerDVD as well.. The stupid requirement to prevent mouse operations during playback somehow means I can't even operate PDVD's own menus. Wow. One of many problems of course. Anyway, thanks! :)
     
  13. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    No mouse operations has nothing to do with drm. That's just how the disc was authored. You don't have a mouse with standalone players do you? In most cases discs are played on a standalone player, and those don't have a mouse

    Sent from my Nexus 7 with Tapatalk
     
  14. kostas

    kostas New Member

    Hmm. Every single DVD I've ever tried supported the mouse just fine. Not a single BD I've ever tried supported the mouse. If this was up to the authors all along, I'd expect some randomness. Regardless, trying to play Jason Bourne UHD with PDVD 18 Ultra (latest), I couldn't even click any of the buttons in the "Mouse is not supported... blah, OK, Cancel" dialog, or any other button/icon in PDVD for that matter (except for the timeline..). If I lucked out and the dialog got the keyboard focus, I could dismiss, but not always.

    Oh well, the lack of support for Nvidia (etc) cards caused me even worse problems. I'm thinking I'll park the whole thing until the next major development.
     
  15. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Perhaps, but you're comparing 2 completely different disc types. The discs are different, the file structure is different, the authoring of them is different.

    Like buying a Ford stationwagon and expecting it to go 300mph like a Maserati or something because hey, they both have 4 wheels and a steering wheel. You can't do that either, one's a city car, the other's a sportscar.

    Verstuurd vanaf mijn Nexus 6P met Tapatalk
     
  16. gumby1974

    gumby1974 Member

    So it seems that if you have a laptop and connect to the drive via USB instead of SATA, you're basically out of luck, correct?
     
  17. berni2k

    berni2k New Member

    hi,
    do I have to unplug my other sata device (ssd) before I boot from usb-stick and run dosflash?
     
  18. berni2k

    berni2k New Member

    according to other posts here in the forum you'll have to open it and unplug the sata to usb adapter then connect it directly via sata, but it should work.
     
  19. teufel82

    teufel82 New Member

    I bought a BW-16D1HT with F/W 1.01. must i upgrade to 3.02 and then downgrade to 3.01 or can i modify this F/W direct?
     
  20. kufo

    kufo Well-Known Member

    @teufel82
    If you want to use this drive for normal BD reading, you'll have to do nothing. UHD reading will not work , because the FW/drive is too old. 1.01 should be a drive that's about 4 years old and known as NS40.
    No chance for UHD reading with this drive :(
     
    Last edited: Oct 1, 2018